summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2019-05-29 14:22:54 +0200
committerThéo Le Calvar2019-05-29 14:22:54 +0200
commit177b719b1dbd69295c23cd4809a3304d09fdc576 (patch)
tree227c6e747dd0cd16893513419142fa816dea088c
parent83d39722b20aee46002f23b332d9c87af78457f7 (diff)
downloadaur-177b719b1dbd69295c23cd4809a3304d09fdc576.tar.gz
change Qt4 dependency to Qt5
fix permissions warning on /usr/, /usr/share and /usr/share/doc folders
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 990618d3a68e..1a52ea1451f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Jan 7 10:24:48 UTC 2019
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
pkgver = 11.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
arch = x86_64
@@ -13,9 +11,12 @@ pkgbase = decklink
depends = libxml2
depends = libpng12
depends = glu
- depends = qt4
+ depends = qt5-base
+ depends = qt5-svg
options = !strip
options = staticlibs
+ source = decklink-11.1.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/bdb0c72cc1af4bf2ac790957c8e5db12
+ sha256sums = a3123bfc5d310ee1b221e49ac4fbe25b8d1006fc29973b27507d47b6659543ee
pkgname = decklink
diff --git a/PKGBUILD b/PKGBUILD
index e259a0d63cd0..c007ea7387d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainers: Perry Hung <perry@leaflabs.com> Florent Thiery <fthiery@gmail.com> Théo Le Calvar <tlc@kher.nl>
pkgname=decklink
pkgver=11.1
-pkgrel=1
+pkgrel=2
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
url="https://www.blackmagicdesign.com/support/family/capture-and-playback"
license=('custom')
makedepends=('curl')
-depends=('linux-headers' 'libxml2' 'libpng12' 'glu' 'qt4')
+depends=('linux-headers' 'libxml2' 'libpng12' 'glu' 'qt5-base' 'qt5-svg')
options=('!strip' 'staticlibs')
[ "$CARCH" = "i686" ] && _arch='i386'
@@ -44,5 +44,9 @@ package() {
tar xf mediaexpress-*-${_arch}.tar.gz
cp -a mediaexpress-*-${_arch}/* $pkgdir
+
+ chmod 755 "$pkgdir/usr"
+ chmod 755 "$pkgdir/usr/share"
+ chmod 755 "$pkgdir/usr/share/doc"
}