summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-08 14:10:35 -1000
committerGaetan Bisson2015-06-08 14:10:35 -1000
commita3db4eb1742c764a89ae324187cf5e979ec35f28 (patch)
treed6fd7d174d66a538a27a8de77a4cc406a1535955
downloadaur-a3db4eb1742c764a89ae324187cf5e979ec35f28.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85dcd5d2556c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = decox
+ pkgdesc = Decreasing continuous exponentials; toy decompression planner
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://fenua.org/gaetan/src/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = ISC
+ source = http://fenua.org/gaetan/src//decox-1.1.c
+ sha1sums = db51af48d937d36708a7783129cb5cfd626e1111
+
+pkgname = decox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c219f1f3fd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=decox
+pkgver=1.1
+pkgrel=1
+pkgdesc='Decreasing continuous exponentials; toy decompression planner'
+url='http://fenua.org/gaetan/src/'
+license=('ISC')
+arch=('i686' 'x86_64' 'armv7h')
+source=("${url}/${pkgname}-${pkgver}.c")
+sha1sums=('db51af48d937d36708a7783129cb5cfd626e1111')
+
+build() {
+ cd "${srcdir}"
+ cc -lm \
+ ${CFLAGS} ${LDFLAGS} \
+ -o ${pkgname} ${pkgname}-${pkgver}.c
+}
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ head -n 15 "${pkgname}-${pkgver}.c" > "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}