summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsuthernfriend2018-12-04 00:46:53 +0200
committersuthernfriend2018-12-04 00:46:53 +0200
commitb72a75c52fc7bdfdd2f331168e12beddea502d0d (patch)
tree3fe75a66d58314895937a0121f350834c9f20f7a
downloadaur-b72a75c52fc7bdfdd2f331168e12beddea502d0d.tar.gz
created package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6abfe2a529b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = decpwd-git
+ pkgdesc = Very simple password manager to use over ssh
+ pkgver = r7.21b5f75
+ pkgrel = 1
+ url = https://github.com/suthernfriend/decpwd
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = qt5-base
+ provides = decpwd
+ conflicts = decpwd
+ source = git+https://github.com/suthernfriend/decpwd.git
+ md5sums = SKIP
+
+pkgname = decpwd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01e6e6af6f87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jan Peter Koenig <public@janpeterkoenig.com>
+pkgname=decpwd-git
+pkgver=r7.21b5f75
+pkgrel=1
+pkgdesc="Very simple password manager to use over ssh"
+arch=("x86_64")
+url="https://github.com/suthernfriend/decpwd"
+license=('MIT')
+depends=('qt5-base')
+makedepends=('git')
+provides=("decpwd")
+conflicts=("decpwd")
+source=('git+https://github.com/suthernfriend/decpwd.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/decpwd"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/decpwd"
+ qmake -o ./build/Makefile
+ cd "./build"
+ make
+}
+
+package() {
+ cd "$srcdir/decpwd/build"
+ install -Dm 755 "decpwd" "$pkgdir/usr/bin/decpwd"
+}