summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Jordan2019-12-29 18:08:14 +0000
committerAntony Jordan2019-12-29 18:08:14 +0000
commitfa06988df2f8764e25c41b2f802899fbf19acdc2 (patch)
tree9dacb28c9dca04903200e1e4f0e26a1784b44f03
downloadaur-fa06988df2f8764e25c41b2f802899fbf19acdc2.tar.gz
Initial release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fa71749da43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = deembed
+ pkgdesc = TouchStone file viewer (smith, Db, phase, magnitude, VSWR, polar).
+ pkgver = 1.6
+ pkgrel = 1
+ url = https://github.com/fransschreuder/DeEmbed
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-base
+ depends = qt5-svg
+ source = deembed-1.6.tar.gz::https://github.com/fransschreuder/DeEmbed/archive/1.6.tar.gz
+ md5sums = 07ef6bb67eb2318a6cdc1152a65cea79
+
+pkgname = deembed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff943e196ea9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Antony Jordan <antony.r.jorda at gmail dot com>
+pkgname=deembed
+pkgver=1.6
+pkgrel=1
+pkgdesc="TouchStone file viewer (smith, Db, phase, magnitude, VSWR, polar)."
+arch=(x86_64)
+url="https://github.com/fransschreuder/DeEmbed"
+license=('GPL3')
+depends=(qt5-svg)
+makedepends=(qt5-base)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fransschreuder/DeEmbed/archive/$pkgver.tar.gz")
+md5sums=("07ef6bb67eb2318a6cdc1152a65cea79")
+
+prepare() {
+ mkdir "DeEmbed-$pkgver/build"
+ cd "DeEmbed-$pkgver/build"
+ qmake ..
+}
+
+build() {
+ cd "DeEmbed-$pkgver/build"
+ make
+}
+
+package() {
+ cd "DeEmbed-$pkgver/build"
+ make INSTALL_ROOT="$pkgdir/" install
+}
+