summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2020-11-19 12:51:20 +0500
committerVyacheslav Konovalov2020-11-19 12:51:20 +0500
commit59c81eb99e6c62febd515519cab43f5bcc6cfd11 (patch)
treebf92894681a4f1d96ef37deccf2477799b6f0e6a
parent3c1ebf1e5b51c2821a5c2c7c0c59fcd12ac44226 (diff)
downloadaur-59c81eb99e6c62febd515519cab43f5bcc6cfd11.tar.gz
Fix python-dnspython version, change source to pypi.org
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceccf8ff6c06..d317e3c986c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deemix
pkgdesc = A barebone deezer downloader library
pkgver = 1.5.20
- pkgrel = 1
+ pkgrel = 2
url = https://t.me/deemixcommunity
arch = any
license = GPL3
@@ -12,9 +12,9 @@ pkgbase = deemix
depends = python-mutagen
depends = python-spotipy
depends = python-eventlet
- depends = python-dnspython<2.0.0
- source = https://notabug.org/RemixDev/deemix/archive/13f6eab17231b99abe33ff37cd309545f01729a9.tar.gz
- sha256sums = 789fa6a825716d0daef294fa1f70d0f992ec9b13817d4e3e0b81d60a9cd2e47b
+ depends = python-dnspython
+ source = https://files.pythonhosted.org/packages/a9/59/07c16836f593a0993f725ab9230a2af43599935ad1151c45229fcfdc90f3/deemix-1.5.20.tar.gz
+ sha256sums = a6c9a330e62d37b78bf7411089a63facbafc19ac3c7fb5634c03896d5c3db6fd
pkgname = deemix
diff --git a/PKGBUILD b/PKGBUILD
index 2f6355388038..0902ce1404ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Vyacheslav Konovalov <vyachkonovalov@protonmail.com>
-_commit=13f6eab17231b99abe33ff37cd309545f01729a9
+_path=a9/59/07c16836f593a0993f725ab9230a2af43599935ad1151c45229fcfdc90f3
pkgname=deemix
pkgver=1.5.20
-pkgrel=1
+pkgrel=2
pkgdesc='A barebone deezer downloader library'
arch=(any)
url='https://t.me/deemixcommunity'
license=('GPL3')
depends=('python>=3.6' 'python-click' 'python-pycryptodomex' 'python-mutagen' 'python-spotipy'
- 'python-eventlet' 'python-dnspython<2.0.0')
+ 'python-eventlet' 'python-dnspython')
makedepends=('python-setuptools')
-source=("https://notabug.org/RemixDev/deemix/archive/$_commit.tar.gz")
-sha256sums=('789fa6a825716d0daef294fa1f70d0f992ec9b13817d4e3e0b81d60a9cd2e47b')
+source=("https://files.pythonhosted.org/packages/$_path/deemix-$pkgver.tar.gz")
+sha256sums=('a6c9a330e62d37b78bf7411089a63facbafc19ac3c7fb5634c03896d5c3db6fd')
pkgver() {
- cd deemix
+ cd deemix-$pkgver
sed -En 's/^__version__ = "([0-9\.]+)"$/\1/p' deemix/__init__.py | tr -d '\n'
}
build() {
- cd deemix
+ cd deemix-$pkgver
python setup.py build
}
package() {
- cd deemix
+ cd deemix-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
}