summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2020-05-27 22:14:28 +0500
committerVyacheslav Konovalov2020-05-27 22:14:28 +0500
commit9420b489dfbedf6173ee95618d08e23bc4ffa88e (patch)
treec4cded7580f9cccd98c948e04e9a30c4f3613e3c
downloadaur-9420b489dfbedf6173ee95618d08e23bc4ffa88e.tar.gz
version 1.0.4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cff27e838a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = deemix
+ pkgdesc = A barebone deezer downloader library
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://deemix.app/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python>=3.6
+ depends = python-click
+ depends = python-pycryptodomex
+ depends = python-mutagen
+ depends = python-spotipy
+ source = https://notabug.org/RemixDev/deemix/archive/47f728e172e3a69e324173acebaad4f7f438b7a2.tar.gz
+ sha256sums = 0316424e5fe844877312ff1170a2a015872d1b9cb8281938aac086c86dd5b7c9
+
+pkgname = deemix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c34a22c4a70d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vyacheslav Konovalov <vyachkonovalov@protonmail.com>
+
+_commit=47f728e172e3a69e324173acebaad4f7f438b7a2
+pkgname=deemix
+pkgver=1.0.4
+pkgrel=1
+pkgdesc='A barebone deezer downloader library'
+arch=(any)
+url='https://deemix.app/'
+license=('GPL3')
+depends=('python>=3.6' 'python-click' 'python-pycryptodomex' 'python-mutagen' 'python-spotipy')
+makedepends=('python-setuptools')
+source=("https://notabug.org/RemixDev/deemix/archive/$_commit.tar.gz")
+sha256sums=('0316424e5fe844877312ff1170a2a015872d1b9cb8281938aac086c86dd5b7c9')
+
+build() {
+ cd deemix
+ python setup.py build
+}
+
+package() {
+ cd deemix
+ python setup.py install --root="$pkgdir" --optimize=1
+}