summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Tas2020-05-28 14:19:06 +0200
committerSimon Tas2020-05-28 14:19:06 +0200
commit209e607b0857d669f6447f51bffd61b5266bfcfa (patch)
treef37b671782dfb5bd736c5daeacdc883915d72c63
downloadaur-209e607b0857d669f6447f51bffd61b5266bfcfa.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04b3f2abe117
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = deemix-git
+ pkgdesc = a deezer downloader built from the ashes of Deezloader Remix.
+ pkgver = r250.47f728e
+ pkgrel = 1
+ url = https://notabug.org/RemixDev/deemix
+ arch = any
+ license = gpl3
+ depends = python>=3.6
+ depends = python-click
+ depends = python-pycryptodomex
+ depends = python-mutagen
+ depends = python-requests
+ depends = python-spotipy
+ provides = deemix
+ source = deemix::git+https://notabug.org/RemixDev/deemix
+ md5sums = SKIP
+
+pkgname = deemix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beb02e0611aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Simon Tas <simon.tas.st@gmail.com>
+
+pkgname="deemix-git"
+_pkgname="deemix"
+pkgver=r250.47f728e
+pkgrel=1
+pkgdesc="a deezer downloader built from the ashes of Deezloader Remix."
+arch=('any')
+url="https://notabug.org/RemixDev/$_pkgname"
+license=('gpl3')
+depends=('python>=3.6' 'python-click' 'python-pycryptodomex' 'python-mutagen' 'python-requests' 'python-spotipy')
+provides=('deemix')
+source=("${_pkgname}::git+https://notabug.org/RemixDev/$_pkgname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+