summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Wirch2017-07-14 10:11:08 +0200
committerEduard Wirch2017-07-14 10:13:21 +0200
commit72dc9e219e6c8574d8a9c12c1f58f8fd21416aec (patch)
tree67b4fc0c66b8e1478d4c1fc7194af2495162bb86
downloadaur-72dc9e219e6c8574d8a9c12c1f58f8fd21416aec.tar.gz
Initial add. Version 3.preview.1-1
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD57
-rw-r--r--deepgit.desktop14
-rw-r--r--deepgit.sh.patch87
5 files changed, 179 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e45dbe799e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = deepgit-preview
+ pkgdesc = A tool to investigate the history of source code. This is preview software intended to provide you with an opportunity to test-drive new builds of the next DeepGit release.
+ pkgver = 3.preview.1
+ pkgrel = 1
+ url = http://www.syntevo.com/deepgit/preview
+ arch = any
+ license = custom
+ depends = java-environment>=8
+ depends = hicolor-icon-theme
+ depends = bash
+ conflicts = deepgit
+ source = http://www.syntevo.com/static/smart/download/deepgit/deepgit-linux-3-preview-1.tar.gz
+ source = deepgit.desktop
+ source = deepgit.sh.patch
+ sha1sums = a2fd88b334e3ac50305b4bba68efd3c786b1fc10
+ sha1sums = 8ab2e36b3cb2e6f7b5af70a4ddbe2e9d307d3988
+ sha1sums = 01b2845c29b507d011ac251625a746b7bd03b11f
+
+pkgname = deepgit-preview
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2b2e89f7873
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Eduard Wirch <wirch.eduard@gmail.com>
+pkgname=deepgit-preview
+pkgver=3.preview.1
+pkgrel=1
+pkgdesc="A tool to investigate the history of source code. This is preview software intended to provide you with an opportunity to test-drive new builds of the next DeepGit release."
+arch=('any')
+url="http://www.syntevo.com/deepgit/preview"
+license=('custom')
+depends=(
+ 'java-environment>=8'
+ 'hicolor-icon-theme'
+ 'bash'
+)
+conflicts=('deepgit')
+
+source=(
+ "http://www.syntevo.com/static/smart/download/deepgit/deepgit-linux-${pkgver//./-}.tar.gz"
+ "deepgit.desktop"
+ "deepgit.sh.patch"
+)
+sha1sums=('a2fd88b334e3ac50305b4bba68efd3c786b1fc10'
+ '8ab2e36b3cb2e6f7b5af70a4ddbe2e9d307d3988'
+ '01b2845c29b507d011ac251625a746b7bd03b11f')
+
+prepare() {
+ patch -uN "$srcdir/deepgit/bin/deepgit.sh" "$srcdir/deepgit.sh.patch"
+}
+
+package() {
+ cd $srcdir/deepgit
+
+ # Executable
+ install -T -Dm 755 bin/deepgit.sh "$pkgdir/usr/bin/deepgit"
+
+ # Runtime
+ install -m 644 -Dt "$pkgdir/usr/share/java/$pkgname/lib/" lib/*
+
+ # Settings
+ install -Dt "$pkgdir/etc/$pkgname/" bin/deepgit.vmoptions
+
+ # Copy license
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname/" license.html
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname/" licenses/*
+
+ # Desktop file
+ install -Dm 644 -t "$pkgdir/usr/share/applications/" "$srcdir/deepgit.desktop"
+
+ # Copy other stuff to /usr/share/$pkgname/
+ install -m 644 -Dt "$pkgdir/usr/share/$pkgname" changelog.txt known-issues.txt readme-linux.txt
+
+ # Install some icons
+ cd "$srcdir/deepgit/bin"
+ for size in 32 48 64 128 256
+ do
+ install -Dm 644 -T deepgit-$size.png "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/deepgit.png"
+ done
+}
diff --git a/deepgit.desktop b/deepgit.desktop
new file mode 100644
index 000000000000..e4485a6b43c9
--- /dev/null
+++ b/deepgit.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=DeepGit
+Keywords=git;hg;svn;mercurial;subversion
+GenericName=Git&Hg-Client + SVN-support
+Type=Application
+Categories=Development;RevisionControl
+Terminal=false
+StartupNotify=true
+StartupWMClass=DeepGit
+Exec=/usr/bin/deepgit %u
+MimeType=x-scheme-handler/deepgit;x-scheme-handler/sourcetree;
+Icon=deepgit
diff --git a/deepgit.sh.patch b/deepgit.sh.patch
new file mode 100644
index 000000000000..a819646a0cec
--- /dev/null
+++ b/deepgit.sh.patch
@@ -0,0 +1,87 @@
+--- deepgit.orig/bin/deepgit.sh 2017-07-14 08:40:36.915613668 +0200
++++ deepgit.new/bin/deepgit.sh 2017-07-14 09:13:07.743455655 +0200
+@@ -45,57 +45,33 @@
+ ;;
+ esac
+
+-# Resolve the location of the DeepGit installation.
+-# This includes resolving any symlinks.
+-PRG=$0
+-while [ -h "$PRG" ]; do
+- ls=`ls -ld "$PRG"`
+- link=`expr "$ls" : '^.*-> \(.*\)$' 2>/dev/null`
+- if expr "$link" : '^/' 2> /dev/null >/dev/null; then
+- PRG="$link"
+- else
+- PRG="`dirname "$PRG"`/$link"
+- fi
+-done
+-
+-DEEPGIT_BIN=`dirname "$PRG"`
+-
+-# Absolutize dir
+-oldpwd=`pwd`
+-cd "${DEEPGIT_BIN}";
+-DEEPGIT_BIN=`pwd`
+-cd "${oldpwd}";
+-unset oldpwd
++DEEPGIT_HOME=/usr/share/java/deepgit-preview
+
+-DEEPGIT_HOME=`dirname "$DEEPGIT_BIN"`
+-
+-parseVmOptions $DEEPGIT_BIN/deepgit.vmoptions
++parseVmOptions /etc/deepgit-preview/deepgit.vmoptions
+ parseVmOptions ~/.deepgit/deepgit.vmoptions
+
+ # Determine Java Runtime
+ if [ "$DEEPGIT_JAVA_HOME" = "" ] ; then
+ DEEPGIT_JAVA_HOME=$DEEPGITHG_JAVA_HOME
+ fi
+-if [ "$DEEPGIT_JAVA_HOME" = "" ] && [ -f "/usr/lib/jvm/java-7-openjdk-i386/jre/bin/java" ] ; then
+- DEEPGIT_JAVA_HOME="/usr/lib/jvm/java-7-openjdk-i386/jre"
+-fi
+ if [ "$DEEPGIT_JAVA_HOME" = "" ] ; then
+- DEEPGIT_JAVA_HOME=$JAVA_HOME
++ _JAVA_EXEC=/usr/bin/java
++else
++ _JAVA_EXEC="java"
++ if [ "$DEEPGIT_JAVA_HOME" != "" ] ; then
++ _TMP="$DEEPGIT_JAVA_HOME/bin/java"
++ if [ -f "$_TMP" ] ; then
++ if [ -x "$_TMP" ] ; then
++ _JAVA_EXEC="$_TMP"
++ else
++ echo "Warning: $_TMP is not executable"
++ fi
++ else
++ echo "Warning: $_TMP does not exist"
++ fi
++ fi
+ fi
+
+-_JAVA_EXEC="java"
+-if [ "$DEEPGIT_JAVA_HOME" != "" ] ; then
+- _TMP="$DEEPGIT_JAVA_HOME/bin/java"
+- if [ -f "$_TMP" ] ; then
+- if [ -x "$_TMP" ] ; then
+- _JAVA_EXEC="$_TMP"
+- else
+- echo "Warning: $_TMP is not executable"
+- fi
+- else
+- echo "Warning: $_TMP does not exist"
+- fi
+-fi
+
+ if ! which "$_JAVA_EXEC" >/dev/null 2>&1 ; then
+ echo "Error: No java environment found (JRE 1.7 or higher required)."
+@@ -109,9 +85,6 @@
+ echoJreConfigurationAndExit
+ fi
+
+-# this seems necessary for Solaris to find the Cairo-library
+-export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib/gnome-private/lib
+-
+ if type "lsb_release" > /dev/null 2> /dev/null ; then
+ if [ "$XDG_CURRENT_DESKTOP" == "Unity" ] ; then
+ # work-around for https://bugs.eclipse.org/bugs/show_bug.cgi?id=419729