summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-02-25 13:44:08 +0800
committerjustforlxz2022-02-25 13:44:08 +0800
commit6f63fbe2430fa212cca0dbd0f2e68108c71dec31 (patch)
tree87a93f8e0a802f26bf619be444f0203bf674b2c0
parentbce78057dd711e6625be8bdcfd13ade5f61f2b4e (diff)
downloadaur-6f63fbe2430fa212cca0dbd0f2e68108c71dec31.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--remove-auth.patch90
3 files changed, 105 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e949faaa9b4..a5322204caef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = deepin-control-center-git
pkgdesc = New control center for linux deepin
- pkgver = 5.4.17.r110.gf1dbfc44e
+ pkgver = 5.4.47.r627.gb6848a8ac
pkgrel = 1
url = https://github.com/linuxdeepin/dde-control-center
- arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
@@ -25,7 +25,7 @@ pkgbase = deepin-control-center-git
makedepends = polkit-qt5
makedepends = deepin-pw-check-git
depends = dtkwidget-git
- depends = deepin-account-faces
+ depends = deepin-account-faces-git
depends = libpwquality
depends = startdde-git
depends = deepin-daemon-git
@@ -44,8 +44,10 @@ pkgbase = deepin-control-center-git
provides = deepin-control-center
conflicts = deepin-control-center
source = deepin-control-center-git::git://github.com/linuxdeepin/dde-control-center/
+ source = remove-auth.patch
source = deepin-control-center-systeminfo-deepin-icon.patch
sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = 74fd63391e923ca37f4559f30da967ba7f33d4426b60d58d1ece8cd9a154578e8184b1a376a8d7ff3ef81ffce530915f79d0845a2612ae4e06522b96855ab3dd
pkgname = deepin-control-center-git
diff --git a/PKGBUILD b/PKGBUILD
index bbbf1ea86daf..72e1d55d309b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=deepin-control-center-git
_pkgname=deepin-control-center
-pkgver=5.4.17.r110.gf1dbfc44e
+pkgver=5.4.47.r627.gb6848a8ac
pkgrel=1
pkgdesc='New control center for linux deepin'
-arch=('x86_64')
+arch=('aarch64')
url="https://github.com/linuxdeepin/dde-control-center"
license=('GPL3')
-depends=('dtkwidget-git' 'deepin-account-faces' 'libpwquality' 'startdde-git'
+depends=('dtkwidget-git' 'deepin-account-faces-git' 'libpwquality' 'startdde-git'
'deepin-daemon-git' 'startdde-git' 'networkmanager-qt'
'deepin-qt-dbus-factory-git' 'deepin-network-utils-git'
'deepin-pw-check-git')
@@ -25,8 +25,10 @@ conflicts=('deepin-control-center')
provides=('deepin-control-center')
groups=('deepin-git')
source=("$pkgname::git://github.com/linuxdeepin/dde-control-center/"
+ remove-auth.patch
$_pkgname-systeminfo-deepin-icon.patch)
sha512sums=('SKIP'
+ 'SKIP'
'74fd63391e923ca37f4559f30da967ba7f33d4426b60d58d1ece8cd9a154578e8184b1a376a8d7ff3ef81ffce530915f79d0845a2612ae4e06522b96855ab3dd')
pkgver() {
@@ -35,10 +37,14 @@ pkgver() {
}
prepare() {
+ rm $pkgname/src/frame/modules/authentication/widgets/faceinfowidget.h
+ rm $pkgname/src/frame/modules/authentication/widgets/faceinfowidget.cpp
+ rm -rf $pkgname/src/frame/window/modules/authentication
+
rm $pkgname/src/frame/window/icons/icons/dcc_nav_systeminfo_{42,84}px.svg
patch -d $pkgname -Np1 < $_pkgname-systeminfo-deepin-icon.patch
-
cd $pkgname
+ patch -p1 -i ../remove-auth.patch
# remove after they obey -DDISABLE_SYS_UPDATE properly
sed -i '/new UpdateModule/d' src/frame/window/mainwindow.cpp
diff --git a/remove-auth.patch b/remove-auth.patch
new file mode 100644
index 000000000000..68ae78b5f4f0
--- /dev/null
+++ b/remove-auth.patch
@@ -0,0 +1,90 @@
+diff -Nrup deepin-control-center-git.orig/src/frame/CMakeLists.txt deepin-control-center-git/src/frame/CMakeLists.txt
+--- deepin-control-center-git.orig/src/frame/CMakeLists.txt 2022-02-24 14:28:52.000000000 +0800
++++ deepin-control-center-git/src/frame/CMakeLists.txt 2022-02-24 14:30:05.000000000 +0800
+@@ -257,35 +257,6 @@ set(WIDGETS_FILES
+ set(MODULE_FILES
+ )
+
+-# load authentatication
+-set(AUTHENTICATION_FILES
+- modules/authentication/fingermodel.cpp
+- modules/authentication/fingerworker.cpp
+- modules/authentication/charamangermodel.cpp
+- modules/authentication/charamangerworker.cpp
+- modules/authentication/widgets/fingeritem.cpp
+- modules/authentication/widgets/disclaimersitem.cpp
+- modules/authentication/widgets/disclaimersdialog.cpp
+- modules/authentication/widgets/fingerwidget.cpp
+- modules/authentication/widgets/faceinfowidget.cpp
+- window/modules/authentication/loginoptionsmodule.cpp
+- window/modules/authentication/loginoptionswidget.cpp
+- window/modules/authentication/fingerwidget.cpp
+- window/modules/authentication/fingerdetailwidget.cpp
+- window/modules/authentication/addfingedialog.cpp
+- window/modules/authentication/faceiddetailwidget.cpp
+- window/modules/authentication/facewidget.cpp
+- window/modules/authentication/authenticationinfoitem.cpp
+- window/modules/authentication/addfaceinfodialog.cpp
+- window/modules/authentication/faceinfodialog.cpp
+- # IRIS
+- window/modules/authentication/irisdetailwidget.cpp
+- window/modules/authentication/iriswidget.cpp
+- window/modules/authentication/addirisinfodialog.cpp
+- modules/authentication/widgets/irisinfowidget.cpp
+- window/modules/authentication/fingedisclaimer.cpp
+-)
+-
+ # load accounts
+ set(ACCOUNTS_FILES
+ modules/accounts/creationresult.cpp
+@@ -514,7 +485,6 @@ set(SRCS
+ ${FRAME_FILES}
+ ${WINDOW_FILES}
+ ${INTERFACES_FILES}
+- ${AUTHENTICATION_FILES}
+ ${ACCOUNTS_FILES}
+ ${BLUETOOTH_FILES}
+ ${DATETIME_FILES}
+@@ -541,7 +511,6 @@ set(QRC
+ modules/datetime/timezone_dialog.qrc
+ modules/power/power.qrc
+ modules/systeminfo/systeminfo.qrc
+- modules/authentication/authentication.qrc
+ modules/accounts/accounts.qrc
+ modules/bluetooth/bluetooth.qrc
+ modules/defapp/defapp.qrc
+@@ -597,7 +566,6 @@ file(GLOB DCONFIG_FILES "../../configs/d
+ dconfig_meta_files(APPID dde-control-center BASE ../../configs FILES ${DCONFIG_FILES})
+
+ set(DEEPIN_PW_CHECK libdeepin_pw_check.so)
+-set(SHMN_VIDEO libdareader.so)
+
+ function(add_build_macro macro)
+ string(TOUPPER ${macro} macro)
+diff -Nrup deepin-control-center-git.orig/src/frame/window/mainwindow.cpp deepin-control-center-git/src/frame/window/mainwindow.cpp
+--- deepin-control-center-git.orig/src/frame/window/mainwindow.cpp 2022-02-24 14:28:51.000000000 +0800
++++ deepin-control-center-git/src/frame/window/mainwindow.cpp 2022-02-24 14:30:05.000000000 +0800
+@@ -18,7 +18,6 @@
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+-#include "modules/authentication/loginoptionsmodule.h"
+ #include "modules/accounts/accountsmodule.h"
+ #include "modules/bluetooth/bluetoothmodule.h"
+ #include "modules/commoninfo/commoninfomodule.h"
+@@ -312,7 +311,6 @@ void MainWindow::initAllModule(const QSt
+ return;
+
+ m_bInit = true;
+- using namespace authentication;
+ using namespace sync;
+ using namespace datetime;
+ using namespace defapp;
+@@ -332,7 +330,6 @@ void MainWindow::initAllModule(const QSt
+ using namespace notification;
+
+ m_modules = {
+- { new LoginOptionsModule(this), tr("Biometric Authentication")},
+ { new AccountsModule(this), tr("Accounts")},
+ //~ contents_path /cloudsync/Cloud Sync
+ { new SyncModule(this), DSysInfo::isCommunityEdition() ? "Deepin ID" : "Union ID"},