summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang, DingYuan2020-09-06 21:38:44 +0800
committerZhang, DingYuan2020-09-06 21:38:44 +0800
commitbd17e689ff01d9a589a1eb95576d28d24a2de3c8 (patch)
tree22abf1161f31a6107a57cf882d9ced7973d31990
parent4b39e1faefaa49e0609757c5ca17f93a5d7b3dd9 (diff)
downloadaur-bd17e689ff01d9a589a1eb95576d28d24a2de3c8.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
-rw-r--r--dde-daemon.patch49
3 files changed, 69 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f06476436a7..809cf011ee75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deepin-daemon-git
pkgdesc = Daemon handling the DDE session settings
- pkgver = 5.11.0.19.r27.g34e54761
+ pkgver = 5.11.0.47.r1.gf4c781cb
pkgrel = 1
url = https://github.com/linuxdeepin/dde-daemon
install = deepin-daemon-git.install
@@ -47,11 +47,11 @@ pkgbase = deepin-daemon-git
provides = deepin-daemon
conflicts = deepin-daemon
replaces = deepin-daemon
- source = git://github.com/linuxdeepin/dde-daemon
- source = dde-daemon_5.9.4.2.diff
+ source = deepin-daemon-git::git://github.com/linuxdeepin/dde-daemon
+ source = dde-daemon.patch
source = deepin-daemon.sysusers
sha512sums = SKIP
- sha512sums = 188bb74fc4deddd2d9cbc210ec487b45664178524294d9a98e47cd4c8a70e369fd3441697bc50b696a975cfbbbfa16666d1798b1ae25469abee50eb84e4bef27
+ sha512sums = SKIP
sha512sums = 808c02d4fec4cbbb01119bbb10499090199e738b7dd72c28a57dde098eef6132723f3434c151f79e21d9f788c7f7bae8046573ac93ba917afe0e803fbffa6d5a
pkgname = deepin-daemon-git
diff --git a/PKGBUILD b/PKGBUILD
index cc5471c04f09..3d1b51164eb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: DingYuan Zhang <justforlxz@gmail.com>
pkgname=deepin-daemon-git
-pkgver=5.11.0.19.r27.g34e54761
+pkgver=5.11.0.47.r1.gf4c781cb
pkgrel=1
pkgdesc='Daemon handling the DDE session settings'
arch=('x86_64')
@@ -24,31 +24,34 @@ replaces=('deepin-daemon')
provides=('deepin-daemon')
groups=('deepin-git')
install="$pkgname.install"
-source=("git://github.com/linuxdeepin/dde-daemon"
- dde-daemon_5.9.4.2.diff
+source=("$pkgname::git://github.com/linuxdeepin/dde-daemon"
+ dde-daemon.patch
'deepin-daemon.sysusers')
sha512sums=('SKIP'
- '188bb74fc4deddd2d9cbc210ec487b45664178524294d9a98e47cd4c8a70e369fd3441697bc50b696a975cfbbbfa16666d1798b1ae25469abee50eb84e4bef27'
+ 'SKIP'
'808c02d4fec4cbbb01119bbb10499090199e738b7dd72c28a57dde098eef6132723f3434c151f79e21d9f788c7f7bae8046573ac93ba917afe0e803fbffa6d5a')
pkgver() {
- cd dde-daemon
+ cd $pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd dde-daemon
- patch -p1 -i ../dde-daemon_5.9.4.2.diff
+ cd $pkgname
+ mkdir build
+ patch -p1 -i ../dde-daemon.patch
export GOPATH="$srcdir/build:/usr/share/gocode"
# golang-deepin-lib's dependency, remove when go packaging resumes
- go get github.com/cryptix/wav
+ go get -v github.com/cryptix/wav
- go get github.com/axgle/mahonia github.com/msteinert/pam github.com/gosexy/gettext github.com/rickb777/date \
+ go get -v github.com/axgle/mahonia github.com/msteinert/pam github.com/gosexy/gettext github.com/rickb777/date \
github.com/jinzhu/gorm github.com/kelvins/sunrisesunset github.com/mozillazg/go-pinyin github.com/teambition/rrule-go \
- golang.org/x/xerrors github.com/mattn/go-sqlite3
-
+ golang.org/x/xerrors github.com/mattn/go-sqlite3 github.com/fsnotify/fsnotify
+ go get -v github.com/godbus/dbus
+ go get -v github.com/godbus/dbus/introspect
+ go get -v github.com/godbus/dbus/prop
sed -i 's#/usr/share/backgrounds/default_background.jpg#/usr/share/backgrounds/deepin/desktop.jpg#' accounts/user.go
}
@@ -59,13 +62,13 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
- cd dde-daemon
+ cd $pkgname
make -C network/nm_generator gen-nm-code
make
}
package() {
- cd dde-daemon
+ cd $pkgname
make DESTDIR="$pkgdir" PAM_MODULE_DIR=usr/lib/security install
mv "$pkgdir"{,/usr}/lib/systemd
diff --git a/dde-daemon.patch b/dde-daemon.patch
new file mode 100644
index 000000000000..fdb9c7d0932b
--- /dev/null
+++ b/dde-daemon.patch
@@ -0,0 +1,49 @@
+diff --git a/system/gesture/core.c b/system/gesture/core.c
+index 85902af6..e1f0df64 100644
+--- a/system/gesture/core.c
++++ b/system/gesture/core.c
+@@ -355,12 +355,12 @@ handle_gesture_events(struct libinput_event *ev, int type)
+ return ;
+ }
+ struct libinput_event_gesture *gesture = libinput_event_get_gesture_event(ev);
+- if (raw->dblclick
++ if (raw->dblclick /*
+ && type != LIBINPUT_EVENT_GESTURE_SWIPE_BEGIN
+ && type != LIBINPUT_EVENT_GESTURE_SWIPE_UPDATE
+ && type != LIBINPUT_EVENT_GESTURE_SWIPE_END
+ && type != LIBINPUT_EVENT_GESTURE_TAP_UPDATE
+- && type != LIBINPUT_EVENT_GESTURE_TAP_END) {
++ && type != LIBINPUT_EVENT_GESTURE_TAP_END*/) {
+ raw->fingers = libinput_event_gesture_get_finger_count(gesture);
+ handleSwipeStop(raw->fingers);
+ raw->dblclick = false;
+@@ -438,7 +438,7 @@ handle_gesture_events(struct libinput_event *ev, int type)
+
+ raw_event_reset(raw, true);
+ break;
+- case LIBINPUT_EVENT_GESTURE_TAP_BEGIN:
++ /*case LIBINPUT_EVENT_GESTURE_TAP_BEGIN:
+ g_debug("[Tap begin] time: %u duration: %d fingers: %d \n", raw->t_start_tap, (libinput_event_gesture_get_time_usec(gesture) - raw->t_start_tap) / 1000, raw->fingers);
+ if (raw->t_start_tap > 0
+ && (libinput_event_gesture_get_time_usec(gesture) - raw->t_start_tap) / 1000 <= dblclick_duration
+@@ -462,7 +462,7 @@ handle_gesture_events(struct libinput_event *ev, int type)
+ } else {
+ raw_event_reset(raw, true);
+ }
+- break;
++ break;*/
+ }
+ }
+
+@@ -592,9 +592,9 @@ handle_events(struct libinput *li, struct movement *m)
+ case LIBINPUT_EVENT_GESTURE_SWIPE_BEGIN:
+ case LIBINPUT_EVENT_GESTURE_SWIPE_UPDATE:
+ case LIBINPUT_EVENT_GESTURE_SWIPE_END:
+- case LIBINPUT_EVENT_GESTURE_TAP_BEGIN:
++ /*case LIBINPUT_EVENT_GESTURE_TAP_BEGIN:
+ case LIBINPUT_EVENT_GESTURE_TAP_UPDATE:
+- case LIBINPUT_EVENT_GESTURE_TAP_END:{
++ case LIBINPUT_EVENT_GESTURE_TAP_END:*/{
+ handle_gesture_events(ev, type);
+ break;
+ }