summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang, DingYuan2020-08-08 10:37:26 +0800
committerZhang, DingYuan2020-08-08 10:37:26 +0800
commit660fad3b5775db692275a9e4053b690f319ec96c (patch)
tree7957f463c319d2e3d1b742d7dcdc0a44d968c5c9
downloadaur-660fad3b5775db692275a9e4053b690f319ec96c.tar.gz
update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
-rw-r--r--distribution.info7
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5299946e562
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = deepin-desktop-base-git
+ pkgdesc = Base component for Deepin
+ pkgver = 2020.04.12.2.r2.g1626fa6
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/deepin-desktop-base
+ arch = any
+ groups = deepin-git
+ license = GPL3
+ provides = deepin-desktop-base
+ conflicts = deepin-desktop-base
+ replaces = deepin-desktop-base
+ source = git://github.com/linuxdeepin/deepin-desktop-base/
+ source = distribution.info
+ sha512sums = SKIP
+ sha512sums = 27625e6d0786b8adacdb7c52806d4faa28d2ab6b319a593b3ea9bcb69f0cc18ea19b258d629e3a0069ef9a69503589b0285289caef39a1e85bbd99e915c7cd7d
+
+pkgname = deepin-desktop-base-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..012cbba2031e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: DingYuan Zhang <justforlxz@gmail.com>
+
+pkgname=deepin-desktop-base-git
+pkgver=2020.04.12.2.r2.g1626fa6
+pkgrel=1
+pkgdesc='Base component for Deepin'
+arch=('any')
+url="https://github.com/linuxdeepin/deepin-desktop-base"
+license=('GPL3')
+groups=('deepin-git')
+conflicts=('deepin-desktop-base')
+replaces=('deepin-desktop-base')
+provides=('deepin-desktop-base')
+groups=('deepin-git')
+source=("git://github.com/linuxdeepin/deepin-desktop-base/"
+ distribution.info)
+sha512sums=('SKIP'
+ '27625e6d0786b8adacdb7c52806d4faa28d2ab6b319a593b3ea9bcb69f0cc18ea19b258d629e3a0069ef9a69503589b0285289caef39a1e85bbd99e915c7cd7d')
+
+pkgver() {
+ cd deepin-desktop-base
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd deepin-desktop-base
+ make
+}
+
+package() {
+ cd deepin-desktop-base
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir"/distribution.info -t "$pkgdir"/usr/share/deepin/
+
+ # Remove Deepin distro's lsb-release
+ rm "$pkgdir"/etc/lsb-release
+
+ # Don't override systemd timeouts
+ rm -r "$pkgdir"/etc/systemd
+
+ # Make a symlink for deepin-version
+ ln -s ../usr/lib/deepin/desktop-version "$pkgdir"/etc/deepin-version
+
+ # Remove UOS logo
+ rm "$pkgdir"/usr/share/deepin/uos_logo.svg
+
+ # Remove apt-specific templates
+ rm -r "$pkgdir"/usr/share/python-apt
+}
diff --git a/distribution.info b/distribution.info
new file mode 100644
index 000000000000..36fbfc03cf4b
--- /dev/null
+++ b/distribution.info
@@ -0,0 +1,7 @@
+[Distribution]
+Name=Arch
+WebsiteName=www.archlinux.org
+Website=https://www.archlinux.org
+Logo=/usr/share/pixmaps/archlinux.svg
+LogoLight=/usr/share/pixmaps/archlinux.svg
+LogoTransparent=/usr/share/pixmaps/archlinux.svg