summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCareF2019-01-03 15:30:58 -0500
committerCareF2019-01-03 15:30:58 -0500
commit508bc4212b537b5a6b7f3828221011d0613ea45e (patch)
tree8e805af5929cc92a7a4c2f3e72d881dad01c20fe
downloadaur-508bc4212b537b5a6b7f3828221011d0613ea45e.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c71707cc9065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = deepin-dock-plugin-arch-update
+ pkgdesc = A plugin for deepin dock, Arch Linux update indicator
+ pkgver = v1.0
+ pkgrel = 1
+ url = https://github.com/CareF/deepin-dock-plugin-arch-update
+ arch = x86_64
+ makedepends = git
+ makedepends = qt5-base
+ makedepends = dtkcore
+ depends = deepin-dock
+ source = deepin-dock-plugin-arch-update-v1.0.tar.gz::https://github.com/CareF/deepin-dock-plugin-arch-update/archive/v1.0.tar.gz
+ md5sums = 4e41c0886c702dd0284ed0e716f0d791
+
+pkgname = deepin-dock-plugin-arch-update
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f52b2f5a9940
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed6826dce131
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: CareF <CareF.lm@gmail.com>
+
+pkgname=deepin-dock-plugin-arch-update
+pkgver=1.0
+pkgrel=1
+pkgdesc="A plugin for deepin dock, Arch Linux update indicator"
+arch=('x86_64')
+url="https://github.com/CareF/deepin-dock-plugin-arch-update"
+depends=('deepin-dock')
+makedepends=('git' 'qt5-base' 'dtkcore')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/CareF/deepin-dock-plugin-arch-update/archive/v${pkgver}.tar.gz")
+md5sums=('4e41c0886c702dd0284ed0e716f0d791')
+
+build() {
+ qmake "$srcdir/$pkgname-$pkgver/source"
+ make ${MAKEFLAGS}
+}
+
+package(){
+ make INSTALL_ROOT="$pkgdir" install
+}