summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorharuyukilxz2018-07-13 19:56:35 +0800
committerharuyukilxz2018-07-13 19:56:35 +0800
commit58ec6e538fd309192fdd8e2d0c0275dd88cdac88 (patch)
treed243152c82b442bd2f3a87e6bf9ff2e0b6e3d101
downloadaur-58ec6e538fd309192fdd8e2d0c0275dd88cdac88.tar.gz
update to 15f6cf0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9869b36a75f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = deepin-network-utils-git
+ pkgdesc = Deepin network utils
+ pkgver = 0.0.1.r1.15f6cf0
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/dde-network-utils
+ arch = x86_64
+ groups = deepin
+ license = GPL3
+ makedepends = git
+ provides = deepin-network-utils
+ source = deepin-network-utils-git::git+https://github.com/linuxdeepin/dde-network-utils.git
+ sha512sums = SKIP
+
+pkgname = deepin-network-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31c9d70af1f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Haruyuki lxz <lxz@ilxz.me>
+
+pkgname=deepin-network-utils-git
+pkgver=0.0.1.r1.15f6cf0
+pkgrel=1
+pkgdesc="Deepin network utils"
+arch=('x86_64')
+url="https://github.com/linuxdeepin/dde-network-utils"
+license=('GPL3')
+groups=('deepin')
+provides=('deepin-network-utils')
+confticts=('deepin-network-utils')
+makedepends=('git')
+source=("${pkgname}"::'git+https://github.com/linuxdeepin/dde-network-utils.git')
+sha512sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ git checkout 15f6cf0
+ qmake
+ make -j4
+}
+
+package() {
+ cd ${pkgname}
+ make INSTALL_ROOT="${pkgdir}" install
+}