summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang, DingYuan2020-08-07 17:09:35 +0800
committerZhang, DingYuan2020-08-07 17:09:35 +0800
commitff861c80126e6c7634edc4e405c4dea5f7d76f1f (patch)
treecf14589cb608f98fdfd4a8e02b8b7acc79bcf535
parent58ec6e538fd309192fdd8e2d0c0275dd88cdac88 (diff)
downloadaur-ff861c80126e6c7634edc4e405c4dea5f7d76f1f.tar.gz
update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD41
2 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9869b36a75f7..1074a36c9a4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = deepin-network-utils-git
- pkgdesc = Deepin network utils
- pkgver = 0.0.1.r1.15f6cf0
+ pkgdesc = DDE network utils
+ pkgver = 5.1.0.2.r2.gd15232e
pkgrel = 1
url = https://github.com/linuxdeepin/dde-network-utils
arch = x86_64
- groups = deepin
+ groups = deepin-git
license = GPL3
makedepends = git
+ makedepends = qt5-tools
+ depends = deepin-qt-dbus-factory-git
provides = deepin-network-utils
- source = deepin-network-utils-git::git+https://github.com/linuxdeepin/dde-network-utils.git
+ conflicts = deepin-network-utils
+ replaces = deepin-network-utils
+ source = git://github.com/linuxdeepin/dde-network-utils.git
sha512sums = SKIP
pkgname = deepin-network-utils-git
diff --git a/PKGBUILD b/PKGBUILD
index 31c9d70af1f0..b651827ad11d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# $Id$
-# Maintainer: Haruyuki lxz <lxz@ilxz.me>
+# Maintainer: DingYuan Zhang <justforlxz@gmail.com>
pkgname=deepin-network-utils-git
-pkgver=0.0.1.r1.15f6cf0
+pkgver=5.1.0.2.r2.gd15232e
pkgrel=1
-pkgdesc="Deepin network utils"
+pkgdesc='DDE network utils'
arch=('x86_64')
url="https://github.com/linuxdeepin/dde-network-utils"
license=('GPL3')
-groups=('deepin')
+depends=('deepin-qt-dbus-factory-git')
+makedepends=('git' 'qt5-tools')
+conflicts=('deepin-network-utils')
+replaces=('deepin-network-utils')
provides=('deepin-network-utils')
-confticts=('deepin-network-utils')
-makedepends=('git')
-source=("${pkgname}"::'git+https://github.com/linuxdeepin/dde-network-utils.git')
+groups=('deepin-git')
+source=("git://github.com/linuxdeepin/dde-network-utils.git")
sha512sums=('SKIP')
-build() {
- cd ${pkgname}
- git checkout 15f6cf0
- qmake
- make -j4
+pkgver() {
+ cd dde-network-utils
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd dde-network-utils
+ # Use our own url instead of third-party commercial company's homepage
+ sed -i '/www.baidu.com/i \ "https://www.archlinux.org/favicon.ico",' connectivitychecker.cpp
+}
+
+build(){
+ cd dde-network-utils
+ qmake-qt5 PREFIX=/usr
+ make
}
package() {
- cd ${pkgname}
- make INSTALL_ROOT="${pkgdir}" install
+ cd dde-network-utils
+ make INSTALL_ROOT="$pkgdir" install
}