summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2021-03-23 09:58:37 +0800
committerjustforlxz2021-03-23 09:58:37 +0800
commit87c938b70117e75c0dd1a539339a8f7fb8088f52 (patch)
tree86eafeee5d79af1f0129720273f15505f3a4ab7b
downloadaur-87c938b70117e75c0dd1a539339a8f7fb8088f52.tar.gz
upgpkg: 5.0.11.r0.ge65055d
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fc4ded2df6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = deepin-pw-check-git
+ pkgdesc = deepin-pw-check is a tool to verify the validity of the password
+ pkgver = 5.0.11.r0.ge65055d
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/deepin-pw-check
+ arch = x86_64
+ groups = deepin-git
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ makedepends = golang-github-linuxdeepin-go-dbus-factory-git
+ makedepends = deepin-gettext-tools
+ depends = cracklib
+ depends = iniparser
+ depends = pam
+ source = deepin-pw-check-git::git://github.com/linuxdeepin/deepin-pw-check
+ sha512sums = SKIP
+
+pkgname = deepin-pw-check-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caf2f8e82650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=deepin-pw-check-git
+pkgver=5.0.11.r0.ge65055d
+pkgrel=1
+pkgdesc='deepin-pw-check is a tool to verify the validity of the password'
+arch=('x86_64')
+url="https://github.com/linuxdeepin/deepin-pw-check"
+license=('GPL3')
+depends=('cracklib' 'iniparser' 'pam')
+makedepends=('git' 'go' 'golang-github-linuxdeepin-go-dbus-factory-git' 'deepin-gettext-tools')
+groups=('deepin-git')
+source=("$pkgname::git://github.com/linuxdeepin/deepin-pw-check")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+ export GOPATH="$srcdir/build:/usr/share/gocode"
+ export GO111MODULE=off
+ go get -v github.com/godbus/dbus
+ go get -v github.com/fsnotify/fsnotify
+
+ sed -i 's/<iniparser\//</g' lib/deepin_pw_check.c
+ sed -i 's/<iniparser\//</g' tool/pwd_conf_update.c
+ sed -i 's/local\///g' Makefile
+}
+
+build() {
+ cd $pkgname
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}