summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:14:27 +0800
committerjustforlxz2022-03-20 01:14:27 +0800
commitdd5e787c33891f64bcc2a25c90bc4f51212abd87 (patch)
tree38a37a32bc26dcda265b9bde773973c1ab0b6546
parent218d176d775e929030f636b383bc15cbb61c669d (diff)
downloadaur-dd5e787c33891f64bcc2a25c90bc4f51212abd87.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46aa9697c7f0..3f2658b1ffbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = deepin-session-shell-git
pkgdesc = Deepin desktop-environment - session-shell module
- pkgver = 5.5.9.r123.gd52f772
+ pkgver = 5.5.24.r8.ga2f84d4
pkgrel = 1
url = https://github.com/linuxdeepin/dde-session-shell
arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
@@ -21,7 +22,7 @@ pkgbase = deepin-session-shell-git
provides = deepin-session-shell
conflicts = deepin-session-ui<5
conflicts = deepin-session-shell
- source = deepin-session-shell-git::git://github.com/linuxdeepin/dde-session-shell
+ source = deepin-session-shell-git::git+https://github.com/linuxdeepin/dde-session-shell
sha512sums = SKIP
pkgname = deepin-session-shell-git
diff --git a/PKGBUILD b/PKGBUILD
index 2903a3029e9f..91c7a2f51a74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-session-shell-git
-pkgver=5.5.9.r123.gd52f772
+pkgver=5.5.24.r8.ga2f84d4
pkgrel=1
pkgdesc='Deepin desktop-environment - session-shell module'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/dde-session-shell"
license=('GPL3')
depends=('deepin-daemon-git' 'deepin-wallpapers-git' 'gsettings-qt' 'liblightdm-qt5' 'startdde-git')
@@ -12,7 +12,7 @@ makedepends=('git' 'cmake' 'ninja' 'qt5-tools' 'gtest' 'gmock')
conflicts=('deepin-session-ui<5' 'deepin-session-shell')
provides=('lightdm-deepin-greeter' 'deepin-session-shell')
groups=('deepin-git')
-source=("$pkgname::git://github.com/linuxdeepin/dde-session-shell")
+source=("$pkgname::git+https://github.com/linuxdeepin/dde-session-shell")
sha512sums=('SKIP')
pkgver() {
@@ -22,6 +22,10 @@ pkgver() {
prepare() {
cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+
sed -i 's/5\.5//g' CMakeLists.txt tests/lightdm-deepin-greeter/CMakeLists.txt tests/dde-lock/CMakeLists.txt
}