summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-02-25 13:49:29 +0800
committerjustforlxz2022-02-25 13:49:29 +0800
commit42b3b3414370f9e7ea9123f2f3d1d6b61f6a8dfd (patch)
tree6d68c045262f2298c71795712e20bfae254eb8d2
parent8caa0179af27b1905359b9e81521a648f2e1c729 (diff)
downloadaur-42b3b3414370f9e7ea9123f2f3d1d6b61f6a8dfd.tar.gz
update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--fix-cmakelist.patch14
3 files changed, 35 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 407a54eb05a0..957fc258484b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
pkgbase = deepin-session-ui-git
pkgdesc = Deepin desktop-environment - Session UI module
- pkgver = 5.4.7.r14.gbf990e94
+ pkgver = 5.5.6.r19.g9cf5bae1
pkgrel = 1
url = https://github.com/linuxdeepin/dde-session-ui
- arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
makedepends = deepin-gettext-tools-git
- makedepends = qt5-tools
+ makedepends = cmake
+ makedepends = ninja
makedepends = deepin-dock-git
+ makedepends = gtest
+ makedepends = gcovr
depends = gsettings-qt
depends = startdde-git
depends = liblightdm-qt5
depends = qt5-svg
depends = deepin-daemon-git
depends = deepin-dock-git
- depends = deepin-wallpapers
+ depends = deepin-wallpapers-git
provides = deepin-notifications
provides = deepin-session-ui
conflicts = dde-workspace
conflicts = deepin-session-ui
conflicts = deepin-notifications
source = deepin-session-ui-git::git://github.com/linuxdeepin/dde-session-ui
+ source = fix-cmakelist.patch
sha512sums = SKIP
+ sha512sums = 50d74d551c71a0039b6064d54939fb8a611941d8e8c653c96a5fc146f3dc168b396d0a4a21c269abb9331fbc7a7cc33909069ea4f8cb20db752705369f1d3710
pkgname = deepin-session-ui-git
diff --git a/PKGBUILD b/PKGBUILD
index f7b01ccf68b0..67a9b7c5de3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-session-ui-git
-pkgver=5.4.7.r14.gbf990e94
+pkgver=5.5.6.r19.g9cf5bae1
pkgrel=1
pkgdesc='Deepin desktop-environment - Session UI module'
-arch=('x86_64')
+arch=('aarch64')
url="https://github.com/linuxdeepin/dde-session-ui"
license=('GPL3')
groups=('deepin')
-depends=('gsettings-qt' 'startdde-git' 'liblightdm-qt5' 'qt5-svg' 'deepin-daemon-git' 'deepin-dock-git' 'deepin-wallpapers')
-makedepends=('git' 'deepin-gettext-tools-git' 'qt5-tools' 'deepin-dock-git')
+depends=('gsettings-qt' 'startdde-git' 'liblightdm-qt5' 'qt5-svg' 'deepin-daemon-git' 'deepin-dock-git' 'deepin-wallpapers-git')
+makedepends=('git' 'deepin-gettext-tools-git' 'cmake' 'ninja' 'deepin-dock-git' 'gtest' 'gcovr')
provides=('deepin-notifications' 'deepin-session-ui')
conflicts=('dde-workspace' 'deepin-session-ui' 'deepin-notifications')
groups=('deepin-git')
-source=("$pkgname::git://github.com/linuxdeepin/dde-session-ui")
-sha512sums=('SKIP')
+source=("$pkgname::git://github.com/linuxdeepin/dde-session-ui"
+ fix-cmakelist.patch)
+sha512sums=('SKIP'
+ '50d74d551c71a0039b6064d54939fb8a611941d8e8c653c96a5fc146f3dc168b396d0a4a21c269abb9331fbc7a7cc33909069ea4f8cb20db752705369f1d3710')
pkgver() {
cd $pkgname
@@ -24,15 +26,16 @@ pkgver() {
prepare() {
cd $pkgname
sed -i 's|/usr/share/backgrounds/default_background.jpg|/usr/share/backgrounds/deepin/desktop.jpg|' widgets/*.cpp
+ patch -p1 -i ../fix-cmakelist.patch
}
build() {
cd $pkgname
- qmake-qt5 PREFIX=/usr
- make -j$(nproc)
+ cmake . -GNinja -DCMAKE_INSTALL_PREFIX=/usr
+ ninja
}
package() {
cd $pkgname
- make INSTALL_ROOT="$pkgdir" install
+ DESTDIR="$pkgdir" ninja install
}
diff --git a/fix-cmakelist.patch b/fix-cmakelist.patch
new file mode 100644
index 000000000000..64ed3bf26197
--- /dev/null
+++ b/fix-cmakelist.patch
@@ -0,0 +1,14 @@
+diff -Nrup deepin-session-ui-git.orig/CMakeLists.txt deepin-session-ui-git/CMakeLists.txt
+--- deepin-session-ui-git.orig/CMakeLists.txt 2022-02-24 15:54:25.000000000 +0800
++++ deepin-session-ui-git/CMakeLists.txt 2022-02-24 15:54:36.000000000 +0800
+@@ -60,8 +60,9 @@ include_directories(
+
+ set(Test_Libraries
+ -lpthread
+- -lgcov
+ -lgtest
++ -lgcov
++ --coverage
+ )
+
+ #----------------------------install config------------------------------