summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang, DingYuan2020-08-08 08:53:58 +0800
committerZhang, DingYuan2020-08-08 08:54:34 +0800
commit8ea5c84f8f029e55100d42551afd9a6d931be35f (patch)
treecf3efe6a5949e231ba2e862c1740009367ff84f0
downloadaur-8ea5c84f8f029e55100d42551afd9a6d931be35f.tar.gz
update
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD46
-rw-r--r--deepin-session-ui-qt5.15.patch24
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..740e02842888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = deepin-session-ui-git
+ pkgdesc = Deepin desktop-environment - Session UI module
+ pkgver = 5.2.0.16.r1.gbc630c7d
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/dde-session-ui
+ arch = x86_64
+ groups = deepin-git
+ license = GPL3
+ makedepends = deepin-gettext-tools
+ makedepends = qt5-tools
+ depends = gsettings-qt
+ depends = deepin-qt5integration-git
+ depends = liblightdm-qt5
+ depends = qt5-svg
+ depends = deepin-daemon
+ depends = deepin-wallpapers
+ provides = deepin-notifications
+ provides = deepin-session-ui
+ conflicts = dde-workspace
+ conflicts = deepin-session-ui
+ conflicts = deepin-notifications
+ replaces = dde-workspace
+ replaces = deepin-session-ui
+ replaces = deepin-notifications
+ source = git://github.com/linuxdeepin/dde-session-ui
+ source = deepin-session-ui-qt5.15.patch
+ sha512sums = SKIP
+ sha512sums = 846726964cac5005b0ac3a5043e5df914ff83faff68f98d2513d86494a9718a85ae4268776fd08ffe852e28ac0ae5878353d3c65db84fbd1509b2325e70fe8d6
+
+pkgname = deepin-session-ui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0613c18e388
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: DingYuan Zhang <justforlxz>
+
+pkgname=deepin-session-ui-git
+pkgver=5.2.0.16.r1.gbc630c7d
+pkgrel=1
+pkgdesc='Deepin desktop-environment - Session UI module'
+arch=('x86_64')
+url="https://github.com/linuxdeepin/dde-session-ui"
+license=('GPL3')
+groups=('deepin')
+depends=('gsettings-qt' 'deepin-qt5integration-git' 'liblightdm-qt5' 'qt5-svg' 'deepin-daemon'
+ 'deepin-wallpapers')
+makedepends=('deepin-gettext-tools' 'qt5-tools')
+provides=('deepin-notifications' 'deepin-session-ui')
+conflicts=('dde-workspace' 'deepin-session-ui' 'deepin-notifications')
+replaces=('dde-workspace' 'deepin-session-ui' 'deepin-notifications')
+groups=('deepin-git')
+source=("git://github.com/linuxdeepin/dde-session-ui"
+ deepin-session-ui-qt5.15.patch)
+sha512sums=('SKIP'
+ '846726964cac5005b0ac3a5043e5df914ff83faff68f98d2513d86494a9718a85ae4268776fd08ffe852e28ac0ae5878353d3c65db84fbd1509b2325e70fe8d6')
+
+pkgver() {
+ cd dde-session-ui
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd dde-session-ui
+ sed -i 's|/usr/share/backgrounds/default_background.jpg|/usr/share/backgrounds/deepin/desktop.jpg|' widgets/*.cpp
+
+ sed -i '/include <QPainter>/a #include <QPainterPath>' dde-notification-plugin/notifications/notificationswidget.cpp
+
+ patch -p1 -i ../deepin-session-ui-qt5.15.patch # Fix build with Qt 5.15
+}
+
+build() {
+ cd dde-session-ui
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd dde-session-ui
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/deepin-session-ui-qt5.15.patch b/deepin-session-ui-qt5.15.patch
new file mode 100644
index 000000000000..582b92c15a57
--- /dev/null
+++ b/deepin-session-ui-qt5.15.patch
@@ -0,0 +1,24 @@
+diff --git a/dde-osd/common.cpp b/dde-osd/common.cpp
+index 0505ac60..ffa55e84 100644
+--- a/dde-osd/common.cpp
++++ b/dde-osd/common.cpp
+@@ -25,6 +25,7 @@
+
+ #include "common.h"
+ #include <QSvgRenderer>
++#include <QPainterPath>
+
+ void DrawHelper::DrawImage(QPainter *painter, const QStyleOptionViewItem &option, const QString &pix, bool withText, bool withProgress)
+ {
+diff --git a/dde-osd/notification-center/overlapwidet.cpp b/dde-osd/notification-center/overlapwidet.cpp
+index d2aee64e..a89f0bd1 100644
+--- a/dde-osd/notification-center/overlapwidet.cpp
++++ b/dde-osd/notification-center/overlapwidet.cpp
+@@ -25,6 +25,7 @@
+ #include "../notification/constants.h"
+ #include "notification/constants.h"
+ #include "notifymodel.h"
++#include <QPainterPath>
+
+ #include <QTimer>
+ #include <QKeyEvent>