summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2024-01-19 20:51:42 +0800
committerjustforlxz2024-01-19 20:51:42 +0800
commit9b2d2cbefe4151419fae4f61668e73a04fd6ac49 (patch)
tree5b7ae9fa738298e54e54db40587149333044fd30
downloadaur-9b2d2cbefe4151419fae4f61668e73a04fd6ac49.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebe6815adad6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = deepin-shell
+ pkgdesc = New DDE shell
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/dde-shell
+ arch = x86_64
+ arch = aarch64
+ groups = deepin
+ license = LGPL3
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = qt5-tools
+ makedepends = dtk6declarative
+ makedepends = qt6-wayland
+ makedepends = cmake
+ makedepends = ninja
+ depends = dtk6declarative
+ depends = qt6-wayland
+ source = https://github.com/linuxdeepin/dde-shell/archive/0.0.4/dde-shell-0.0.4.tar.gz
+ sha512sums = 07c3ee1d8318ad58a5490785b28cffe05f70f8e4526980a4f59a297cf9ea50e6cca672791d750adc06961e10e1d894b48b2a5d66f25832c13fc05ba3a80d64b4
+
+pkgname = deepin-shell
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6f9cee1ae90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=deepin-shell
+_pkgname=dde-shell
+pkgver=0.0.4
+pkgrel=1
+pkgdesc='New DDE shell'
+arch=('x86_64' 'aarch64')
+url="https://github.com/linuxdeepin/dde-shell"
+license=('LGPL3')
+depends=('dtk6declarative' 'qt6-wayland')
+makedepends=('git' 'qt6-tools' 'qt5-tools' 'dtk6declarative' 'qt6-wayland' 'cmake' 'ninja')
+groups=('deepin')
+source=("https://github.com/linuxdeepin/dde-shell/archive/$pkgver/$_pkgname-$pkgver.tar.gz")
+sha512sums=('07c3ee1d8318ad58a5490785b28cffe05f70f8e4526980a4f59a297cf9ea50e6cca672791d750adc06961e10e1d894b48b2a5d66f25832c13fc05ba3a80d64b4')
+
+build() {
+ cd $_pkgname-$pkgver
+ cmake -GNinja \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build .
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ DESTDIR="$pkgdir" ninja install
+}