summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-02-25 12:33:01 +0800
committerjustforlxz2022-02-25 12:33:01 +0800
commit519eb27cb9143d00632cedac6092f280ba3eb2a4 (patch)
tree8baea69c749bafcfba0e1ab9cbed46986d900ec5
downloadaur-519eb27cb9143d00632cedac6092f280ba3eb2a4.tar.gz
update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be6379c59b46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = deepin-sound-theme-git
+ pkgdesc = Deepin sound theme
+ pkgver = 15.10.6.r2.ge3aa7fb
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/deepin-sound-theme
+ arch = any
+ groups = deepin-git
+ license = GPL3
+ conflicts = deepin-artwork
+ conflicts = deepin-sound-theme
+ source = deepin-sound-theme-git::git://github.com/linuxdeepin/deepin-sound-theme/
+ sha512sums = SKIP
+
+pkgname = deepin-sound-theme-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6851c410d746
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=deepin-sound-theme-git
+pkgver=15.10.6.r2.ge3aa7fb
+pkgrel=1
+pkgver=15.10.6.r2.ge3aa7fb
+pkgrel=1
+pkgdesc="Deepin sound theme"
+arch=('any')
+url="https://github.com/linuxdeepin/deepin-sound-theme"
+license=('GPL3')
+groups=('deepin-git')
+conflicts=('deepin-artwork' 'deepin-sound-theme')
+source=("$pkgname::git://github.com/linuxdeepin/deepin-sound-theme/")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}