summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:15:49 +0800
committerjustforlxz2022-03-20 01:15:49 +0800
commit56f52b788eb1d3504f28092b1fbe16405b492ee1 (patch)
tree553d9793b76947b97bdf4f7b6862f1cbfa823e6b
parent519eb27cb9143d00632cedac6092f280ba3eb2a4 (diff)
downloadaur-56f52b788eb1d3504f28092b1fbe16405b492ee1.tar.gz
update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be6379c59b46..753c1accd349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,10 @@ pkgbase = deepin-sound-theme-git
arch = any
groups = deepin-git
license = GPL3
+ makedepends = git
conflicts = deepin-artwork
conflicts = deepin-sound-theme
- source = deepin-sound-theme-git::git://github.com/linuxdeepin/deepin-sound-theme/
+ source = deepin-sound-theme-git::git+https://github.com/linuxdeepin/deepin-sound-theme/
sha512sums = SKIP
pkgname = deepin-sound-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 6851c410d746..ad71e50f37f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=deepin-sound-theme-git
pkgver=15.10.6.r2.ge3aa7fb
pkgrel=1
-pkgver=15.10.6.r2.ge3aa7fb
-pkgrel=1
pkgdesc="Deepin sound theme"
arch=('any')
url="https://github.com/linuxdeepin/deepin-sound-theme"
+makedepends=('git')
license=('GPL3')
groups=('deepin-git')
conflicts=('deepin-artwork' 'deepin-sound-theme')
-source=("$pkgname::git://github.com/linuxdeepin/deepin-sound-theme/")
+source=("$pkgname::git+https://github.com/linuxdeepin/deepin-sound-theme/")
sha512sums=('SKIP')
pkgver() {
@@ -19,6 +18,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+}
+
build() {
cd $pkgname
make