summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:16:23 +0800
committerjustforlxz2022-03-20 01:16:23 +0800
commit59870560170c2f1457a977a576863065346434d5 (patch)
treed869a7236a89b4466ef73ceddd9ce49fa28918aa
parent01ed4a1b90cb94df8213f03960929b8ee140581d (diff)
downloadaur-59870560170c2f1457a977a576863065346434d5.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c819b36609..91591e2baaba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = deepin-turbo-git
pkgdesc = A daemon that helps to launch applications faster
- pkgver = 0.0.5.r13.g8c85d2c
+ pkgver = 0.0.5.r14.g427439d
pkgrel = 1
url = https://github.com/linuxdeepin/deepin-turbo
arch = x86_64
+ arch = aarch64
groups = deepin
license = GPL3
makedepends = cmake
+ makedepends = git
depends = qt5-base
provides = deepin-turbo
conflicts = deepin-turbo
- source = deepin-turbo-git::git://github.com/linuxdeepin/deepin-turbo
+ source = deepin-turbo-git::git+https://github.com/linuxdeepin/deepin-turbo
sha512sums = SKIP
pkgname = deepin-turbo-git
diff --git a/PKGBUILD b/PKGBUILD
index c9d41f70c155..d38c8d5b68fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: DingYuan Zhang <justforlxz@gmail.com>
pkgname=deepin-turbo-git
-pkgver=0.0.5.r13.g8c85d2c
+pkgver=0.0.5.r14.g427439d
pkgrel=1
pkgdesc='A daemon that helps to launch applications faster'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/deepin-turbo"
license=('GPL3')
depends=('qt5-base')
-makedepends=('cmake')
+makedepends=('cmake' 'git')
groups=('deepin')
provides=('deepin-turbo')
conflicts=('deepin-turbo')
-source=("$pkgname::git://github.com/linuxdeepin/deepin-turbo")
+source=("$pkgname::git+https://github.com/linuxdeepin/deepin-turbo")
sha512sums=('SKIP')
pkgver() {
@@ -20,6 +20,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+}
+
build() {
cd $pkgname
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_BUILD_TYPE=Release .