summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:17:49 +0800
committerjustforlxz2022-03-20 01:17:49 +0800
commit1b4d80d64d94e867dbb14505445f9b71bff9191c (patch)
treee6123c3d693cd61c54dd2f6ed8dddffdd4d5adc6
parentc1fcd640962d5aeb4bd4e4d73696de2bf9d22ab8 (diff)
downloadaur-1b4d80d64d94e867dbb14505445f9b71bff9191c.tar.gz
update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf3acd0b58c0..91d715e6117a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,9 @@ pkgbase = deepin-wallpapers-git
arch = any
groups = deepin-git
license = GPL
+ makedepends = git
makedepends = deepin-api-git
- source = deepin-wallpapers-git::git://github.com/linuxdeepin/deepin-wallpapers/
+ source = deepin-wallpapers-git::git+https://github.com/linuxdeepin/deepin-wallpapers/
sha512sums = SKIP
pkgname = deepin-wallpapers-git
diff --git a/PKGBUILD b/PKGBUILD
index 8441b2e028c5..adf3e9ec4462 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,9 @@ pkgdesc='Deepin Wallpapers'
arch=('any')
license=('GPL')
url="https://github.com/linuxdeepin/deepin-wallpapers"
-makedepends=('deepin-api-git')
+makedepends=('git' 'deepin-api-git')
groups=('deepin-git')
-source=("$pkgname::git://github.com/linuxdeepin/deepin-wallpapers/")
+source=("$pkgname::git+https://github.com/linuxdeepin/deepin-wallpapers/")
sha512sums=('SKIP')
pkgver() {
@@ -24,7 +24,11 @@ pkgver() {
}
prepare() {
- cd $pkgbase
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+
cp -a "$srcdir"/$pkgbase{,-community}
}