summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-12-08 16:01:39 +0800
committerjustforlxz2022-12-08 16:01:39 +0800
commita3c24b5c8d41a9af6db609a85bcf038ce81d36e9 (patch)
tree678a49dc3ea92b72e736c3dce2f9940a29505fa0
parent1b4d80d64d94e867dbb14505445f9b71bff9191c (diff)
downloadaur-a3c24b5c8d41a9af6db609a85bcf038ce81d36e9.tar.gz
update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD45
2 files changed, 7 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91d715e6117a..4c1df219459b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = deepin-wallpapers-git
pkgdesc = Deepin Wallpapers
- pkgver = 1.7.7.r9.ga579405
+ pkgver = 1.8.3.r10.g548f259
pkgrel = 1
- epoch = 1
url = https://github.com/linuxdeepin/deepin-wallpapers
arch = any
groups = deepin-git
@@ -13,9 +12,3 @@ pkgbase = deepin-wallpapers-git
sha512sums = SKIP
pkgname = deepin-wallpapers-git
- pkgdesc = Default wallpapers for DDE
- groups = deepin-git
-
-pkgname = deepin-community-wallpapers-git
- pkgdesc = Community wallpapers for DDE
- groups = deepin-git
diff --git a/PKGBUILD b/PKGBUILD
index adf3e9ec4462..f1c0561fa598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,9 @@
# Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
# Contributor: Xu Fasheng <fasheng.xu[AT]gmail.com>
-pkgbase=deepin-wallpapers-git
-pkgname=(deepin-wallpapers-git deepin-community-wallpapers-git)
-pkgver=1.7.7.r9.ga579405
+pkgname=deepin-wallpapers-git
+pkgver=1.8.3.r10.g548f259
pkgrel=1
-epoch=1
pkgdesc='Deepin Wallpapers'
arch=('any')
license=('GPL')
@@ -19,57 +17,26 @@ source=("$pkgname::git+https://github.com/linuxdeepin/deepin-wallpapers/")
sha512sums=('SKIP')
pkgver() {
- cd $pkgbase
+ cd $pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd $pkgname
- if [[ ! -z ${sha} ]];then
- git checkout -b $sha
- fi
-
- cp -a "$srcdir"/$pkgbase{,-community}
-}
-
build() {
- cd "$srcdir"/$pkgbase
+ cd $pkgname
for _pic in deepin/*; do
make PICS=$_pic
done
-
- cd "$srcdir"/$pkgbase-community
- for _pic in deepin-community/*; do
- make PICS=$_pic
- done
}
-package_deepin-wallpapers-git() {
- pkgdesc='Default wallpapers for DDE'
- groups=('deepin-git')
-
- cd $pkgbase
+package() {
+ cd $pkgname
install -dm755 "$pkgdir"/usr/share/wallpapers
cp -r deepin "$pkgdir"/usr/share/wallpapers/
-
install -dm755 "$pkgdir"/var/cache
cp -r image-blur "$pkgdir"/var/cache/
-
# Suggested by upstream
install -dm755 "$pkgdir"/usr/share/backgrounds/deepin
ln -s ../../wallpapers/deepin/Hummingbird_by_Shu_Le.jpg "$pkgdir"/usr/share/backgrounds/deepin/desktop.jpg
ln -s $(echo -n /usr/share/wallpapers/deepin/Hummingbird_by_Shu_Le.jpg | md5sum | cut -d " " -f 1).jpg \
"$pkgdir"/var/cache/image-blur/$(echo -n /usr/share/backgrounds/deepin/desktop.jpg | md5sum | cut -d " " -f 1).jpg
}
-
-package_deepin-community-wallpapers-git() {
- pkgdesc='Community wallpapers for DDE'
- groups=('deepin-git')
-
- cd $pkgbase-community
- install -dm755 "$pkgdir"/usr/share/wallpapers/deepin
- cp deepin-community/* "$pkgdir"/usr/share/wallpapers/deepin/
-
- install -dm755 "$pkgdir"/var/cache
- cp -r image-blur "$pkgdir"/var/cache/
-}