summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-02-19 21:13:40 +0800
committerzxp198210052023-02-19 21:13:40 +0800
commit32d4870caf4143b10e4bc8a5111febe12f3ea6f6 (patch)
tree1a90d2532d85a7a078e051014ffb5b541cc8f556
downloadaur-32d4870caf4143b10e4bc8a5111febe12f3ea6f6.tar.gz
the first release
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD63
-rw-r--r--deepin-wine-danmoshui.desktop11
-rw-r--r--deepin-wine-danmoshui.install16
-rw-r--r--deepin-wine-danmoshui.pngbin0 -> 3354 bytes
-rw-r--r--run.sh20
6 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59594b3ffbc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = deepin-wine-danmoshui
+ pkgdesc = DanMoShui Calligraphy on deepin wine 6.基于Deepin Wine 6的淡墨水字帖PC版。
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://danmoshui.com
+ install = deepin-wine-danmoshui.install
+ arch = x86_64
+ license = custom
+ depends = deepin-wine6-stable
+ depends = xdg-utils
+ optdepends = wqy-microhei
+ optdepends = wqy-zenhei
+ provides = danmoshui
+ source = com.deepin.bandizip-7.23.deb::https://mirrors.sdu.edu.cn/spark-store-repository/store/tools/com.deepin.bandizip/com.deepin.bandizip_7.23_amd64.deb
+ source = danmoshui-0.0.6.zip::https://danmoshui.com/static/danmoshuiZiTie-win.zip
+ source = LICENSE::https://danmoshui.com/privacy_policy
+ source = deepin-wine-danmoshui.install
+ source = deepin-wine-danmoshui.desktop
+ source = deepin-wine-danmoshui.png
+ source = run.sh
+ sha256sums = e8f04a4870dbd7e4398b8d3a92a19f451b8756df58f30cdd8cbc0b2bdf629b7a
+ sha256sums = 7bd8b3c7e3256cdc6349585e6ec21105d0fdd2d3b5f7977490de08643a34e5e6
+ sha256sums = e984edcbcf35bb47fb35eb8f618b49a0c8e9dff561df32d65a1efab2af33a756
+ sha256sums = 2da39854e84f2f0c2f2401747ee99c5a46dd6288099d8761b52eb2cfa2e255c2
+ sha256sums = cf63cb5313fc422f874bbe34045cf48c46fffb23e8bb117f9836b2ac24cefabf
+ sha256sums = 055cf7f62fe412b52626648a861fad75653cd13383aec40278c556c88fe40ba6
+ sha256sums = fe34f327816b306fb08975683e1e61f85c066c29fbcaee332a3e76caf2e08d47
+
+pkgname = deepin-wine-danmoshui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b67663d8f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=deepin-wine-danmoshui
+_pkgname=danmoshui
+pkgver=0.0.6
+_tmppkgname=com.deepin.bandizip
+_tmppkgver=7.23
+_tmpfilename=Bandizip
+pkgrel=1
+epoch=
+pkgdesc="DanMoShui Calligraphy on deepin wine 6.基于Deepin Wine 6的淡墨水字帖PC版。"
+arch=("x86_64")
+url="https://danmoshui.com"
+license=('custom')
+depends=(
+ 'deepin-wine6-stable'
+ 'xdg-utils'
+ )
+optdepends=(
+ 'wqy-microhei'
+ 'wqy-zenhei'
+ )
+conflicts=()
+provides=("danmoshui")
+install="${pkgname}.install"
+source=(
+ "${_tmppkgname}-${_tmppkgver}.deb::https://mirrors.sdu.edu.cn/spark-store-repository/store/tools/${_tmppkgname}/${_tmppkgname}_${_tmppkgver}_amd64.deb"
+ "${_pkgname}-${pkgver}.zip::${url}/static/${_pkgname}ZiTie-win.zip"
+ "LICENSE::https://danmoshui.com/privacy_policy"
+ "${pkgname}.install"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+ "run.sh"
+ )
+sha256sums=('e8f04a4870dbd7e4398b8d3a92a19f451b8756df58f30cdd8cbc0b2bdf629b7a'
+ '7bd8b3c7e3256cdc6349585e6ec21105d0fdd2d3b5f7977490de08643a34e5e6'
+ 'e984edcbcf35bb47fb35eb8f618b49a0c8e9dff561df32d65a1efab2af33a756'
+ '2da39854e84f2f0c2f2401747ee99c5a46dd6288099d8761b52eb2cfa2e255c2'
+ 'cf63cb5313fc422f874bbe34045cf48c46fffb23e8bb117f9836b2ac24cefabf'
+ '055cf7f62fe412b52626648a861fad75653cd13383aec40278c556c88fe40ba6'
+ 'fe34f327816b306fb08975683e1e61f85c066c29fbcaee332a3e76caf2e08d47')
+
+prepare() {
+ bsdtar -xf data.tar.xz
+ mv "${srcdir}/opt/apps/${_tmppkgname}" "${srcdir}/opt/apps/${pkgname}"
+ rm -r "${srcdir}/opt/apps/${pkgname}/entries"
+ 7z x -aoa "${srcdir}/opt/apps/${pkgname}/files/files.7z" -o"${srcdir}/tmp"
+ rm -r "${srcdir}/tmp/drive_c/Program Files/${_tmpfilename}" "${srcdir}/tmp/"*.conf "${srcdir}/tmp/desktopdata" "${srcdir}/tmp/windata" \
+ "${srcdir}/tmp/drive_c/users/crossover/Desktop/${_tmpfilename}.lnk" "${srcdir}/opt/apps/${pkgname}/files/files.7z"
+ unzip -O CP936 ${_pkgname}-${pkgver}.zip -d "${srcdir}/tmp/drive_c/Program Files/"
+ mv "${srcdir}/tmp/drive_c/Program Files/淡墨水字帖_x64" "${srcdir}/tmp/drive_c/Program Files/${_pkgname}"
+ mv "${srcdir}/tmp/drive_c/Program Files/${_pkgname}/淡墨水字帖.exe" "${srcdir}/tmp/drive_c/Program Files/${_pkgname}/${_pkgname}.exe"
+ 7z a -t7z -r "${srcdir}/opt/apps/${pkgname}/files/files.7z" "${srcdir}/tmp/*"
+ rm -rf ${srcdir}/opt/apps/${_pkgname}/info
+}
+
+package() {
+ cp -r "${srcdir}/opt" "${pkgdir}"
+ md5sum "${pkgdir}/opt/apps/${pkgname}/files/files.7z" | awk '{ print $1 }' > "${pkgdir}/opt/apps/${pkgname}/files/files.md5sum"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.png"
+ install -Dm755 "${srcdir}/run.sh" "${pkgdir}/opt/apps/${pkgname}/files/"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/deepin-wine-danmoshui.desktop b/deepin-wine-danmoshui.desktop
new file mode 100644
index 000000000000..1c15eee15cb6
--- /dev/null
+++ b/deepin-wine-danmoshui.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Terminal=false
+NoDisplay=false
+Icon=deepin-wine-danmoshui
+Type=Application
+Categories=Education;
+Exec=/opt/apps/deepin-wine-danmoshui/files/run.sh
+Name=淡墨水字帖
+GenericName=淡墨水字帖
+Comment=淡墨水字帖 \ No newline at end of file
diff --git a/deepin-wine-danmoshui.install b/deepin-wine-danmoshui.install
new file mode 100644
index 000000000000..f85e35ea031f
--- /dev/null
+++ b/deepin-wine-danmoshui.install
@@ -0,0 +1,16 @@
+info() {
+ echo -e "\033[0;34m============================提示/INFO==============================="
+ echo -e "此脚本主要是覆盖安装时使用,删除原有的运行及配置文件。"
+ echo -e "====================================================================\033[0m"
+}
+post_install() {
+ info
+}
+post_upgrade() {
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -f \{\}/Deepin-danmoshui/reinstalled \;
+ info
+}
+pre_remove() {
+ echo "deleting the douyin bottle..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-danmoshui/ \;
+} \ No newline at end of file
diff --git a/deepin-wine-danmoshui.png b/deepin-wine-danmoshui.png
new file mode 100644
index 000000000000..2b79fbc52ca5
--- /dev/null
+++ b/deepin-wine-danmoshui.png
Binary files differ
diff --git a/run.sh b/run.sh
new file mode 100644
index 000000000000..7000170bd314
--- /dev/null
+++ b/run.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# Copyright (C) 2020 Deepin, Inc.
+#
+# Author: RTX3090 <QQ482961502@gmail.com>
+
+BOTTLENAME="Deepin-danmoshui"
+APPVER="5.7.9"
+EXEC_PATH="c:/Program Files/danmoshui/danmoshui.exe"
+START_SHELL_PATH="/opt/deepinwine/tools/run_v4.sh"
+
+export MIME_TYPE=""
+export DEB_PACKAGE_NAME="deepin-wine-danmoshui"
+export APPRUN_CMD="deepin-wine6-stable"
+
+if [ -n "$EXEC_PATH" ];then
+ $START_SHELL_PATH $BOTTLENAME $APPVER "$EXEC_PATH" "$@"
+ else
+ $START_SHELL_PATH $BOTTLENAME $APPVER "uninstaller.exe" "$@"
+fi \ No newline at end of file