aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCodist2019-10-21 21:08:45 +0800
committerCodist2019-10-21 21:08:45 +0800
commit16fbad8287ad07d4cd953543464cf2bf283c9e90 (patch)
treedc0b98907c99c3d1844cb2ecb52349bd0bb89386
parentffbc46992a500e7e2cac60abdbe0420c5e083a24 (diff)
downloadaur-16fbad8287ad07d4cd953543464cf2bf283c9e90.tar.gz
Add help info to PKGBUILD
Signed-off-by: Codist <countstarlight@gmail.com>
-rw-r--r--PKGBUILD9
-rw-r--r--README.md58
2 files changed, 59 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d23733c76deb..2262aedb6e5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,4 +47,13 @@ package() {
install -m644 "${srcdir}/files.7z" "${pkgdir}/opt/deepinwine/apps/Deepin-TIM/"
install -m755 "${srcdir}/run.sh" "${pkgdir}/opt/deepinwine/apps/Deepin-TIM/"
install -m644 "${srcdir}/TIM$pkgver.exe" "${pkgdir}/opt/deepinwine/apps/Deepin-TIM/"
+ msg "Printing help info ..."
+ echo -e "\033[0;34m=========================提示/INFO==============================="
+ echo -e "\033[0;34m* 报告问题(Report issue):"
+ echo -e "\033[0;34m https://github.com/countstarlight/deepin-wine-tim-arch/issues"
+ echo -e "\033[0;34m* 切换到 'deepin-wine'(Switch to 'deepin-wine'):"
+ echo -e "\033[0;34m https://github.com/countstarlight/deepin-wine-tim-arch"
+ echo -e "\033[0;34m* 安装包下载(Installation package download):"
+ echo -e "\033[0;34m https://github.com/countstarlight/deepin-wine-tim-arch/releases"
+ echo -e "\033[0;34m================================================================="
}
diff --git a/README.md b/README.md
index e8decd6346e1..990d055d3ef2 100644
--- a/README.md
+++ b/README.md
@@ -28,6 +28,11 @@ Deepin 打包的 TIM 容器移植到 Archlinux,不依赖 `deepin-wine`,包
- [用安装包安装](#用安装包安装)
- [本地打包安装](#本地打包安装)
- [切换到 `deepin-wine`](#切换到-deepin-wine)
+ - [1. 安装 deepin-wine](#1-安装-deepin-wine)
+ - [2. 修改 `deepin-wine-tim` 的启动文件](#2-修改-deepin-wine-tim-的启动文件)
+ - [3. 对于非 GNOME 桌面(KDE, XFCE等)](#3-对于非-gnome-桌面kde-xfce等)
+ - [4. 删除原先的TIM目录](#4-删除原先的tim目录)
+ - [5. 修复 `deepin-wine` 字体渲染发虚](#5-修复-deepin-wine-字体渲染发虚)
- [字体](#字体)
- [使用其他字体](#使用其他字体)
- [修复字体模糊](#修复字体模糊)
@@ -84,36 +89,73 @@ sudo pacman -U #下载的包名
* 运行应用菜单中创建的 TIM 快捷方式,开始安装 TIM
+ **注意:安装TIM时不需要修改安装路径,如果修改默认路径,要对应修改 `deepin-wine-tim` 的启动脚本:**
+
+ `/opt/deepinwine/apps/Deepin-TIM/run.sh`
+
+ ```bash
+ env WINEPREFIX="$WINEPREFIX" WINEDEBUG=-msvcrt $WINE_CMD "c:\\Program Files\\Tencent\\TIM\\Bin\\TIM.exe" &
+ ```
+
+ 改为修改后的安装路径,否则只有安装后第一次能够运行
+
* 安装完可直接启动
## 切换到 `deepin-wine`
-由于原版 `wine` 在DDE(Deepin Desktop Environment)上,存在托盘图标无法响应鼠标事件([deepin-wine-tim-arch#21](https://github.com/countstarlight/deepin-wine-tim-arch/issues/21))等问题,且原版 `wine` 尚不能实现保存登录密码等功能,可以选择切换到 `deepin-wine`。
+由于原版 `wine` 在 [DDE(Deepin Desktop Environment)](https://www.deepin.org/dde/) 上,存在托盘图标无法响应鼠标事件([deepin-wine-tim-arch#21](https://github.com/countstarlight/deepin-wine-tim-arch/issues/21)),边框穿透显示([deepin-wine-wechat-arch#15](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/15)), 无法截图等问题,且原版 `wine` 尚不能实现保存登录密码等功能,可以选择切换到 `deepin-wine`。
-根据 [deepin-wine-tim-arch#15](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/15#issuecomment-515455845),由 [@feileb](https://github.com/feileb) 和 [@violetbobo](https://github.com/violetbobo) 提供的方法:
+根据 [deepin-wine-wechat-arch#15](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/15#issuecomment-515455845),[deepin-wine-wechat-arch#27](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/27),由 [@feileb](https://github.com/feileb), [@violetbobo](https://github.com/violetbobo), [@HE7086](https://github.com/HE7086)提供的方法:
-* 1. 安装 deepin-wine
+### 1. 安装 deepin-wine
```bash
yay -S deepin-wine
```
-* 2. 修改 `deepin-wine-tim` 的启动文件
+### 2. 修改 `deepin-wine-tim` 的启动文件
-/opt/deepinwine/tools/run.sh
+修改如下两个文件中的 `WINE_CMD` 的值:
-/opt/deepinwine/apps/Deepin-TIM/run.sh
+`/opt/deepinwine/tools/run.sh`
-修改这两个文件中的 `WINE_CMD` 的值:
+`/opt/deepinwine/apps/Deepin-TIM/run.sh`
```diff
-WINE_CMD="wine"
+WINE_CMD="deepin-wine"
```
+### 3. 对于非 GNOME 桌面(KDE, XFCE等)
+
+需要安装 `gnome-settings-daemon`
+
+```bash
+sudo pacman -Sy gnome-settings-daemon
+```
+并在 `/opt/deepinwine/apps/Deepin-TIM/run.sh` 中加入如下几行:
+
+```diff
+ RunApp()
+ {
++ if [[ -z "$(ps -e | grep -o gsd-xsettings)" ]]
++ then
++ /usr/lib/gsd-xsettings &
++ fi
+ if [ -d "$WINEPREFIX" ]; then
+ UpdateApp
+ else
+```
+
**注意:对 `/opt/deepinwine/apps/Deepin-TIM/run.sh` 的修改会在 `deepin-wine-tim` 更新或重装时被覆盖,可以单独拷贝一份作为启动脚本**
-* 3. 修复 `deepin-wine` 字体渲染发虚
+### 4. 删除原先的TIM目录
+
+```bash
+rm -rf ~/.deepinwine/Deepin-TIM
+```
+
+### 5. 修复 `deepin-wine` 字体渲染发虚
```bash
yay -S lib32-freetype2-infinality-ultimate