aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-02-26 11:58:15 +0900
committerasukaminato2023-02-26 11:58:15 +0900
commita1eb7d3aa76d94b81930dd0e97ac82841801b42e (patch)
tree0f56a457b7c4a47da1625d17aca478a5a44a397e
parent0e9b467cecded474213af33c2aea63472b3e0aa5 (diff)
downloadaur-a1eb7d3aa76d94b81930dd0e97ac82841801b42e.tar.gz
update to 2023-1-11
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD39
-rwxr-xr-xrun.sh2
3 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f7f7c416853..e204efaf8d68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deepin-wine-tim
pkgdesc = Tencent TIM on Deepin Wine5(com.qq.office.deepin) For Archlinux
- pkgver = 3.3.9.22051
+ pkgver = 3.4.5.22071
pkgrel = 1
url = https://tim.qq.com/
install = deepin-wine-tim.install
@@ -21,12 +21,12 @@ pkgbase = deepin-wine-tim
conflicts = deepin.com.qq.office
conflicts = deepin-tim-for-arch
source = https://com-store-packages.uniontech.com/appstore/pool/appstore/c/com.qq.im.deepin/com.qq.im.deepin_9.3.2deepin20_i386.deb
- source = https://dldir1.qq.com/qqfile/qq/TIM3.3.9/TIM3.3.9.22051.exe
+ source = https://dldir1.qq.com/qqfile/qq/TIM3.4.5/TIM3.4.5.22071.exe
source = run.sh
source = share.7z
md5sums = 5fdc20e614d945bd2ba5251420872479
- md5sums = e5b97081022766415bd22d21fba706f6
- md5sums = cb8c2f007930241730cede526094fae5
+ md5sums = 91ad8ac2055e10385e8016058dfc2e7b
+ md5sums = 3ffc2a7c521bb6d7c929c6fd6864ac2c
md5sums = 479ae2a04a9c5dcc08c67c7b1395a944
pkgname = deepin-wine-tim
diff --git a/PKGBUILD b/PKGBUILD
index 0835005dfc17..6d3235ac724b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Codist <countstarlight@gmail.com>
pkgname=deepin-wine-tim
-pkgver=3.3.9.22051
-debpkgver=9.3.2deepin20
-debpkgname="com.qq.im.deepin"
-timpkgname="com.qq.office.deepin"
+pkgver=3.4.5.22071
+_debpkgver=9.3.2deepin20
+_debpkgname="com.qq.im.deepin"
+_timpkgname="com.qq.office.deepin"
pkgrel=1
-pkgdesc="Tencent TIM on Deepin Wine5(${timpkgname}) For Archlinux"
+pkgdesc="Tencent TIM on Deepin Wine5(${_timpkgname}) For Archlinux"
arch=("x86_64")
url="https://tim.qq.com/"
license=('custom')
@@ -14,26 +14,26 @@ depends=('p7zip' 'deepin-wine5' 'deepin-wine-helper>=5.1.30_1-1' 'xorg-xwininfo'
conflicts=('wine-tim' 'deepin.com.qq.office' 'deepin-tim-for-arch')
install="deepin-wine-tim.install"
_mirror="https://com-store-packages.uniontech.com"
-source=("$_mirror/appstore/pool/appstore/c/${debpkgname}/${debpkgname}_${debpkgver}_i386.deb"
- "https://dldir1.qq.com/qqfile/qq/TIM3.3.9/TIM${pkgver}.exe"
+source=("$_mirror/appstore/pool/appstore/c/${_debpkgname}/${_debpkgname}_${_debpkgver}_i386.deb"
+ "https://dldir1.qq.com/qqfile/qq/TIM3.4.5/TIM${pkgver}.exe"
"run.sh"
"share.7z")
md5sums=('5fdc20e614d945bd2ba5251420872479'
- 'e5b97081022766415bd22d21fba706f6'
- 'cb8c2f007930241730cede526094fae5'
- '479ae2a04a9c5dcc08c67c7b1395a944')
+ '91ad8ac2055e10385e8016058dfc2e7b'
+ '3ffc2a7c521bb6d7c929c6fd6864ac2c'
+ '479ae2a04a9c5dcc08c67c7b1395a944')
build() {
- msg "Extracting DPKG package ..."
+ printf "Extracting DPKG package ...\n"
mkdir -p "${srcdir}/dpkgdir"
tar -xvf data.tar.xz -C "${srcdir}/dpkgdir"
#sed "s/\(Categories.*$\)/\1Network;/" -i "${srcdir}/dpkgdir/usr/share/applications/deepin.com.qq.office.desktop"
#sed "13s/TIM.exe/tim.exe/" -i "${srcdir}/dpkgdir/usr/share/applications/deepin.com.qq.office.desktop"
- msg "Extracting Deepin Wine QQ archive ..."
- 7z x -aoa "${srcdir}/dpkgdir/opt/apps/${debpkgname}/files/files.7z" -o"${srcdir}/deepintimdir"
+ printf "Extracting Deepin Wine QQ archive ...\n"
+ 7z x -aoa "${srcdir}/dpkgdir/opt/apps/${_debpkgname}/files/files.7z" -o"${srcdir}/deepintimdir"
printf "Cleaning up the original package directory ...\n"
rm -r "${srcdir}/deepintimdir/drive_c/Program Files/Tencent/QQ"
- #msg "Patching reg files ..."
+ #printf "Patching reg files ..."
#patch -p1 -d "${srcdir}/deepintimdir/" < "${srcdir}/reg.patch"
printf "Creating font file link ...\n"
ln -sf "/usr/share/fonts/wenquanyi/wqy-microhei/wqy-microhei.ttc" "${srcdir}/deepintimdir/drive_c/windows/Fonts/wqy-microhei.ttc"
@@ -49,10 +49,9 @@ package() {
7z x -aoa "${srcdir}/share.7z" -o"${srcdir}/"
cp -a ${srcdir}/share/* "${pkgdir}/usr/share/"
printf "Copying deepin files ...\n"
- install -d "${pkgdir}/opt/apps/${timpkgname}/files"
- install -m644 "${srcdir}/files.7z" "${pkgdir}/opt/apps/${timpkgname}/files/"
- # cp ${srcdir}/dpkgdir/opt/apps/${debpkgname}/files/helper_archive* "${pkgdir}/opt/apps/${timpkgname}/files/"
- #install -m755 "${srcdir}/dpkgdir/opt/apps/${debpkgname}/files/gtkGetFileNameDlg" "${pkgdir}/opt/apps/${timpkgname}/files/"
- md5sum "${srcdir}/files.7z" | awk '{ print $1 }' > "${pkgdir}/opt/apps/${timpkgname}/files/files.md5sum"
- install -m755 "${srcdir}/run.sh" "${pkgdir}/opt/apps/${timpkgname}/files/"
+ install -Dm644 "files.7z" -t "${pkgdir}/opt/apps/${_timpkgname}/files/"
+ # cp ${srcdir}/dpkgdir/opt/apps/${_debpkgname}/files/helper_archive* "${pkgdir}/opt/apps/${_timpkgname}/files/"
+ #install -m755 "${srcdir}/dpkgdir/opt/apps/${_debpkgname}/files/gtkGetFileNameDlg" "${pkgdir}/opt/apps/${_timpkgname}/files/"
+ md5sum "${srcdir}/files.7z" | awk '{ print $1 }' > "${pkgdir}/opt/apps/${_timpkgname}/files/files.md5sum"
+ install -Dm755 "run.sh" -t "${pkgdir}/opt/apps/${_timpkgname}/files/"
}
diff --git a/run.sh b/run.sh
index 485d53c0c7d1..98c551b192fd 100755
--- a/run.sh
+++ b/run.sh
@@ -13,7 +13,7 @@ BOTTLENAME="Deepin-TIM"
APPVER="9.3.2deepin20"
WINEPREFIX="$HOME/.deepinwine/$BOTTLENAME"
TIM_FONTS="$WINEPREFIX/drive_c/windows/Fonts"
-TIM_VER="3.3.9.22051"
+TIM_VER="3.4.5.22071"
EXEC_PATH="c:/Program Files/Tencent/TIM/Bin/TIM.exe"
EXEC_FILE="$WINEPREFIX/drive_c/Program Files/Tencent/TIM/Bin/TIM.exe"
START_SHELL_PATH="/opt/deepinwine/tools/run_v4.sh"