aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVufa2023-02-24 19:16:53 +0800
committerVufa2023-02-24 19:16:53 +0800
commit793ade76f652567b06551178424f3a45cc908dbd (patch)
tree3d1ec79337a432da5f7ac56f6a2a89545f34e4fa
parent966ab90669886ec0694efa77e1445935a77d4551 (diff)
downloadaur-793ade76f652567b06551178424f3a45cc908dbd.tar.gz
Upgrade WeChat to '3.9.0.28'
Signed-off-by: Vufa <countstarlight@gmail.com>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
-rw-r--r--README.md34
-rw-r--r--reg.patch11
-rwxr-xr-xrun.sh13
6 files changed, 58 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8d93ad639f0..ebbeded5afb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = deepin-wine-wechat
pkgdesc = Tencent WeChat on Deepin Wine(com.qq.weixin.deepin) For Archlinux
- pkgver = 3.8.1.26
- pkgrel = 1
+ pkgver = 3.9.0.28
+ pkgrel = 2
url = https://weixin.qq.com/
install = deepin-wine-wechat.install
arch = x86_64
license = custom
depends = p7zip
- depends = deepin-wine6-stable>=6.0.0.39-1
- depends = deepin-wine-helper>=5.1.43_1-1
+ depends = lib32-udis86-git
+ depends = deepin-wine6-stable>=6.0.0.42-1
+ depends = deepin-wine-helper>=5.1.45_1-1
depends = xorg-xwininfo
depends = wqy-microhei
depends = lib32-alsa-lib
@@ -21,16 +22,18 @@ pkgbase = deepin-wine-wechat
optdepends = lib32-nvidia-utils: required for nvidia graphics card
conflicts = deepin-wechat
source = https://com-store-packages.uniontech.com/appstore/pool/appstore/c/com.qq.weixin.deepin/com.qq.weixin.deepin_3.4.0.38deepin6_i386.deb
- source = WeChatSetup-3.8.1.26.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
+ source = WeChatSetup-3.9.0.28.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
source = https://community-packages.deepin.com/deepin/pool/main/o/openldap/libldap-2.4-2_2.4.47+dfsg.4-1+eagle_i386.deb
source = https://community-packages.deepin.com/deepin/pool/main/c/cyrus-sasl2/libsasl2-2_2.1.27.1-1+dde_i386.deb
source = run.sh
- source = reg.patch
+ source = https://github.com/vufa/deepin-wine-wechat-arch/raw/action/mmmojo.dll
+ source = https://github.com/vufa/deepin-wine-wechat-arch/raw/action/mmmojo_64.dll
md5sums = 6c4edb108a0593bab7a556a6c9e8a012
- md5sums = 4f374b1a0961dc7ca734db90ebc5e635
+ md5sums = 3efd527ee04c027f401e3b0a460242c2
md5sums = cf87ad9db0bf279ddf9e5c1dce64a716
md5sums = 89b10711889f52ab0a386f37b4eb3212
- md5sums = 1a98e0a0ba0d740115e9e62523104011
- md5sums = 05b05416ef1fa4e1baaf64736e15a057
+ md5sums = 758b560950adccb5778a7347410efcf6
+ md5sums = e8296fadc17b303dd5c77e4a05677ebd
+ md5sums = 2aa6b65bd19bbde32432ea06c28cc33d
pkgname = deepin-wine-wechat
diff --git a/.gitignore b/.gitignore
index 1c009340eb21..fb4360a2c448 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,3 +7,4 @@
/WeChat*
/reg_tmp_fixed/
/reg_tmp/
+/*.dll
diff --git a/PKGBUILD b/PKGBUILD
index ae5aba01ca80..30db576ee0d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Vufa <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
-pkgver=3.8.1.26
+pkgver=3.9.0.28
wechat_installer=WeChatSetup
deepinwechatver=3.4.0.38deepin6
debpkgname="com.qq.weixin.deepin"
-pkgrel=1
+pkgrel=2
pkgdesc="Tencent WeChat on Deepin Wine(${debpkgname}) For Archlinux"
arch=("x86_64")
url="https://weixin.qq.com/"
license=('custom')
-depends=('p7zip' 'deepin-wine6-stable>=6.0.0.39-1' 'deepin-wine-helper>=5.1.43_1-1' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
+depends=('p7zip' 'lib32-udis86-git' 'deepin-wine6-stable>=6.0.0.42-1' 'deepin-wine-helper>=5.1.45_1-1' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
optdepends=('noto-fonts-sc: display some Chinese characters'
'lib32-nvidia-utils: required for nvidia graphics card')
conflicts=('deepin-wechat')
@@ -22,13 +22,15 @@ source=("$_mirror/appstore/pool/appstore/c/${debpkgname}/${debpkgname}_${deepinw
"$_mirror_lib/o/openldap/libldap-2.4-2_2.4.47+dfsg.4-1+eagle_i386.deb"
"$_mirror_lib/c/cyrus-sasl2/libsasl2-2_2.1.27.1-1+dde_i386.deb"
"run.sh"
- "reg.patch")
+ "https://github.com/vufa/deepin-wine-wechat-arch/raw/action/mmmojo.dll"
+ "https://github.com/vufa/deepin-wine-wechat-arch/raw/action/mmmojo_64.dll")
md5sums=('6c4edb108a0593bab7a556a6c9e8a012'
- '4f374b1a0961dc7ca734db90ebc5e635'
+ '3efd527ee04c027f401e3b0a460242c2'
'cf87ad9db0bf279ddf9e5c1dce64a716'
'89b10711889f52ab0a386f37b4eb3212'
- '1a98e0a0ba0d740115e9e62523104011'
- '05b05416ef1fa4e1baaf64736e15a057')
+ '758b560950adccb5778a7347410efcf6'
+ 'e8296fadc17b303dd5c77e4a05677ebd'
+ '2aa6b65bd19bbde32432ea06c28cc33d')
build() {
msg "Extracting DPKG package ..."
@@ -52,9 +54,12 @@ build() {
ln -sf "/usr/share/fonts/wenquanyi/wqy-microhei/wqy-microhei.ttc" "${srcdir}/deepinwechatdir/drive_c/windows/Fonts/wqy-microhei.ttc"
msg "Copying latest WeChat installer to ${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/ ..."
install -m644 "${srcdir}/${wechat_installer}-${pkgver}.exe" "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/"
- msg "Creating 'XPlugin/Plugins/XWeb' to forbid wechat browser creating crash logs ..."
- mkdir -p "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/"
- touch "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/XWeb"
+ msg "Copying mmmojo.dll and mmmojo_64.dll to ${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/ ..."
+ install -m644 "${srcdir}/mmmojo.dll" "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/"
+ install -m644 "${srcdir}/mmmojo_64.dll" "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/"
+ #msg "Creating 'XPlugin/Plugins/XWeb' to forbid wechat browser creating crash logs ..."
+ #mkdir -p "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/"
+ #touch "${srcdir}/deepinwechatdir/drive_c/users/@current_user@/Application Data/Tencent/WeChat/XPlugin/Plugins/XWeb"
#find -L "${srcdir}/deepinwechatdir/dosdevices" -maxdepth 1 -type l -delete
msg "Repackaging app archive ..."
7z a -t7z -r "${srcdir}/files.7z" "${srcdir}/deepinwechatdir/*"
diff --git a/README.md b/README.md
index c67e09fb55ab..77c5d76b0200 100644
--- a/README.md
+++ b/README.md
@@ -5,7 +5,7 @@
<img src="https://img.shields.io/github/actions/workflow/status/vufa/deepin-wine-wechat-arch/ci.yml?branch=action&logo=github&style=flat-square">
</a>
<a href="https://pc.weixin.qq.com/">
- <img src="https://img.shields.io/badge/WeChat-3.8.1.26-blue?style=flat-square&logo=wechat" alt="WeChat Version">
+ <img src="https://img.shields.io/badge/WeChat-3.9.0.28-blue?style=flat-square&logo=wechat" alt="WeChat Version">
</a>
<a href="https://aur.archlinux.org/packages/deepin-wine-wechat/">
<img src="https://img.shields.io/aur/version/deepin-wine-wechat?label=AUR&logo=arch-linux&style=flat-square" alt="AUR Version">
@@ -130,21 +130,22 @@ dpi,系统版本,目录映射等可以在 `winecfg` 进行设置,打开 `w
:warning: **注意:所有版本的摄像头均不可用**
-| 微信版本 | wine | 兼容性 | 备注 | deepin-wine | 兼容性 | 备注 |
-| :-----------------: | :-------: | :--------: | :---------------------------------------------------------------------------------------: | :---------: | :----: | :----------------------------------------------------------------------------------------------------------------------------------------------------------------------------: |
-| 3.8.0.41~ | \ | \ | \ | 6.0.0.39-1 | 部分 | 截图不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
-| 3.7.0.30~3.7.6.44 | \ | \ | \ | 6.0.0.24-1 | 部分 | 截图和表情包不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
-| 3.5.0.46~3.7.0.30 | \ | \ | \ | 6.0.0.24-1 | 部分 | 小程序和公众号可用,截图([#192](https://github.com/vufa/deepin-wine-wechat-arch/issues/192))和表情包不可用([#177](https://github.com/vufa/deepin-wine-wechat-arch/issues/188)) |
-| 3.3.0.93~3.5.0.46 | \ | \ | \ | 5.0.16-1 | 支持 | |
-| 3.2.1.141~3.2.1.154 | 6.6 | | 截图功能不可用:[#87](https://github.com/vufa/deepin-wine-wechat-arch/issues/87) | 5.0.16-1 | 支持 | |
-| 3.2.1.127 | 6.5 | 部分 | 群聊闪退&截图功能不可用:[#87](https://github.com/vufa/deepin-wine-wechat-arch/issues/87) | 5.0.16-1 | 支持 | |
-| 3.1.0.41~3.1.0.72 | 5.22~6.0 | 部分 | 截图功能不可用:[#73](https://github.com/vufa/deepin-wine-wechat-arch/issues/73) | 5.0.16-1 | 支持 | |
-| 3.0.0.57 | 5.22 | **不支持** | 微信安装程序不能启动:[#92](https://github.com/vufa/deepin-wine-wechat-arch/issues/92) | 5.0.16-1 | 支持 | |
-| 3.0.0.57 | 5.19 | 支持 | | 2.18_24-3 | 支持 | |
-| 2.8.0.106~2.9.5.56 | 4.19~5.13 | 部分 | 发送图片有问题: [#42](https://github.com/vufa/deepin-wine-wechat-arch/issues/42) | 2.18_22-3 | 部分 | 发送图片有问题: [#42](https://github.com/vufa/deepin-wine-wechat-arch/issues/42) |
-| 2.7.1.82~2.7.1.88 | 4.19+ | 支持 | | | | |
-| 2.7.1.82~2.7.1.88 | 4.17~4.18 | 部分 | 不能使用中文输入法 | 2.18_18-2 | 不支持 | 闪退 |
-| 2.6.8.65 | 4.16 | 支持 | | 2.18_18-2 | 支持 | |
+| 微信版本 | wine | 兼容性 | 备注 | deepin-wine | 兼容性 | 备注 |
+| :-----------------: | :-------: | :--------: | :----------------------------------------------------------: | :---------: | :----: | :----------------------------------------------------------: |
+| 3.9.0.28-2~ | \ | \ | \ | 6.0.0.42-1 | 部分 | 截图不可用 |
+| 3.8.0.41~3.8.1.26 | \ | \ | \ | 6.0.0.39-1 | 部分 | 截图不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
+| 3.7.0.30~3.7.6.44 | \ | \ | \ | 6.0.0.24-1 | 部分 | 截图和表情包不可用,内置浏览器出现问题([#225](https://github.com/vufa/deepin-wine-wechat-arch/issues/225)) |
+| 3.5.0.46~3.7.0.30 | \ | \ | \ | 6.0.0.24-1 | 部分 | 小程序和公众号可用,截图([#192](https://github.com/vufa/deepin-wine-wechat-arch/issues/192))和表情包不可用([#177](https://github.com/vufa/deepin-wine-wechat-arch/issues/188)) |
+| 3.3.0.93~3.5.0.46 | \ | \ | \ | 5.0.16-1 | 支持 | |
+| 3.2.1.141~3.2.1.154 | 6.6 | | 截图功能不可用:[#87](https://github.com/vufa/deepin-wine-wechat-arch/issues/87) | 5.0.16-1 | 支持 | |
+| 3.2.1.127 | 6.5 | 部分 | 群聊闪退&截图功能不可用:[#87](https://github.com/vufa/deepin-wine-wechat-arch/issues/87) | 5.0.16-1 | 支持 | |
+| 3.1.0.41~3.1.0.72 | 5.22~6.0 | 部分 | 截图功能不可用:[#73](https://github.com/vufa/deepin-wine-wechat-arch/issues/73) | 5.0.16-1 | 支持 | |
+| 3.0.0.57 | 5.22 | **不支持** | 微信安装程序不能启动:[#92](https://github.com/vufa/deepin-wine-wechat-arch/issues/92) | 5.0.16-1 | 支持 | |
+| 3.0.0.57 | 5.19 | 支持 | | 2.18_24-3 | 支持 | |
+| 2.8.0.106~2.9.5.56 | 4.19~5.13 | 部分 | 发送图片有问题: [#42](https://github.com/vufa/deepin-wine-wechat-arch/issues/42) | 2.18_22-3 | 部分 | 发送图片有问题: [#42](https://github.com/vufa/deepin-wine-wechat-arch/issues/42) |
+| 2.7.1.82~2.7.1.88 | 4.19+ | 支持 | | | | |
+| 2.7.1.82~2.7.1.88 | 4.17~4.18 | 部分 | 不能使用中文输入法 | 2.18_18-2 | 不支持 | 闪退 |
+| 2.6.8.65 | 4.16 | 支持 | | 2.18_18-2 | 支持 | |
## 切换到 `deepin-wine`
@@ -307,6 +308,7 @@ if __name__ == "__main__":
<details open>
<summary>2023</summary>
+- 2023-02-23 WeChat-3.9.0.28
- 2023-01-16 WeChat-3.8.1.26
</details>
diff --git a/reg.patch b/reg.patch
deleted file mode 100644
index 12dd66a8f83c..000000000000
--- a/reg.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN reg_tmp/user.reg reg_tmp_fixed/user.reg
---- reg_tmp/user.reg 2022-02-17 09:42:03.000000000 +0800
-+++ reg_tmp_fixed/user.reg 2022-07-21 23:09:44.174122163 +0800
-@@ -794,6 +794,7 @@
- "txupd.exe"=""
- "usp10"="native,builtin"
- "wechatupdate.exe"=""
-+"wechatplayer.exe"=""
-
- [Software\\Wine\\Drivers\\winepulse.drv] 1591000018
- #time=1d637ee6a5a1faa
diff --git a/run.sh b/run.sh
index 8bc55d6b64e8..e3028e17abd2 100755
--- a/run.sh
+++ b/run.sh
@@ -11,7 +11,7 @@ BOTTLENAME="Deepin-WeChat"
APPVER="3.4.0.38deepin6"
WINEPREFIX="$HOME/.deepinwine/$BOTTLENAME"
WECHAT_FONTS="$WINEPREFIX/drive_c/windows/Fonts"
-WECHAT_VER="3.8.1.26"
+WECHAT_VER="3.9.0.28"
EXEC_PATH="c:/Program Files/Tencent/WeChat/WeChat.exe"
EXEC_FILE="$WINEPREFIX/drive_c/Program Files/Tencent/WeChat/WeChat.exe"
START_SHELL_PATH="/opt/deepinwine/tools/run_v4.sh"
@@ -64,6 +64,7 @@ DeployApp() {
cp -n $HOME/.deepinwine/.wechat_tmp/* $WECHAT_FONTS/
rm -rf "$HOME/.deepinwine/.wechat_tmp"
fi
+
touch $WINEPREFIX/reinstalled
msg 0 "Creating $WINEPREFIX/PACKAGE_VERSION ..."
cat /opt/apps/$DEB_PACKAGE_NAME/files/files.md5sum >$WINEPREFIX/PACKAGE_VERSION
@@ -91,9 +92,19 @@ Run() {
fi
if [ -z "${EXEC_PATH##*.lnk*}" ]; then
+ # copy mmmojo.dll and mmmojo_64.dll
+ msg 0 "Copying mmmojo.dll and mmmojo_64.dll to $WINEPREFIX/drive_c/Program Files/Tencent/WeChat/[$WECHAT_VER]/"
+ cp -f "$WINEPREFIX/drive_c/Program Files/Tencent/mmmojo.dll" "$WINEPREFIX/drive_c/Program Files/Tencent/WeChat/[$WECHAT_VER]/"
+ cp -f "$WINEPREFIX/drive_c/Program Files/Tencent/mmmojo_64.dll" "$WINEPREFIX/drive_c/Program Files/Tencent/WeChat/[$WECHAT_VER]/"
+
msg 0 "Launching $EXEC_PATH lnk file ..."
$START_SHELL_PATH $BOTTLENAME $APPVER "C:/windows/command/start.exe" "/Unix" "$EXEC_PATH" "$@"
else
+ # copy mmmojo.dll and mmmojo_64.dll
+ msg 0 "Copying mmmojo.dll and mmmojo_64.dll to $WINEPREFIX/drive_c/Program Files/Tencent/WeChat/[$WECHAT_VER]/"
+ cp -f "$WINEPREFIX/drive_c/Program Files/Tencent/mmmojo.dll" "$WINEPREFIX/drive_c/Program Files/Tencent/WeChat/[$WECHAT_VER]/"
+ cp -f "$WINEPREFIX/drive_c/Program Files/Tencent/mmmojo_64.dll" "$WINEPREFIX/drive_c/Program Files/Tencent/WeChat/[$WECHAT_VER]/"
+
msg 0 "Launching $EXEC_PATH ..."
$START_SHELL_PATH $BOTTLENAME $APPVER "$EXEC_PATH" "$@"
fi