aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCountStarlight2019-04-03 21:26:47 +0800
committerCountStarlight2019-04-03 21:26:47 +0800
commita960e31d46e442b0c096cdd2a8513d010fcad286 (patch)
tree78de5024671629be7c495cd75904ee4c62ac2528
parent9f2dfa5f1acf7039c7b256207c6f177e7c681104 (diff)
downloadaur-a960e31d46e442b0c096cdd2a8513d010fcad286.tar.gz
Remove useless dependency packages.
Signed-off-by: CountStarlight <countstarlight@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rwxr-xr-xex.sh5
-rwxr-xr-xtar.sh18
4 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68d74933895a..e2b2c6eca610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,9 +11,7 @@ pkgbase = deepin-wine-wechat
depends = wine-mono
depends = wine_gecko
depends = xorg-xwininfo
- depends = xdotool
depends = wqy-microhei
- depends = adobe-source-han-sans-cn-fonts
depends = lib32-alsa-lib
depends = lib32-alsa-plugins
depends = lib32-libpulse
diff --git a/PKGBUILD b/PKGBUILD
index 38ddee351c48..fe2ae6c1b0a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Tencent WeChat (com.wechat) on Deepin Wine For Archlinux"
arch=("x86_64")
url="https://weixin.qq.com/"
license=('custom')
-depends=('p7zip' 'wine' 'wine-mono' 'wine_gecko' 'xorg-xwininfo' 'xdotool' 'wqy-microhei' 'adobe-source-han-sans-cn-fonts' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
+depends=('p7zip' 'wine' 'wine-mono' 'wine_gecko' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
conflicts=('deepin-wechat')
install="deepin-wine-wechat.install"
_mirror="https://mirrors.ustc.edu.cn/deepin"
@@ -35,7 +35,6 @@ build() {
cp update.policy "${srcdir}/deepinwechatdir/update.policy"
cp user.reg "${srcdir}/deepinwechatdir/user.reg"
ln -sf "/usr/share/fonts/wenquanyi/wqy-microhei/wqy-microhei.ttc" "${srcdir}/deepinwechatdir/drive_c/windows/Fonts/wqy-microhei.ttc"
- ln -sf "/usr/share/fonts/adobe-source-han-sans/SourceHanSansCN-Medium.otf" "${srcdir}/deepinwechatdir/drive_c/windows/Fonts/SourceHanSansCN-Medium.otf"
msg "Repackaging app archive ..."
7z a -t7z -r "${srcdir}/files.7z" "${srcdir}/deepinwechatdir/*"
}
diff --git a/ex.sh b/ex.sh
new file mode 100755
index 000000000000..15ebaeb26195
--- /dev/null
+++ b/ex.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+rm -rf reg_tmp && \
+ mkdir reg_tmp && \
+ tar xvjf reg_files.tar.bz2 -C reg_tmp
diff --git a/tar.sh b/tar.sh
new file mode 100755
index 000000000000..d282d2322fae
--- /dev/null
+++ b/tar.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+pre_reg_md5=`md5sum reg_files.tar.bz2|cut -d ' ' -f1`
+
+cd reg_tmp && \
+ tar -cvjSf reg_files.tar.bz2 * && \
+ mv reg_files.tar.bz2 ../ && \
+ cd ../
+
+new_reg_md5=`md5sum reg_files.tar.bz2|cut -d ' ' -f1`
+
+if [ "$pre_reg_md5" = "$new_reg_md5" ];
+then
+ echo -e "\033[33mReg files have not changed\033[0m"
+else
+ sed -i "s#$pre_reg_md5#$new_reg_md5#" PKGBUILD
+ echo Done
+fi