aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKm.Van2019-04-03 22:18:54 +0800
committerCountStarlight2019-04-03 22:19:45 +0800
commited6d2d1e4f17250df81b3d5fac2b4b05e361e69f (patch)
tree88acb240ec3876921fa68e363efa4ecc156fae61
parent2d1178830d44a97af79bab88c85da955ee440b20 (diff)
downloadaur-ed6d2d1e4f17250df81b3d5fac2b4b05e361e69f.tar.gz
Upgrade WeChat to 2.6.7.57.
Signed-off-by: CountStarlight <countstarlight@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD10
-rw-r--r--README.md14
-rwxr-xr-xrun.sh12
5 files changed, 34 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7d5064787ab..695edca64893 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deepin-wine-wechat
pkgdesc = Tencent WeChat (com.wechat) on Deepin Wine For Archlinux
- pkgver = 2.6.2
+ pkgver = 2.6.7.57
pkgrel = 1
url = https://weixin.qq.com/
install = deepin-wine-wechat.install
@@ -20,11 +20,13 @@ pkgbase = deepin-wine-wechat
depends = lib32-libldap
conflicts = deepin-wechat
source = https://mirrors.ustc.edu.cn/deepin/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_2.6.2.31deepin0_i386.deb
+ source = https://dlglobal.qq.com/weixin/Windows/WeChat_C1022.exe
source = run.sh
source = reg_files.tar.bz2
source = update.policy
md5sums = c66a173fe6817afd898e0061d9eaf42e
- md5sums = 8a47e1c10ff08a9592fbb5a76dc69982
+ md5sums = dbadd15d78384c68d33b19819eaaa9fe
+ md5sums = 7aa0649cf9ebd87db080d775e9d7a083
md5sums = 33809717e8c3d128b4925df060041e82
md5sums = a66646b473a3fbad243ac1afd64da07a
diff --git a/.gitignore b/.gitignore
index 687399ddcda4..ca56da6fa777 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
-.directory
-deepin.com.wechat*
-deepin-wine-wechat-*.tar.xz
-pkg/
-src/
+/deepin.com.wechat*
+/deepin-wine-wechat-*.tar.xz
+/pkg/
+/src/
+/WeChat_*
diff --git a/PKGBUILD b/PKGBUILD
index 0f6cf3ddc366..1d22b8eac332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: CountStarlight <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
-pkgver=2.6.2
+pkgver=2.6.7.57
+wechat_installer=WeChat_C1022
deepinwechatver=2.6.2.31deepin0
pkgrel=1
pkgdesc="Tencent WeChat (com.wechat) on Deepin Wine For Archlinux"
@@ -13,11 +14,13 @@ conflicts=('deepin-wechat')
install="deepin-wine-wechat.install"
_mirror="https://mirrors.ustc.edu.cn/deepin"
source=("$_mirror/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_${deepinwechatver}_i386.deb"
+ "https://dlglobal.qq.com/weixin/Windows/${wechat_installer}.exe"
"run.sh"
"reg_files.tar.bz2"
"update.policy")
md5sums=('c66a173fe6817afd898e0061d9eaf42e'
- '8a47e1c10ff08a9592fbb5a76dc69982'
+ 'dbadd15d78384c68d33b19819eaaa9fe'
+ '7aa0649cf9ebd87db080d775e9d7a083'
'33809717e8c3d128b4925df060041e82'
'a66646b473a3fbad243ac1afd64da07a')
@@ -28,6 +31,8 @@ build() {
sed "s/\(Categories.*$\)/\1Network;/" -i "${srcdir}/dpkgdir/usr/share/applications/deepin.com.wechat.desktop"
msg "Extracting Deepin Wine WeChat archive ..."
7z x -aoa "${srcdir}/dpkgdir/opt/deepinwine/apps/Deepin-WeChat/files.7z" -o"${srcdir}/deepinwechatdir"
+ msg "Removing original outdated WeChat directory ..."
+ rm -r "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/WeChat"
msg "Adding config files and fonts"
tar -jxvf reg_files.tar.bz2 -C "${srcdir}/"
cp userdef.reg "${srcdir}/deepinwechatdir/userdef.reg"
@@ -47,4 +52,5 @@ package() {
install -d "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat"
install -m644 "${srcdir}/files.7z" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
install -m755 "${srcdir}/run.sh" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
+ install -m644 "${srcdir}/${wechat_installer}.exe" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
}
diff --git a/README.md b/README.md
index bcd546173f52..c63590cdc66a 100644
--- a/README.md
+++ b/README.md
@@ -5,7 +5,7 @@
<img src="https://travis-ci.org/countstarlight/deepin-wine-wechat-arch.svg?branch=master" alt="Build Status">
</a>
<a href="https://pc.weixin.qq.com/">
- <img src="https://img.shields.io/badge/WeChat-2.6.2-blue.svg" alt="WeChat Version">
+ <img src="https://img.shields.io/badge/WeChat-2.6.7.57-blue.svg" alt="WeChat Version">
</a>
<a href="https://aur.archlinux.org/packages/deepin-wine-wechat/">
<img src="https://img.shields.io/aur/version/deepin-wine-wechat.svg" alt="AUR Version">
@@ -15,16 +15,13 @@
</a>
</p>
-Deepin打包的微信(WeChat)容器移植到Archlinux
+Deepin打包的微信(WeChat)容器移植到Archlinux,微信安装包替换为官方最新
- [安装](#安装)
- [常见问题](#常见问题)
- [感谢](#感谢)
- [更新日志](#更新日志)
-**注意:**
-微信最新版本是2.6.6(2019.1.3),经测试能正常运行,但不能固定下载的版本(下载文件名都是WeChatSetup,不能确定下载到的是2.6.6还是更新的版本,也没有找到提供历史版本下载),所以还是直接使用deepin官方打包的2.6.2版本。
-
## 安装
`deepin-wine-wechat`依赖`Multilib`仓库中的`wine`,`wine_gecko`和`wine-mono`,Archlinux默认没有开启`Multilib`仓库,需要编辑`/etc/pacman.conf`,取消对应行前面的注释([Archlinux wiki](https://wiki.archlinux.org/index.php/Official_repositories#multilib)):
@@ -57,13 +54,13 @@ yaourt deepin-wine-wechat
makepkg -si
```
-* 直接运行应用菜单中创建的WeChat快捷方式
-* 默认使用文泉驿微米黑(`wqy-microhei`)字体,要使用其他字体,如 微软雅黑或者微软宋体放进`~/.deepinwine/Deepin-TIM/drive_c/windows/Fonts`中。
+* 运行应用菜单中创建的WeChat,开始安装
+* 安装完可直接启动
## 常见问题
- [ ] 1.不能视频通话
-- [ ] 2.不能截图(微信2.6.2和最新的2.6.6,2019.1.3)
+- [ ] 2.不能截图
- [x] 3.在 2k/4k 屏幕下字体和图标都非常小, 参见[issue1](https://github.com/countstarlight/deepin-wine-tim-arch/issues/1)
- [x] 4.使用全局截图快捷键和解决Gnome上窗口化问题,参见[issue2](https://github.com/countstarlight/deepin-wine-tim-arch/issues/2)
@@ -73,4 +70,5 @@ yaourt deepin-wine-wechat
## 更新日志
+* 2019-04-03 WeChat-2.6.7.57
* 2019-01-03 WeChat-2.6.2 \ No newline at end of file
diff --git a/run.sh b/run.sh
index 1128682c0930..d042f263b7f8 100755
--- a/run.sh
+++ b/run.sh
@@ -8,6 +8,7 @@
WINEPREFIX="$HOME/.deepinwine/Deepin-WeChat"
APPDIR="/opt/deepinwine/apps/Deepin-WeChat"
APPVER="2.6.2.31deepin0"
+WECHAT_INSTALLER="WeChat_C1022"
APPTAR="files.7z"
PACKAGENAME="com.wechat"
WINE_CMD="wine"
@@ -21,7 +22,16 @@ HelpApp()
}
CallApp()
{
- env WINEPREFIX="$WINEPREFIX" WINEDEBUG=-msvcrt $WINE_CMD "c:\\Program Files\\Tencent\\WeChat\\WeChat.exe" &
+ if [ ! -f "$WINEPREFIX/reinstalled" ]
+ then
+ touch $WINEPREFIX/reinstalled
+ env WINEPREFIX="$WINEPREFIX" $WINE_CMD $APPDIR/$WECHAT_INSTALLER.exe
+ else
+ #Support use native file dialog
+ export ATTACH_FILE_DIALOG=1
+
+ env WINEPREFIX="$WINEPREFIX" WINEDEBUG=-msvcrt $WINE_CMD "c:\\Program Files\\Tencent\\WeChat\\WeChat.exe" &
+ fi
}
ExtractApp()
{