summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2021-06-22 04:11:23 +0800
committerzhullyb2021-06-22 04:11:23 +0800
commit7f9ca6ec75b34f685a3e3a1d89f8f729c759e032 (patch)
tree15ded11d68c2b05b0505640647015f3a2b583a3f
parent7fd7277e59aa5c9c124b2a26fafce51e22ccbedc (diff)
downloadaur-deepin.com.dingtalk.com.tar.gz
Update to 6.0.0.11902deepin1
-rw-r--r--.INSTALL12
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD58
-rw-r--r--README.md57
4 files changed, 90 insertions, 88 deletions
diff --git a/.INSTALL b/.INSTALL
index 62ce1391cda6..6962d03bdcc5 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -1,15 +1,11 @@
-#!/bin/sh
-
post_install() {
-sed "15a\export LC_CTYPE='zh_CN.UTF-8'" -i /opt/deepinwine/apps/Deepin-DingTalk/run.sh
-sed -i "s|deepin-wine|deepin-wine5|g" /opt/deepinwine/apps/Deepin-DingTalk/run.sh
+ echo "deleting the DingTalk bottle..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-DingTalk/ \;
}
-
post_upgrade() {
-sed "15a\export LC_CTYPE='zh_CN.UTF-8'" -i /opt/deepinwine/apps/Deepin-DingTalk/run.sh
-sed -i "s|deepin-wine|deepin-wine5|g" /opt/deepinwine/apps/Deepin-DingTalk/run.sh
+ echo "deleting the DingTalk bottle..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}Deepin-DingTalk/ \;
}
-
pre_remove() {
echo "deleting the DingTalk bottle..."
find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-DingTalk/ \;
diff --git a/.SRCINFO b/.SRCINFO
index 3d8394e6d887..539ebace1ab7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,47 @@
pkgbase = deepin.com.dingtalk.com
- pkgdesc = DingTalk Client on Deepin Wine
- pkgver = 5.1.28.12
- pkgrel = 2
- url = https://github.com/zhullyb/deepin.com.dingtalk.com
+ pkgdesc = Deepin Wine dingtalk
+ pkgver = 6.0.0.11902
+ pkgrel = 1
+ url = https://www.dingtalk.com/
install = .INSTALL
arch = i686
arch = x86_64
- license = custom
- depends = deepin-wine5
- depends = wqy-microhei
- source = https://github.com/zhullyb/deepin.com.dingtalk.com/releases/download/v5.1.28.12/deepin.com.dingtalk.com_5.1.28.12_i386.deb
- md5sums = 491e2c6229575bc9170450d497d41896
+ license = Proprietary
+ makedepends = tar
+ depends = lib32-alsa-plugins
+ depends = lib32-glib2
+ depends = lib32-glibc
+ depends = libgphoto2
+ depends = lib32-gst-plugins-base-libs
+ depends = lib32-lcms2
+ depends = lib32-libldap
+ depends = lib32-mpg123
+ depends = lib32-openal
+ depends = lib32-libpcap
+ depends = lib32-libcanberra-pulse
+ depends = lib32-libudev0-shim
+ depends = lib32-libusb
+ depends = lib32-vkd3d
+ depends = lib32-libx11
+ depends = lib32-libxext
+ depends = lib32-libxml2
+ depends = lib32-ocl-icd
+ depends = deepin-udis86
+ depends = lib32-zlib
+ depends = lib32-ncurses
+ depends = lib32-fontconfig
+ depends = lib32-freetype2
+ depends = lib32-gettext
+ depends = lib32-libxcursor
+ depends = lib32-mesa
+ depends = lib32-libjpeg6
+ depends = lib32-libxrandr
+ depends = lib32-libxi
+ depends = lib32-glu
+ noextract = deepin.com.dingtalk.com_6.0.0.11902deepin1_i386.deb
+ source = https://github.com/zhullyb/deepin.com.dingtalk.com/releases/download/v6.0.0.11902/deepin.com.dingtalk.com_6.0.0.11902deepin1_i386.deb
+ source = git+https://github.com/zhullyb/deepin.com.dingtalk.com.git
+ md5sums = 58aecd26cb5996de91a36dd5c5161127
+ md5sums = SKIP
pkgname = deepin.com.dingtalk.com
-
diff --git a/PKGBUILD b/PKGBUILD
index 06eb040ed125..7fbde07357c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,52 @@
-# Maintainer: zhullyb <5435486@qq.com>
+# Maintainer: zhullyb <zhullyb [at] outlook dot com>
pkgname=deepin.com.dingtalk.com
-pkgver=5.1.28.12
-pkgrel=2
-install=.INSTALL
-pkgdesc="DingTalk Client on Deepin Wine"
+pkgver=6.0.0.11902
+deepin=1
+pkgrel=1
+epoch=
+pkgdesc="Deepin Wine dingtalk"
arch=('i686' 'x86_64')
-url="https://github.com/zhullyb/deepin.com.dingtalk.com"
-license=('custom')
-depends=('deepin-wine5' 'wqy-microhei')
-source=("https://github.com/zhullyb/deepin.com.dingtalk.com/releases/download/v${pkgver}/deepin.com.dingtalk.com_${pkgver}_i386.deb")
-md5sums=('491e2c6229575bc9170450d497d41896')
+url="https://www.dingtalk.com/"
+license=('Proprietary')
+groups=()
+depends=(
+ 'lib32-alsa-plugins' 'lib32-glib2' 'lib32-glibc' 'libgphoto2'
+ 'lib32-gst-plugins-base-libs' 'lib32-lcms2' 'lib32-libldap' 'lib32-mpg123'
+ 'lib32-openal' 'lib32-libpcap' 'lib32-libcanberra-pulse' 'lib32-libudev0-shim'
+ 'lib32-libusb' 'lib32-vkd3d' 'lib32-libx11' 'lib32-libxext' 'lib32-libxml2'
+ 'lib32-ocl-icd' 'deepin-udis86' 'lib32-zlib' 'lib32-ncurses' 'lib32-fontconfig'
+ 'lib32-freetype2' 'lib32-gettext' 'lib32-libxcursor' 'lib32-mesa' 'lib32-libjpeg6'
+ 'lib32-libxrandr' 'lib32-libxi' 'lib32-glu'
+ )
+makedepends=('tar')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=.INSTALL
+changelog=
+source=("https://github.com/zhullyb/deepin.com.dingtalk.com/releases/download/v${pkgver}/${pkgname}_${pkgver}deepin${deepin}_i386.deb"
+ "git+https://github.com/zhullyb/deepin.com.dingtalk.com.git")
+noextract=("${pkgname}_${pkgver}deepin${deepin}_i386.deb")
+md5sums=('58aecd26cb5996de91a36dd5c5161127'
+ 'SKIP')
+validpgpkeys=()
+
prepare() {
- bsdtar -xf "$srcdir"/data.tar.xz
+ ar -x ${pkgname}_${pkgver}deepin${deepin}_i386.deb
+ mkdir ${pkgname}_${pkgver}deepin${deepin}
+ tar -xf data.tar.xz --directory="${pkgname}_${pkgver}deepin${deepin}"
}
+
package() {
- cd "$srcdir"
- mv opt usr "$pkgdir"
+ cd "${pkgname}_${pkgver}deepin${deepin}"
+ cp -r ./ ${pkgdir}/
+
+ mkdir -p ${pkgdir}/usr/share/
+ mv ${srcdir}/deepin.com.dingtalk.com/icons/ ${pkgdir}/usr/share/
+ mv ${srcdir}/deepin.com.dingtalk.com/applications/ ${pkgdir}/usr/share/
}
diff --git a/README.md b/README.md
deleted file mode 100644
index 800afc6a4114..000000000000
--- a/README.md
+++ /dev/null
@@ -1,57 +0,0 @@
-# deepin.com.dingtalk.com(一份非官方的钉钉容器)
-
-> 前言:这份容器我参考了gorquan大佬的[QQMusic](https://github.com/gorquan/QQMusic)项目,很惭愧,未能在疫情开始的时候将其打包出来。
-
-* 当前版本:5.1.28.12
-
-* 更新时间:2020/9/30
-
-* 注意事项
-
- 1. 针对Arch系,我已经打包至AUR,仓库名为```deepin.com.dingtalk.com```
-
- 2. Issue中有人提到manjaro(archlinux或许也有)通过yay更新无法解决输入框无法显示的问题,需要卸载重装,我这里没有做进一步的测试,如果遇到此类问题可以参考[Issue3](https://github.com/zhullyb/deepin.com.dingtalk.com/issues/3#issuecomment-701110857)
-
- 3. 如果你的系统已经拥有deepin-wine5的运行环境,可以尝试切换到deepin-wine5以获得更好的体验
-
- ```bash
- sudo sed -i "s/deepin-wine/deepin-wine5/" /opt/deepinwine/apps/Deepin-DingTalk/run.sh
- ```
-
- 4. deepin-wine下运行可能会出现图标异常,可以打开设置中的**SVG支持**解决
-
- 5. 基于Debain的发行版可能遇到中文字体显示错误,通过安装中文字体或许可以解决,这里推荐```fonts-wqy-microhei```
-
- 6. Debain系发行版直接安装deb时可能遇上依赖错误,建议直接使用dpkg安装,命令如下:
-
- ```bash
- sudo dpkg -i XXX.deb
- ```
-
-* Fix
- * 2020/9/30
- * 修复输入框无法显示文字的bug [[3]](https://github.com/zhullyb/deepin.com.dingtalk.com/issues/3)
-
-* ISSUE和PR
- * 如果出现了问题或者有什么好的建议,欢迎提出ISSUE,我会及时进行处理
- * 如果有自己的想法且已经实现了,欢迎提交PR
-
-* 打包方式:详细的打包过程可以参考[gorquan大佬的blog](https://blogs.gorquan.cn),过段时间我会简述自己的打包过程
-
-* 依赖:
- * deepin-wine (>= 2.18-12)
- * deepin-wine32 (>= 2.18-12)
- * deepin-wine32-preloader (>= 2.18-12)
- * deepin-wine-helper (>= 1.2deepin8)
- * deepin-wine-uninstaller (>= 0.1deepin2)
-
-* 感谢名单
- * [钉钉官方](https://www.dingtalk.com/)
- * [deepin-wine](https://www.deepin.org)
- * [wszqkzqk](https://github.com/wszqkzqk/deepin-wine-ubuntu)
- * [gorquan](https://github.com/gorquan)
-
-* 最后
- * 该包不涉及任何反编译行为,希望能让更多Linux用户能够用上钉钉客户端,希望官方能够早日研发出Linux平台的钉钉
- * 该包仅限于提供给各位学习使用,请勿用于商业行为!
- * 如果引用包时请带上Github仓库链接,请不要直接占用成果,谢谢合作!