summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2020-07-04 22:33:34 +0800
committerzhullyb2020-07-04 22:33:34 +0800
commit98706d0382616392437daed92bb515e62f72d7db (patch)
tree112248c27014fd7c7a9f166fe6e8d3e81ecd35e1
parent1ff21b6c46281293c09df509c6d0b55c8b464984 (diff)
downloadaur-98706d0382616392437daed92bb515e62f72d7db.tar.gz
Set Chinese as the defaults and import wqy-microhei.ttc
-rw-r--r--.INSTALL12
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 5 deletions
diff --git a/.INSTALL b/.INSTALL
index 357ea755fdb2..f92735979d5f 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -1,10 +1,13 @@
#!/bin/sh
post_install() {
+sed "15a\export LC_CTYPE='zh_CN.UTF-8'" -i /opt/deepinwine/apps/Deepin-DingTalk/run.sh
+sed '16a\if [ ! -e /$HOME/.deepinwine/Deepin-Dingtalk/drive_c/windows/Fonts/wqy-microhei.ttc ]\nthen\n ln -sf /usr/share/fonts/wenquanyi/wqy-microhei/wqy-microhei.ttc /$HOME/.deepinwine/Deepin-DingTalk/drive_c/windows/Fonts/wqy-microhei.ttc\nfi\n' -i /opt/deepinwine/apps/Deepin-DingTalk/run.sh
echo "*****************************************************************************************"
echo " "
-echo "注:如果遇到图标变成口,请在钉钉的设置中打开SVG支持"
-echo "Note: If the icon becomes garbled, please turn on SVG support in the settings of dingtalk"
+echo " WARNING "
+echo "第一次打开钉钉会界面会有乱码,重新打开一次即可"
+echo "如果遇到图标消失(不显示),请在钉钉的设置中打开SVG支持"
echo " "
echo "*****************************************************************************************"
}
@@ -17,3 +20,8 @@ echo "Note: If the icon becomes garbled, please turn on SVG support in the setti
echo " "
echo "*****************************************************************************************"
}
+
+pre_remove() {
+ echo "deleting the DingTalk bottle..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-DingTalk/ \;
+}
diff --git a/.SRCINFO b/.SRCINFO
index 6eaf0d1be66f..89cbea32bd6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deepin.com.dingtalk.com
pkgdesc = DingTalk Client on Deepin Wine
pkgver = 5.1.9.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zhullyb/deepin.com.dingtalk.com
install = .INSTALL
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 762b728c4402..9e5962a79244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=deepin.com.dingtalk.com
pkgver=5.1.9.11
-pkgrel=1
+pkgrel=2
install=.INSTALL
pkgdesc="DingTalk Client on Deepin Wine"
arch=('i686' 'x86_64')
url="https://github.com/zhullyb/deepin.com.dingtalk.com"
license=('custom')
-depends=('deepin-wine')
+depends=('deepin-wine' 'wqy-microhei')
source=("https://github.com/zhullyb/deepin.com.dingtalk.com/releases/download/v${pkgver}/deepin.com.dingtalk.com_${pkgver}_i386.deb")
sha256sums=('489c66d72a031f13041ab1f37e9fbd01dea17d54ae0043c77c53e071575793fe')
prepare() {