summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2020-12-06 21:40:23 +0800
committerzhullyb2020-12-06 21:41:38 +0800
commit0028d33d78383dd767d2d3ffbf3e95079b87a74a (patch)
treea338d9bd8d9a216e012545670617d5670f5e21a7
parentdb33b69c6d44cbab08d1b31402e384ba4e086fb1 (diff)
downloadaur-0028d33d78383dd767d2d3ffbf3e95079b87a74a.tar.gz
Fix Path problem
-rw-r--r--.INSTALL6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rwxr-xr-xrun.sh1
4 files changed, 16 insertions, 8 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..3f198fe4a740
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+pre_remove() {
+ echo "deleting the DingTalk bottle..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-QQLight/ \;
+}
diff --git a/.SRCINFO b/.SRCINFO
index 71de4c689030..a495032652fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = deepin.com.qq.im.light
pkgdesc = Deepin Wine QQ Light 7.9.
pkgver = 7.9.14308deepin8
- pkgrel = 3
+ pkgrel = 4
url = http://im.qq.com/
+ install = .INSTALL
arch = i686
arch = x86_64
license = Proprietary
@@ -11,8 +12,8 @@ pkgbase = deepin.com.qq.im.light
noextract = deepin.com.qq.im.light_7.9.14308deepin8_i386.deb
source = https://packages.deepin.com/deepin/pool/non-free/d/deepin.com.qq.im.light/deepin.com.qq.im.light_7.9.14308deepin8_i386.deb
source = run.sh
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = a2472c420ee9037f530afc24d2e594ea
+ md5sums = 6999edb941d7e04a73e1582ec3b0f828
pkgname = deepin.com.qq.im.light
diff --git a/PKGBUILD b/PKGBUILD
index f32cd2a26485..814e16d03d91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zhullyb <zhullyb@outlook.com>
pkgname=deepin.com.qq.im.light
pkgver=7.9.14308deepin8
-pkgrel=3
+pkgrel=4
epoch=
pkgdesc="Deepin Wine QQ Light 7.9."
arch=('i686' 'x86_64')
@@ -17,13 +17,13 @@ conflicts=()
replaces=()
backup=()
options=()
-install=
+install=.INSTALL
changelog=
source=("https://packages.deepin.com/deepin/pool/non-free/d/${pkgname}/${pkgname}_${pkgver}_i386.deb"
"run.sh")
noextract=("${pkgname}_${pkgver}_i386.deb")
-md5sums=('SKIP'
- "SKIP")
+md5sums=('a2472c420ee9037f530afc24d2e594ea'
+ "6999edb941d7e04a73e1582ec3b0f828")
validpgpkeys=()
prepare() {
@@ -36,5 +36,5 @@ prepare() {
package() {
cd "${pkgname}-${pkgver}"
cp -r ./ ${pkgdir}/
-
+ mv ${pkgdir}/usr/local/share ${pkgdir}/usr/share
}
diff --git a/run.sh b/run.sh
index f8aed62ec953..5ca34c32a4fb 100755
--- a/run.sh
+++ b/run.sh
@@ -10,6 +10,7 @@ APPDIR="/opt/deepinwine/apps/Deepin-QQLight"
APPVER="7.9.14308deepin8"
APPTAR="files.7z"
PACKAGENAME="deepin.com.qq.im.light"
+export LC_CTYPE='en_US.UTF-8'
HelpApp()
{