summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-05-12 08:51:58 +0800
committerwenLiangcan2016-05-12 08:51:58 +0800
commit8b608de836665273bdb2e70739e9486c934646be (patch)
tree66639ac49f3d4500f1331b66f3a899fc8766623a
downloadaur-8b608de836665273bdb2e70739e9486c934646be.tar.gz
deepinwine-qqintl 0.1.3_2-1.
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD39
-rw-r--r--qqintl.pngbin0 -> 42444 bytes
-rw-r--r--wine-qqintl72
5 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eed48280e355
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Thu May 12 00:50:21 UTC 2016
+pkgbase = deepinwine-qqintl
+ pkgdesc = Wine QQ International 2012 by Deepin.
+ pkgver = 0.1.3_2
+ pkgrel = 1
+ url = http://www.imqq.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = wine
+ depends = wine-mono
+ depends = sh
+ conflicts = wine-qqintl
+ options = !strip
+ options = !emptydirs
+ source = wine-qqintl_0.1.3-2_i386.deb::http://downloads.sourceforge.net/deepinwine-qqintl/wine-qqintl_0.1.3-2_i386.deb
+ source = qqintl.png
+ source = wine-qqintl
+ md5sums = d0f3340da494a6b20c768b0bd51a999d
+ md5sums = 4068748799fe81a37120a7e3405f2283
+ md5sums = 84f607a1c81c583830f99b9d2256e559
+ depends_i686 = gtk2
+ depends_i686 = lcms
+ depends_i686 = ncurses
+ depends_i686 = alsa-plugins
+ depends_i686 = libsm
+ depends_i686 = libpng12
+ depends_x86_64 = lib32-gtk2
+ depends_x86_64 = lib32-lcms
+ depends_x86_64 = lib32-ncurses
+ depends_x86_64 = lib32-alsa-plugins
+ depends_x86_64 = lib32-libsm
+ depends_x86_64 = lib32-libpng12
+
+pkgname = deepinwine-qqintl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67c3720d075d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+### https://raw.github.com/github/gitignore/fa441f903154d8159ef71db23d4816d802450fef/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+*.deb
+
+pkg/
+src/
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0150de7b818
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+pkgname=deepinwine-qqintl
+pkgver=0.1.3_2
+_pkgver=${pkgver/_/-}
+pkgrel=1
+pkgdesc='Wine QQ International 2012 by Deepin.'
+arch=('i686' 'x86_64')
+url='http://www.imqq.com/'
+license=('custom')
+depends=('wine' 'wine-mono' 'sh')
+depends_i686=('gtk2' 'lcms' 'ncurses' 'alsa-plugins' 'libsm' 'libpng12')
+depends_x86_64=('lib32-gtk2' 'lib32-lcms' 'lib32-ncurses' 'lib32-alsa-plugins' 'lib32-libsm' 'lib32-libpng12')
+options=('!strip' '!emptydirs')
+conflicts=('wine-qqintl')
+source=("wine-qqintl_${_pkgver}_i386.deb::http://downloads.sourceforge.net/deepinwine-qqintl/wine-qqintl_${_pkgver}_i386.deb"
+ "qqintl.png"
+ "wine-qqintl")
+md5sums=('d0f3340da494a6b20c768b0bd51a999d'
+ '4068748799fe81a37120a7e3405f2283'
+ '84f607a1c81c583830f99b9d2256e559')
+
+build() {
+ bsdtar -xvf data.tar.gz
+}
+
+package() {
+ install -dm755 "${pkgdir}/opt/deepinwine"
+
+ cp -r './usr/share/deepinwine/'* "${pkgdir}/opt/deepinwine/"
+ rm -rf "${pkgdir}/opt/deepinwine/qqintl/"{'wine-qqintl','wine'}
+
+ install -Dm755 "wine-qqintl" "${pkgdir}/usr/bin/wine-qqintl"
+ install -Dm644 "qqintl.png" "${pkgdir}/usr/share/pixmaps/qqintl.png"
+ install -Dm644 "./usr/share/applications/qqintl.desktop" "${pkgdir}/usr/share/applications/qqintl.desktop"
+ install -Dm644 "./usr/share/doc/wine-qqintl/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+ install -Dm644 "./usr/share/doc/wine-qqintl/changelog.Debian.gz" "${pkgdir}/usr/share/man/man1/${pkgname}.1.gz"
+}
+
diff --git a/qqintl.png b/qqintl.png
new file mode 100644
index 000000000000..d1f7e25cfbd7
--- /dev/null
+++ b/qqintl.png
Binary files differ
diff --git a/wine-qqintl b/wine-qqintl
new file mode 100644
index 000000000000..cfe0a8598658
--- /dev/null
+++ b/wine-qqintl
@@ -0,0 +1,72 @@
+#!/bin/sh
+WINEPREFIX=$HOME/.deepinwine/qqintl
+APPDIR=/opt/deepinwine/qqintl
+EXECUTE=$WINEPREFIX/drive_c/Program\ Files/Tencent/QQIntl/Bin/QQ.exe
+APPTAR=QQIntl.tar.gz
+WINEDIR=/usr
+PACKAGENAME=Deepinwine-QQIntl
+
+helpapp()
+{
+ echo " Commands:"
+ echo " -r/--reinstall Fix error or reinstall $PACKAGENAME"
+ echo " -k/--kill Kill wine progrem"
+ echo " -e/--regedit Start regedit editor"
+ echo " -c/--winecfg Start winecfg to tweak wine environment"
+ echo " -h/--help Program help info"
+}
+reinstallapp()
+{
+ echo "Reinstall $PACKAGENAME....."
+ read -p "* Are you sure?(Y/N)" ANSWER
+ if [ "$ANSWER" = "Y" -o "$ANSWER" = "y" -o -z $ANSWER ];then
+ rm -r $WINEPREFIX
+ installapp
+ else
+ exit 0
+ fi
+}
+installapp()
+{
+ echo "Install $PACKAGENAME....."
+ if [ -e $WINEPREFIX ];then
+ echo "PACKAGE had installed,If has trouble, Please use --reinstall(-r) to reinstall $PACKAGENAME"
+ else
+ mkdir -p $WINEPREFIX
+ tar -xzf $APPDIR/$APPTAR -C $WINEPREFIX
+ env WINEPREFIX=$WINEPREFIX $WINEDIR/bin/wine "$EXECUTE"
+ fi
+}
+
+runapp()
+{
+ if [ -e $WINEPREFIX ];then
+ env WINEPREFIX=$WINEPREFIX $WINEDIR/bin/wine "$EXECUTE"
+ else
+ installapp
+ fi
+}
+case $1 in
+ "--reinstall"| "-r")
+ reinstallapp
+ ;;
+ "--kill"| "-k")
+ env WINEPREFIX=$WINEPREFIX $WINEDIR/bin/wineserver -k
+ ;;
+ "--regedit"| "-e")
+ env WINEPREFIX=$WINEPREFIX $WINEDIR/bin/regedit
+ ;;
+ "--winecfg"| "-c")
+ env WINEPREFIX=$WINEPREFIX $WINEDIR/bin/winecfg
+ ;;
+ "--help"| "-h")
+ helpapp
+ ;;
+ *)
+ if [ -z $1 ];then
+ runapp
+ else
+ echo "Invalid option: $1"
+ fi
+ ;;
+esac