summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxhe2017-08-20 13:37:25 +0800
committerxhe2017-08-20 13:37:25 +0800
commit5b1b02c650e893439d7f34cb4d1e390205445e2e (patch)
tree19148f33e1c7576ff2f42c556e2b3a36f915497f
downloadaur-5b1b02c650e893439d7f34cb4d1e390205445e2e.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
-rw-r--r--upnp_2.patch11
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f5d3e7739e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = deeponion
+ pkgdesc = DeepOnion (ONION) is a new PoW/PoS altcoin that is most secure. All the communications in DeepOnion network is done through the TOR network.
+ pkgver = r6.d0d33df
+ pkgrel = 1
+ url = https://github.com/deeponion/deeponion
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = miniupnpc
+ depends = libpng
+ depends = boost
+ depends = openssl-1.0
+ depends = libevent
+ depends = db
+ source = deeponion::git+https://github.com/deeponion/deeponion
+ source = upnp_2.patch
+ md5sums = SKIP
+ md5sums = 3c6aec679a55744df1fac1a8cb502505
+
+pkgname = deeponion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5194c4326591
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: xhebox <xw897002528 at gmail dot com>
+pkgname=deeponion
+pkgver=r6.d0d33df
+pkgrel=1
+pkgdesc="DeepOnion (ONION) is a new PoW/PoS altcoin that is most secure. All the communications in DeepOnion network is done through the TOR network."
+arch=('i686' 'x86_64')
+url="https://github.com/deeponion/deeponion"
+license=('MIT')
+depends=('miniupnpc' 'libpng' 'boost' 'openssl-1.0' 'libevent' 'db')
+source=("deeponion::git+https://github.com/deeponion/deeponion"
+"upnp_2.patch")
+md5sums=('SKIP'
+ '3c6aec679a55744df1fac1a8cb502505')
+
+pkgver() {
+ cd "$srcdir/deeponion"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 -i "$srcdir/upnp_2.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ cd src/leveldb
+ chmod +x ./build_detect_platform
+ make libleveldb.a libmemenv.a
+ cd -
+ cd src/
+ make -f makefile.unix \
+ CFLAGS="-I/usr/include/openssl-1.0" \
+ CXXFLAGS="-I/usr/include/openssl-1.0" \
+ LDFLAGS="-L/usr/lib/openssl-1.0"
+}
+
+package() {
+ cd "$srcdir/$pkgname/src"
+ install -D -m755 DeepOniond "$pkgdir/usr/bin/DeepOniond"
+ cd ..
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/upnp_2.patch b/upnp_2.patch
new file mode 100644
index 000000000000..894e6a756649
--- /dev/null
+++ b/upnp_2.patch
@@ -0,0 +1,11 @@
+--- deeponion/src/net.cpp 2017-08-19 23:55:38.023863100 +0800
++++ deeponion/src/net.cpp 2017-08-19 23:55:38.023863100 +0800
+@@ -1005,7 +1005,7 @@
+ #else
+ /* miniupnpc 1.6 */
+ int error = 0;
+- devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
++ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 0, &error);
+ #endif
+
+ struct UPNPUrls urls;