summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-04-25 15:00:15 +0200
committerMichel Zou2020-04-25 15:00:15 +0200
commit53e59fe0d787c3c8009d7568e9c00c41479e4c7b (patch)
tree5072020f91b22beafd0f22d9454114d142d4fdcd
parenta0e3a8dc5b8e6ebf927cb1c0f5145568c7082522 (diff)
downloadaur-53e59fe0d787c3c8009d7568e9c00c41479e4c7b.tar.gz
simplify
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3301c1a08268..870a87a53bef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,16 +36,14 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver//_/-}/native_client"
make deepspeech
- cd python
- make bindings
+ make bindings -C python
}
package_deepspeech() {
depends=('sox')
cd "${srcdir}/${_pkgname}-${pkgver//_/-}/native_client"
PREFIX="${pkgdir}"/usr make install
- install -d "${pkgdir}"/usr/include
- install -m644 deepspeech.h "${pkgdir}"/usr/include
+ install -Dm644 deepspeech.h "${pkgdir}"/usr/include/deepspeech.h
}
package_python-deepspeech() {
@@ -54,5 +52,4 @@ package_python-deepspeech() {
cd "${srcdir}/${_pkgname}-${pkgver//_/-}/native_client"
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps python/dist/deepspeech*.whl
mv "$pkgdir/usr/bin/deepspeech" "$pkgdir/usr/bin/deepspeech_python"
- rm -rf "$pkgdir/usr/lib/python3.?/site-packages/deepspeech/lib"
}