summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Brown2019-05-19 16:03:08 -0400
committerBenjamin Brown2019-05-19 16:03:08 -0400
commit3171f584f47d3e7a129a782f2c4896626ecf55df (patch)
treeb5de63d26e23017f9b336cce33d67615535fc535
downloadaur-3171f584f47d3e7a129a782f2c4896626ecf55df.tar.gz
Initial commit with version 0.4.1.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..057f99e4eb58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = deepspeech-models
+ pkgdesc = A TensorFlow implementation of Baidu's DeepSpeech architecture - models and supporting files.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/mozilla/DeepSpeech
+ arch = any
+ license = MPL2
+ provides = deepspeech-models
+ source = https://github.com/mozilla/DeepSpeech/releases/download/v0.4.1/deepspeech-0.4.1-models.tar.gz
+ sha512sums = 804e97c22f83beefca9e54056f1c6d55499440171fd6cf7737b83895a847ede5bbd3d65dd196280d15ac239259573757069d209401478cd2f6eddbbeff4aaf35
+
+pkgname = deepspeech-models
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f08f1575a0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Benjamin Brown <brown.benjam@husky.neu.edu>
+pkgname=deepspeech-models
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A TensorFlow implementation of Baidu's DeepSpeech architecture - models and supporting files."
+arch=('any')
+url="https://github.com/mozilla/DeepSpeech"
+license=('MPL2')
+provides=('deepspeech-models')
+
+# Set all sources.
+_src_base_url="https://github.com/mozilla/DeepSpeech/releases/download/v$pkgver"
+source=("$_src_base_url/deepspeech-$pkgver-models.tar.gz")
+sha512sums=('804e97c22f83beefca9e54056f1c6d55499440171fd6cf7737b83895a847ede5bbd3d65dd196280d15ac239259573757069d209401478cd2f6eddbbeff4aaf35')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/mozilla/deepspeech/models"
+ install -Dm 444 "models/output_graph.pbmm" "models/alphabet.txt" "models/lm.binary" "models/trie" "$pkgdir/usr/share/mozilla/deepspeech/models"
+}