summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDev-Aligator2023-10-02 22:03:01 +0700
committerDev-Aligator2023-10-02 22:03:01 +0700
commitfe6d05383215db50b32df3a05c3c5ff83601443c (patch)
tree3946ffed79c50bb06056264b1388c8a45eb15e26
downloadaur-fe6d05383215db50b32df3a05c3c5ff83601443c.tar.gz
my first ever aur package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fb6b8aec036
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = deeptitle
+ pkgdesc = DeepTitle - An automatic subtitle translator
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Dev-Aligator/deeptitle
+ arch = any
+ license = MIT
+ source = git+https://github.com/Dev-Aligator/deeptitle.git
+ sha256sums = SKIP
+
+pkgname = deeptitle
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aad16e7fa8f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nguyen Hoang Tan <devaligator1004@gmail.com>
+pkgname=deeptitle
+pkgver=1.0.0 # Replace with the actual version of your script
+pkgrel=1
+pkgdesc="DeepTitle - An automatic subtitle translator"
+arch=('any')
+url="https://github.com/Dev-Aligator/deeptitle" # Replace with your project's URL
+license=('MIT') # License of your project
+
+#source=("$pkgname-$pkgver::https://github.com/Dev-Aligator/DeepTitle/archive/v$pkgver.tar.gz")
+source=("git+https://github.com/Dev-Aligator/deeptitle.git")
+sha256sums=('SKIP') # You can skip this for now
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 models.py "$pkgdir/usr/bin/deeptitle-packages/models.py"
+ install -Dm755 main.py "$pkgdir/usr/bin/deeptitle-packages/main.py"
+ install -Dm755 scripts.sh "$pkgdir/usr/bin/$pkgname" # Install 'scripts.sh' as a wrapper script
+}