summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2021-07-22 14:08:57 +0200
committerSibren Vasse2021-07-22 14:09:24 +0200
commit9e861000b7b342fe6f9cfb6d5fe76cecfdcda94e (patch)
treeb3328c8ac1b925cc798f114243e151e4fe13345a
parent72be5b81d1b07933d01afd3bbe38b2bd0db280e0 (diff)
downloadaur-9e861000b7b342fe6f9cfb6d5fe76cecfdcda94e.tar.gz
v5.30.20
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--start-hidden-on-tray.patch19
3 files changed, 31 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d46b5a2fbc3f..84c19695c421 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deezer
pkgdesc = A proprietary music streaming service
- pkgver = 5.30.10
+ pkgver = 5.30.20
pkgrel = 1
url = https://www.deezer.com/
arch = any
@@ -13,13 +13,15 @@ pkgbase = deezer
makedepends = nodejs
depends = electron
provides = deezer
- source = deezer-5.30.10-setup.exe::https://www.deezer.com/desktop/download/artifact/win32/x86/5.30.10
+ source = deezer-5.30.20-setup.exe::https://www.deezer.com/desktop/download/artifact/win32/x86/5.30.20
source = deezer.desktop
source = deezer
+ source = start-hidden-on-tray.patch
source = quit.patch
- sha256sums = 9741cd8538658a9dccd76167d51b4f93bb8d2b4b5e00f6f608a8b9bb3e17ddc8
+ sha256sums = 004c04be35ac76251abae916409e99993e1e34f9adda9eedd1f6a8c5840289fe
sha256sums = f8a5279239b56082a5c85487b0c261fb332623f27dac3ec8093458b8c55d8d99
sha256sums = 8717ba2de9cabc5c0a35780315871329c15bde5ff46c4f0bf859a87e42aa96f5
+ sha256sums = 2254632a03ca2cf7ae6b50a4109b0bec417cf0db6d669a8037125d13488e3b9f
sha256sums = d3f96ae6019abb60aa097919b22b1873f83061ed7453cd251e43b3afe5d54919
pkgname = deezer
diff --git a/PKGBUILD b/PKGBUILD
index f6e47687f999..161a9c39ea2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
# Contributor: Ilya Gulya <ilyagulya@gmail.com>
pkgname="deezer"
-pkgver=5.30.10
+pkgver=5.30.20
pkgrel=1
pkgdesc="A proprietary music streaming service"
arch=('any')
@@ -13,10 +13,12 @@ makedepends=('p7zip' 'asar' 'prettier' 'imagemagick' 'npm' 'nodejs')
source=("$pkgname-$pkgver-setup.exe::https://www.deezer.com/desktop/download/artifact/win32/x86/$pkgver"
"$pkgname.desktop"
deezer
+ start-hidden-on-tray.patch
quit.patch)
-sha256sums=('9741cd8538658a9dccd76167d51b4f93bb8d2b4b5e00f6f608a8b9bb3e17ddc8'
+sha256sums=('004c04be35ac76251abae916409e99993e1e34f9adda9eedd1f6a8c5840289fe'
'f8a5279239b56082a5c85487b0c261fb332623f27dac3ec8093458b8c55d8d99'
'8717ba2de9cabc5c0a35780315871329c15bde5ff46c4f0bf859a87e42aa96f5'
+ '2254632a03ca2cf7ae6b50a4109b0bec417cf0db6d669a8037125d13488e3b9f'
'd3f96ae6019abb60aa097919b22b1873f83061ed7453cd251e43b3afe5d54919')
prepare() {
@@ -37,7 +39,9 @@ prepare() {
prettier --write "build/*.js"
# Hide to tray (https://github.com/SibrenVasse/deezer/issues/4)
- patch -p1 <"$srcdir/quit.patch"
+ patch --forward --strip=1 --input="$srcdir/quit.patch"
+ # Add start in tray cli option (https://github.com/SibrenVasse/deezer/pull/12)
+ patch --forward --strip=1 --input="$srcdir/start-hidden-on-tray.patch"
cd "$srcdir/resources/"
asar pack app app.asar
diff --git a/start-hidden-on-tray.patch b/start-hidden-on-tray.patch
new file mode 100644
index 000000000000..ffc44b048dec
--- /dev/null
+++ b/start-hidden-on-tray.patch
@@ -0,0 +1,19 @@
+diff --git a/build/main.js b/build/main.js
+index 5066eef..592a6bc 100644
+--- a/build/main.js
++++ b/build/main.js
+@@ -3122,8 +3122,12 @@
+ finalMinSize[1]
+ );
+ }
+- isDev() ? this.window.showInactive() : this.window.show(),
+- this.thumbar.init();
++ if (!process.argv.some(arg => arg === '--start-in-tray')) {
++ isDev() ? this.window.showInactive() : this.window.show(),
++ this.thumbar.init();
++ } else {
++ this.window.hide();
++ }
+ }),
+ this.appService.enableDevMode();
+ }