summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2024-01-14 17:50:57 +0100
committerSibren Vasse2024-01-14 17:50:57 +0100
commite0195f61d2dd41d4d4e31ace72805a367eb788f0 (patch)
tree756d26591be716ae0e9642e4dd06033dc8140999
parent2ec9ba409808bbd8874e31017455573f632e9461 (diff)
downloadaur-e0195f61d2dd.tar.gz
Fix build with prettier 3.2.1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--fix-isDev-usage.patch40
3 files changed, 8 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6115413bdc0..0439cfb60e16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,7 +25,7 @@ pkgbase = deezer
sha256sums = b464dbfc0d426730259ce2abc660960ecc6a73bbef838b8fbbd15deb2f5dce53
sha256sums = ec87bbcc5a615c61c78bf117889d5b697a2174150722b1318205ad1c903286f2
sha256sums = 3566f3aa580b35a5af7f31831c36d579576a47286103a9b621051a8a38ac3180
- sha256sums = 731d25269ed260b386ad40937e38b6f56634cf7a13e2a98a8eaf53a778026161
+ sha256sums = a6b5ecc4ee5f22269eb872379b090f83b8875c31084780f30a9fe09d88e466eb
sha256sums = 505bc0363443f8a921361efb5f204a15afa7773e57fa386c2221ba1609b896c8
sha256sums = 78d26c08c234594eeba0ac68c95612a8c01ea4026f34e0141e8a997287b0af1b
sha256sums = f3b75aabbd3530c329e70a83ca89dba938eda34f61a31c6e66169f493ac21b04
diff --git a/PKGBUILD b/PKGBUILD
index 803346b7ac1e..6ca938491eef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ sha256sums=('62792c1fd94b4894c74c012229cc130e44ffd60dccaaaefb4f634063c3b54bd9'
'b464dbfc0d426730259ce2abc660960ecc6a73bbef838b8fbbd15deb2f5dce53'
'ec87bbcc5a615c61c78bf117889d5b697a2174150722b1318205ad1c903286f2'
'3566f3aa580b35a5af7f31831c36d579576a47286103a9b621051a8a38ac3180'
- '731d25269ed260b386ad40937e38b6f56634cf7a13e2a98a8eaf53a778026161'
+ 'a6b5ecc4ee5f22269eb872379b090f83b8875c31084780f30a9fe09d88e466eb'
'505bc0363443f8a921361efb5f204a15afa7773e57fa386c2221ba1609b896c8'
'78d26c08c234594eeba0ac68c95612a8c01ea4026f34e0141e8a997287b0af1b'
'f3b75aabbd3530c329e70a83ca89dba938eda34f61a31c6e66169f493ac21b04')
diff --git a/fix-isDev-usage.patch b/fix-isDev-usage.patch
index c38ee2fe6ba1..cd0e4a70f5dd 100644
--- a/fix-isDev-usage.patch
+++ b/fix-isDev-usage.patch
@@ -1,20 +1,8 @@
-From: Dorian Stoll <dorian.stoll@tmsp.io>
-Date: Sat, 5 Feb 2022 07:05:16 +0100
-Subject: [PATCH] Fix isDev() usage
-
-This stops the excessive logging, since parts of the app will not run in development
-mode anymore. It also stops the app from logging the urls for the mp3 files, which is
-against the Deezer TOS.
----
- build/main.js | 6 +++---
- build/preload.js | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
diff --git a/build/main.js b/build/main.js
-index 2da2ed1..88135ae 100644
+index e7a2cc5..2e1ebac 100644
--- a/build/main.js
+++ b/build/main.js
-@@ -1979,7 +1979,7 @@
+@@ -1975,7 +1975,7 @@
tags: Object.assign(
{ country: user.country, offerId: user.offerId },
{
@@ -23,10 +11,10 @@ index 2da2ed1..88135ae 100644
os: `${external_os_default().type()} ${external_os_default().release()}`,
"os.name": external_os_default().type(),
arch: process.arch,
-@@ -3268,10 +3268,10 @@
- (external_electron_log_default().transports.console.format = `{h}:{i}:{s}.{ms} ({processType}/{level}) ${
- isPlatform(PLATFORM.WINDOWS) ? ">" : "›"
- } {text}`),
+@@ -3255,10 +3255,10 @@
+ processType: isProcessMain() ? "main" : process.type,
+ }),
+ (external_electron_log_default().transports.console.format = `{h}:{i}:{s}.{ms} ({processType}/{level}) ${isPlatform(PLATFORM.WINDOWS) ? ">" : "›"} {text}`),
- (external_electron_log_default().transports.console.level = isDev
+ (external_electron_log_default().transports.console.level = isDev()
? "silly"
@@ -36,19 +24,3 @@ index 2da2ed1..88135ae 100644
? "silly"
: "warn"),
(external_electron_log_default().transports.sentry = function (msg) {
-diff --git a/build/preload.js b/build/preload.js
-index a8bb8d6..73dc8b4 100644
---- a/build/preload.js
-+++ b/build/preload.js
-@@ -490,7 +490,7 @@
- }
- getSentryTags() {
- return {
-- environment: isDev ? "development" : "production",
-+ environment: isDev() ? "development" : "production",
- os: `${external_os_default().type()} ${external_os_default().release()}`,
- "os.name": external_os_default().type(),
- arch: process.arch,
---
-2.34.1
-