summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchristian2021-06-21 21:39:21 +0200
committerchristian2021-06-21 21:39:21 +0200
commitc0c3edf4a9e5e6a085d590f01034b1512994220a (patch)
tree5d9a2f3464c62db4d828d266351f811d30465937
parent17760eddd1b24893a3ce08d00153634361281548 (diff)
downloadaur-c0c3edf4a9e5e6a085d590f01034b1512994220a.tar.gz
adds generating and updating .SRCINFO
-rw-r--r--.gitlab-ci.yml7
1 files changed, 6 insertions, 1 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index ceb6af243eb0..262ac7ce44bb 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -23,10 +23,13 @@ makepkg:
- sudo -u builder makepkg -C -S --log --noconfirm
# Test building and installing the package
- sudo -u builder makepkg -C -i --log --noconfirm
+ # generate SRCINFO
+ - sudo -u builder makepkg --printsrcinfo > .SRCINFO
cache:
- key: pkgbuild
+ key: makepkg
paths:
- PKGBUILD
+ - .SRCINFO
namcap:
tags:
@@ -45,6 +48,8 @@ push:
script:
- git add PKGBUILD
- git diff-index --quiet HEAD || git commit -m "updates hash for AppImage"
+ - git add .SRCINFO
+ - git diff-index --quiet HEAD || git commit -m "updates .SRCINFO"
- git push -o ci.skip "https://${GITLAB_USER_NAME}:${RENOVATE_TOKEN}@${CI_REPOSITORY_URL#*@}" "HEAD:${CI_COMMIT_BRANCH}"
rules:
- if: '$CI_PIPELINE_SOURCE != "merge_request_event"'