summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-08-13 01:20:53 +0800
committerChocobo12020-08-13 01:21:21 +0800
commit9bb2d040063b4cc54343a36a39cbdf10d23adb61 (patch)
tree8e1b96fec25ed309b75fcce0c424559800080793
downloadaur-9bb2d040063b4cc54343a36a39cbdf10d23adb61.tar.gz
newpkg: deheader-git 1.7.r0.g571921f-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ca0027120f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = deheader-git
+ pkgdesc = Find and remove unneeded includes in C/C++ sourcefiles
+ pkgver = 1.7.r0.g571921f
+ pkgrel = 1
+ url = http://www.catb.org/~esr/deheader/
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ makedepends = xmlto
+ depends = python
+ provides = deheader
+ conflicts = deheader
+ source = git+https://gitlab.com/esr/deheader.git
+ sha256sums = SKIP
+
+pkgname = deheader-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bff545c0fd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=deheader-git
+pkgver=1.7.r0.g571921f
+pkgrel=1
+pkgdesc="Find and remove unneeded includes in C/C++ sourcefiles"
+arch=('any')
+url="http://www.catb.org/~esr/deheader/"
+license=('BSD')
+depends=('python')
+makedepends=('git' 'docbook-xml' 'docbook-xsl' 'xmlto')
+provides=('deheader')
+conflicts=('deheader')
+source=("git+https://gitlab.com/esr/deheader.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "deheader"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "deheader"
+
+ make
+}
+
+check() {
+ cd "deheader"
+
+ make check
+}
+
+package() {
+ cd "deheader"
+
+ install -Dm755 "deheader" -t "$pkgdir/usr/bin"
+ install -Dm644 "deheader.1" -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/deheader"
+}