summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCork2020-01-29 18:49:05 +0100
committerCork2020-01-29 18:49:05 +0100
commit0a89aeed5e2cf20555d247237ba5e4f2903f05ec (patch)
treed85dccc59083f825b16f185fdd8c96b39e992f74
downloadaur-0a89aeed5e2cf20555d247237ba5e4f2903f05ec.tar.gz
First version of dejsonlz4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5703598fad6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dejsonlz4-git
+ pkgdesc = Decompress Mozilla Firefox bookmarks backup files
+ pkgver = 9.c4305b8
+ pkgrel = 1
+ url = https://github.com/avih/dejsonlz4
+ arch = x86_64
+ license = other
+ source = dejsonlz4-git::git+https://github.com/avih/dejsonlz4
+ sha256sums = SKIP
+
+pkgname = dejsonlz4-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c4578f1047f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=dejsonlz4-git
+pkgver=9.c4305b8
+pkgrel=1
+pkgdesc='Decompress Mozilla Firefox bookmarks backup files'
+arch=('x86_64')
+url='https://github.com/avih/dejsonlz4'
+license=('other')
+depends=()
+makedepends=()
+source=("${pkgname}::git+https://github.com/avih/dejsonlz4")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ gcc -Wall -o dejsonlz4 src/dejsonlz4.c src/lz4.c
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -D "dejsonlz4" "$pkgdir/usr/bin/dejsonlz4"
+}
+