summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-03-03 15:24:39 +0100
committerJP Cimalando2018-03-03 15:26:04 +0100
commit0245015ab73414da1a01aeea4bb1fd10e7140efa (patch)
tree303181d722d385efe0795a66445d6e5cb11040ce
parent5ad5d2d5ef5fc26faaffc612b28c04ea451af250 (diff)
downloadaur-0245015ab73414da1a01aeea4bb1fd10e7140efa.tar.gz
new release: use system dependencies instead of virtualenv
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
-rw-r--r--deken.sh3
-rw-r--r--easywebdav2.diff24
-rw-r--r--hy-0.14.diff15
5 files changed, 40 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d412755bd8d7..2c229ecf1226 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,26 @@
pkgbase = deken-git
pkgdesc = Externals wrangler for Pure Data
- pkgver = v0.2.6.r92.ga427c41
- pkgrel = 1
+ pkgver = v0.2.6.r125.gcb599c6
+ pkgrel = 2
url = https://puredata.info/docs/Deken
- arch = i686
- arch = x86_64
+ arch = any
license = custom:BSD
- depends = python
+ depends = hy
+ depends = python-easywebdav
+ depends = python-pyelftools
+ depends = python-macholib
+ depends = python-pefile
+ depends = python-gnupg
+ depends = python-keyring
+ depends = python-ndg-httpsclient
+ depends = python-pyasn1
+ depends = python-pyopenssl
provides = deken
conflicts = deken
source = git+https://github.com/pure-data/deken
- source = deken.sh
- source = easywebdav2.diff
+ source = hy-0.14.diff
md5sums = SKIP
- md5sums = bed7b62180a82ff6f89d414cccc70af1
- md5sums = d2a170f510cea077e0a27b99628eaa46
+ md5sums = 9f6911515de9a79f81a0f385aed1f772
pkgname = deken-git
diff --git a/PKGBUILD b/PKGBUILD
index 232ff8cef1f5..d645e5320ca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: JP Cimalando <jp-dev@inbox.ru>
pkgname=deken-git
_pkgname=deken
-pkgver=v0.2.6.r92.ga427c41
-pkgrel=1
+pkgver=v0.2.6.r125.gcb599c6
+pkgrel=2
epoch=
pkgdesc="Externals wrangler for Pure Data"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://puredata.info/docs/Deken"
license=('custom:BSD')
groups=()
-depends=('python')
+depends=('hy' 'python-easywebdav' 'python-pyelftools' 'python-macholib'
+ 'python-pefile' 'python-gnupg' 'python-keyring'
+ 'python-ndg-httpsclient' 'python-pyasn1' 'python-pyopenssl')
makedepends=()
checkdepends=()
optdepends=()
@@ -21,11 +23,9 @@ options=()
install=
changelog=
source=("git+https://github.com/pure-data/$_pkgname"
- 'deken.sh'
- 'easywebdav2.diff')
+ 'hy-0.14.diff')
md5sums=('SKIP'
- 'bed7b62180a82ff6f89d414cccc70af1'
- 'd2a170f510cea077e0a27b99628eaa46')
+ '9f6911515de9a79f81a0f385aed1f772')
noextract=()
validpgpkeys=()
@@ -36,21 +36,11 @@ pkgver() {
prepare() {
cd "$_pkgname"
- # easywebdav2 for python3 compatibility
- if ! grep -q easywebdav2 developer/requirements.txt; then
- patch -p1 -i "$srcdir/easywebdav2.diff"
- fi
+ patch -Np1 -i "$srcdir"/hy-0.14.diff
}
package() {
cd "$_pkgname"
- local DEKEN_HOME="$pkgdir/usr/lib/deken"
- install -D -m644 developer/requirements.txt "$DEKEN_HOME/requirements.txt"
- install -D -m644 developer/deken.hy "$DEKEN_HOME/deken.hy"
- DEKEN_HOME="$DEKEN_HOME" DEKEN_ROOT=1 developer/deken install
- "$pkgdir/usr/lib/deken/virtualenv-source/virtualenv.py" --relocatable "$pkgdir/usr/lib/deken/virtualenv"
- rm -f "$pkgdir"/usr/lib/deken/virtualenv/bin/activate{,.csh,.fish}
- rm -rf "$pkgdir"/usr/lib/deken/virtualenv{-source,.tar.gz}
- install -D -m755 "$srcdir/deken.sh" "$pkgdir/usr/bin/deken"
+ install -D -m755 "developer/deken.hy" "$pkgdir/usr/bin/deken"
install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
diff --git a/deken.sh b/deken.sh
deleted file mode 100644
index 3cae6d00a634..000000000000
--- a/deken.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh -e
-export DEKEN_HOME="/usr/lib/deken"
-exec "$DEKEN_HOME"/virtualenv/bin/hy "$DEKEN_HOME"/deken.hy "$@"
diff --git a/easywebdav2.diff b/easywebdav2.diff
deleted file mode 100644
index 75e6a41114ea..000000000000
--- a/easywebdav2.diff
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/developer/deken.hy b/developer/deken.hy
-index 7921bcd..e383a31 100644
---- a/developer/deken.hy
-+++ b/developer/deken.hy
-@@ -527,7 +527,7 @@
- (% "Couldn't upload to %s!\n" url)
- (% "Are you sure you have the correct username and password set for '%s'?\n" host)
- (% "Please ensure the folder '%s' exists on the server and is writeable." path))))))
-- (import easywebdav)
-+ (import [easywebdav2 :as easywebdav])
- (if filepath
- (do
- (setv filename (os.path.basename filepath))
-diff --git a/developer/requirements.txt b/developer/requirements.txt
-index 7904770..c76f5a4 100644
---- a/developer/requirements.txt
-+++ b/developer/requirements.txt
-@@ -1,5 +1,5 @@
- hy==0.12.1
--easywebdav==1.2.0
-+easywebdav2==1.3.0
- pyelftools==0.24
- macholib==1.9
- pefile==2017.11.5
diff --git a/hy-0.14.diff b/hy-0.14.diff
new file mode 100644
index 000000000000..59bbc258dcdc
--- /dev/null
+++ b/hy-0.14.diff
@@ -0,0 +1,15 @@
+diff --git a/developer/deken.hy b/developer/deken.hy
+index 4fb4c30..ec9f41a 100644
+--- a/developer/deken.hy
++++ b/developer/deken.hy
+@@ -66,6 +66,10 @@
+ (defn cut-slice [x y z] (cut x y z))
+ (try (cut []) (except [e NameError] (defn cut-slice [x y z] (slice x y z))))
+
++;; apply has been removed from hy-0.12
++(defmacro apply [f &optional (args []) (kwargs {})]
++ `(~f #* ~args #** ~kwargs))
++
+ ;; convert a string into bytes
+ (defn str-to-bytes [s] (try (bytes s) (except [e TypeError] (bytes s "utf-8"))))
+