summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilbert Gilb's2018-09-23 22:40:23 +0200
committerGilbert Gilb's2018-09-25 21:23:11 +0200
commit3693f6d432dfcaa1eeb8d00ad7aee1d9e01517bd (patch)
tree86f00cd9ffcc11e0763f7be4fae7b372f7ff4ed2
downloadaur-3693f6d432dfcaa1eeb8d00ad7aee1d9e01517bd.tar.gz
Add initial pkgbuild.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--dell-bios-fan-control.service12
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85a32c3fce44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dell-bios-fan-control-git
+ pkgdesc = A user space utility to set control of fans by bios on some Dell XPS Laptops.
+ pkgver = r3.a2c81a2
+ pkgrel = 1
+ url = https://github.com/TomFreudenberg/dell-bios-fan-control
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ optdepends = i8kutils: to control Dell laptop system temperature
+ source = git+https://github.com/TomFreudenberg/dell-bios-fan-control.git
+ source = dell-bios-fan-control.service
+ sha256sums = SKIP
+ sha256sums = c090e883d8aa4942cb6f4d9c2aeaa353f7c49ec83a0fa0fc404bceafb42e4ab0
+
+pkgname = dell-bios-fan-control-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e2018c000b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gilbert Gilb's <gilbsgilbert@gmail.com>
+
+_reponame=dell-bios-fan-control
+pkgname=dell-bios-fan-control-git
+pkgver=r3.a2c81a2
+pkgrel=1
+pkgdesc="A user space utility to set control of fans by bios on some Dell XPS Laptops."
+arch=('i686' 'x86_64')
+url="https://github.com/TomFreudenberg/dell-bios-fan-control"
+license=('GPL2')
+depends=('glibc')
+optdepends=('i8kutils: to control Dell laptop system temperature')
+makedepends=('git')
+conflicts=()
+provides=()
+source=('git+https://github.com/TomFreudenberg/dell-bios-fan-control.git'
+ 'dell-bios-fan-control.service')
+sha256sums=('SKIP'
+ 'c090e883d8aa4942cb6f4d9c2aeaa353f7c49ec83a0fa0fc404bceafb42e4ab0')
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' \
+ || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${_reponame}"
+ make
+}
+
+package() {
+ cd "${_reponame}"
+ install -D -m755 dell-bios-fan-control "${pkgdir}/usr/bin/dell-bios-fan-control"
+ install -D -m644 ../dell-bios-fan-control.service "${pkgdir}/usr/lib/systemd/system/dell-bios-fan-control.service"
+}
diff --git a/dell-bios-fan-control.service b/dell-bios-fan-control.service
new file mode 100644
index 000000000000..e1db1e0633dc
--- /dev/null
+++ b/dell-bios-fan-control.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Disables BIOS control of fans at boot.
+Before=i8kmon.service
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/dell-bios-fan-control 0
+RemainAfterExit=true
+ExecStop=/usr/bin/dell-bios-fan-control 1
+
+[Install]
+WantedBy=multi-user.target