summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCem Kaya2023-03-09 17:02:07 +0100
committerCem Kaya2023-03-09 17:02:07 +0100
commitfb772d4b33c6710c2a9cf0b290a57ead71b57d15 (patch)
tree0d07b50ee3e8baae821f61e33f608ff4a7eda757
downloadaur-fb772d4b33c6710c2a9cf0b290a57ead71b57d15.tar.gz
Initial version.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7505cfa71888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dell-g15-ledcontrol
+ pkgdesc = GUI RGB led controller for dell g15 and some other alienware laptops.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/cemkaya-mpi/Dell-G15-LedControl
+ arch = x86_64
+ license = GPLv3
+ depends = python
+ depends = python-pyusb
+ depends = pyside6
+ source = dell-g15-ledcontrol::https://github.com/cemkaya-mpi/Dell-G15-LedControl/archive/refs/tags/v1.0.tar.gz
+ sha256sums = b8c6a9f53844a07d8a3515aafcfdd0b0abdfc3c415622d0e7a60792045c55981
+
+pkgname = dell-g15-ledcontrol
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70a893e29263
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Cem Kaya<cemkaya.boun@gmail.com>
+# Contributor: Cem Kaya <cemkaya.boun@gmail.com>
+pkgname=dell-g15-ledcontrol
+pkgver=1.0
+pkgrel=1
+pkgdesc="GUI RGB led controller for dell g15 and some other alienware laptops."
+arch=('x86_64')
+url="https://github.com/cemkaya-mpi/Dell-G15-LedControl"
+license=('GPLv3')
+groups=()
+depends=('python' 'python-pyusb' 'pyside6')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::https://github.com/cemkaya-mpi/Dell-G15-LedControl/archive/refs/tags/v${pkgver}.tar.gz")
+noextract=()
+sha256sums=('b8c6a9f53844a07d8a3515aafcfdd0b0abdfc3c415622d0e7a60792045c55981')
+
+package() {
+ cd "${srcdir}/Dell-G15-LedControl-$pkgver"
+ #Create Directories
+ install -d "$pkgdir/opt/$pkgname/"
+ install -d "$pkgdir/etc/udev/rules.d/"
+ install -d "$pkgdir/usr/share/applications/"
+ #Udev rule
+ cp "00-aw-elc.rules" "$pkgdir/etc/udev/rules.d/00-aw-elc.rules"
+ #Copy files
+ cp "awelc.py" "$pkgdir/opt/$pkgname/awelc.py"
+ cp "elc_constants.py" "$pkgdir/opt/$pkgname/elc_constants.py"
+ cp "elc.py" "$pkgdir/opt/$pkgname/elc.py"
+ cp "hidreport.py" "$pkgdir/opt/$pkgname/hidreport.py"
+ cp "main.py" "$pkgdir/opt/$pkgname/main.py"
+ #Install desktop entry
+ cp "dell-g15-ledcontrol.desktop" "$pkgdir/usr/share/applications/dell-g15-ledcontrol.desktop"
+
+# make DESTDIR="$pkgdir/" install
+}