summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2021-08-10 22:29:25 -0500
committerHurricanePootis2021-08-10 22:29:25 -0500
commita2014e195068f6bfd06b71d415994f8fdf722803 (patch)
tree7216420dc54ac0981b05993f1adac345ba7a3a26
parente9e4519ae6b8fdb93357efd366193fa806ed226d (diff)
downloadaur-a2014e195068f6bfd06b71d415994f8fdf722803.tar.gz
Updated build process, actually has license file with package now thanks to micwoj92
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c65fb89993a..dfabec1d6d51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,8 @@ pkgbase = dell-h825cdw-s2825cdn
url = https://www.dell.com/support/home/en-us/product-support/product/dell-h825cdw-printer/drivers
arch = x86_64
license = Dell Software License Agreement
- makedepends = unzip
depends = cups
- noextract = Printer_H825cdw_Driver_Dell_A00_Linux.zip
source = https://dl.dell.com/FOLDER03385341M/1/Printer_H825cdw_Driver_Dell_A00_Linux.zip
sha256sums = e993d3ebbcbfa7dfa7f74d00096bab57bafbdb4b9415f5b69169cd7485a1b18c
pkgname = dell-h825cdw-s2825cdn
-
diff --git a/PKGBUILD b/PKGBUILD
index 5c5800804b07..6c371efce87d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,23 @@ pkgdesc="Proprietary driver for Dell's H825cdw and S2825 Printers"
arch=('x86_64')
url="https://www.dell.com/support/home/en-us/product-support/product/dell-h825cdw-printer/drivers"
license=('Dell Software License Agreement')
-makedepends=('unzip')
depends=('cups')
source=('https://dl.dell.com/FOLDER03385341M/1/Printer_H825cdw_Driver_Dell_A00_Linux.zip')
sha256sums=('e993d3ebbcbfa7dfa7f74d00096bab57bafbdb4b9415f5b69169cd7485a1b18c')
-noextract=("${source[@]##*/}")
_rpmfile="S2825cdn-H825cdw/Dell-Color-MFP-S2825cdn-H825cdw-${pkgver//_/-}.$CARCH.rpm"
prepare() {
cd "$srcdir/"
- unzip "${source[@]##*/}" "$_rpmfile"
bsdtar -f $_rpmfile -x
}
package() {
- mkdir -p $pkgdir/usr/share/cups/model && mkdir -p $pkgdir/usr/lib/cups/filter/Dell-Color-MFP-S2825cdn-H825cdw
- install -D -m 644 $srcdir/usr/share/cups/model/Dell/Dell_Color_MFP_S2825cdn.ppd.gz $pkgdir/usr/share/cups/model/Dell/Dell_Color_MFP_S2825cdn.ppd.gz
- install -D -m 644 $srcdir/usr/share/cups/model/Dell/Dell_Color_MFP_H825cdw.ppd.gz $pkgdir/usr/share/cups/model/Dell/Dell_Color_MFP_H825cdw.ppd.gz
- install -D -m 755 $srcdir/usr/lib/cups/filter/Dell-Color-MFP-S2825cdn-H825cdw/DellSecureFilter $pkgdir/usr/lib/cups/filter/Dell-Color-MFP-S2825cdn-H825cdw/DellSecureFilter
+ mkdir -p "$pkgdir"/usr/share/cups/model && mkdir -p "$pkgdir"/usr/lib/cups/filter/Dell-Color-MFP-S2825cdn-H825cdw
+ install -D -m 644 "$srcdir"/usr/share/cups/model/Dell/Dell_Color_MFP_S2825cdn.ppd.gz "$pkgdir"/usr/share/cups/model/Dell/Dell_Color_MFP_S2825cdn.ppd.gz
+ install -D -m 644 "$srcdir"/usr/share/cups/model/Dell/Dell_Color_MFP_H825cdw.ppd.gz "$pkgdir"/usr/share/cups/model/Dell/Dell_Color_MFP_H825cdw.ppd.gz
+ install -D -m 755 "$srcdir"/usr/lib/cups/filter/Dell-Color-MFP-S2825cdn-H825cdw/DellSecureFilter "$pkgdir"/usr/lib/cups/filter/Dell-Color-MFP-S2825cdn-H825cdw/DellSecureFilter
+ install -D -m 644 "$srcdir"/S2825cdn-H825cdw/License/English/License.txt "$pkgdir"/usr/share/licenses/"$pkgname"/License.txt
}