summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2019-06-27 12:00:15 +0200
committerHaochen Tong2019-06-27 12:00:15 +0200
commit1a4e692dc1d37987365c105213a1ba8e57a3ba3c (patch)
treee875b27d6e7dd0ad2c6184742202a5894d968f5d
downloadaur-1a4e692dc1d37987365c105213a1ba8e57a3ba3c.tar.gz
newpkg
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1cdd02ad558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dellfan-git
+ pkgdesc = User space utility to control the fan speed on Dell Laptops
+ pkgver = r2.fe2ec69
+ pkgrel = 1
+ url = https://github.com/clopez/dellfan
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = git+https://github.com/clopez/dellfan.git
+ sha256sums = SKIP
+
+pkgname = dellfan-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..847c3e9b99f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: hexchain <i at hexchain dot org>
+
+pkgname=dellfan-git
+_repo=dellfan
+url="https://github.com/clopez/dellfan"
+pkgver=r2.fe2ec69
+pkgrel=1
+arch=('x86_64')
+pkgdesc="User space utility to control the fan speed on Dell Laptops"
+license=('GPL2')
+depends=('glibc')
+source=("git+https://github.com/clopez/dellfan.git")
+
+pkgver() {
+ cd "$_repo"
+ ( set -o pipefail; git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)";
+ )
+}
+
+build() {
+ cd "$srcdir/$_repo"
+ make
+}
+
+package() {
+ cd "$srcdir/$_repo"
+ install -Dm755 dellfan "$pkgdir/usr/bin/dellfan"
+}
+sha256sums=('SKIP')