aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2017-02-26 16:55:54 +1100
committerJP-Ellis2017-02-26 21:06:11 +1100
commit56e101b5e8b1bf3bf5c72b5436940b18e78a681a (patch)
treeee235caae13d46b63630e99e133f45b391f39eeb
parentfccefe5040b1ea1afce3a64a17d778fd4e9231b7 (diff)
downloadaur-56e101b5e8b1bf3bf5c72b5436940b18e78a681a.tar.gz
Consolidate patches
The patches are brought forward from upstream and fix various small issues with the installation through CMake. Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO8
-rw-r--r--0f5bf9d.patch85
-rw-r--r--781e311.patch21
-rw-r--r--7d83636.patch57
-rw-r--r--PKGBUILD16
-rw-r--r--cmake.patch404
6 files changed, 411 insertions, 180 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf64c23c073..7f2b1d5efe42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,13 +12,9 @@ pkgbase = delphes
depends = root
depends = exrootanalysis
source = https://github.com/delphes/delphes/archive/3.4.0.tar.gz
- source = 0f5bf9d.patch
- source = 7d83636.patch
- source = 781e311.patch
+ source = cmake.patch
sha256sums = 35a11e7c027a4f0523827babce7b496ff660dfabb2e8b94fd8be1da7468ad197
- sha256sums = 502ba71464610b4a76708941cb528bfb30829ebaff6a6b8509304086d13cefea
- sha256sums = 550ed21c707ba71c8df702291b914b00835c44b56118cdc074c31d9a43e7ae6d
- sha256sums = c48fab60b712d7ac3841ebeba4feb8201da3daf73ebcc7103790f088543d39ea
+ sha256sums = bfed1d16f3ca1068f60dd38f9b21958331adb7a66af1f8e2bbafb0f842c9203d
pkgname = delphes
diff --git a/0f5bf9d.patch b/0f5bf9d.patch
deleted file mode 100644
index 68a1be73b1a3..000000000000
--- a/0f5bf9d.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 0f5bf9d9e29b38f680ebcaf979921989a54af915 Mon Sep 17 00:00:00 2001
-From: Joschka Lingemann <joschka.lingemann@cern.ch>
-Date: Wed, 23 Nov 2016 18:02:52 +0100
-Subject: [PATCH] Add missing install targets
-
-- header files for some ExRoot* classes
-- all pcm files generated when ROOT version > 6.x
----
- classes/CMakeLists.txt | 7 +++++++
- display/CMakeLists.txt | 7 +++++++
- external/ExRootAnalysis/CMakeLists.txt | 13 ++++++++++++-
- modules/CMakeLists.txt | 12 +++++++++++-
- 4 files changed, 37 insertions(+), 2 deletions(-)
-
-diff --git a/delphes-3.4.0/classes/CMakeLists.txt b/delphes-3.4.0/classes/CMakeLists.txt
-index fd7fb15..51b353c 100644
---- a/delphes-3.4.0/classes/CMakeLists.txt
-+++ b/delphes-3.4.0/classes/CMakeLists.txt
-@@ -20,3 +20,10 @@ add_library(classes OBJECT ${sources} ClassesDict.cxx)
-
- # install public headers
- install(FILES ${headers} DESTINATION include/classes)
-+
-+# install pcms if they are created
-+if (${ROOT_VERSION} GREATER 6)
-+ install(FILES
-+ ${PROJECT_BINARY_DIR}/classes/libClassesDict_rdict.pcm
-+ DESTINATION lib)
-+endif()
-diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
-index d11b9c6..43d208e 100644
---- a/delphes-3.4.0/display/CMakeLists.txt
-+++ b/delphes-3.4.0/display/CMakeLists.txt
-@@ -11,3 +11,10 @@ list(REMOVE_ITEM headers ${CMAKE_CURRENT_SOURCE_DIR}/DisplayLinkDef.h)
- DELPHES_GENERATE_DICTIONARY(DisplayDict ${headers} LINKDEF DisplayLinkDef.h)
-
- add_library(display OBJECT ${sources} DisplayDict.cxx)
-+
-+# install pcms if they are created
-+if (${ROOT_VERSION} GREATER 6)
-+ install(FILES
-+ ${PROJECT_BINARY_DIR}/external/DisplayDict_rdict.pcm
-+ DESTINATION lib)
-+endif()
-diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-index 6ac4873..6cf2043 100644
---- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-+++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-@@ -12,4 +12,15 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
- add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
-
- # install headers needed by public Delphes headers to include/
--install(FILES ExRootTask.h ExRootConfReader.h DESTINATION include/ExRootAnalysis)
-+install(FILES ExRootTask.h ExRootConfReader.h ExRootTreeWriter.h ExRootTreeBranch.h
-+ DESTINATION include/ExRootAnalysis)
-+
-+# install all LinkDef files into the same folder to ease user environment
-+install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
-+
-+# install pcms if they are created
-+if (${ROOT_VERSION} GREATER 6)
-+ install(FILES
-+ ${PROJECT_BINARY_DIR}/external/ExRootAnalysis/libExRootAnalysisDict_rdict.pcm
-+ DESTINATION lib)
-+endif()
-diff --git a/delphes-3.4.0/modules/CMakeLists.txt b/delphes-3.4.0/modules/CMakeLists.txt
-index 0b0604f..c2d7394 100644
---- a/delphes-3.4.0/modules/CMakeLists.txt
-+++ b/delphes-3.4.0/modules/CMakeLists.txt
-@@ -19,4 +19,14 @@ list(REMOVE_ITEM sources ${CMAKE_CURRENT_SOURCE_DIR}/PileUpMergerPythia8.cc)
- add_library(modules OBJECT ${sources} FastJetDict.cxx ModulesDict.cxx)
-
- # install public headers
--install(FILES Delphes.h DESTINATION include/modules)
-+install(FILES Delphes.h
-+ DESTINATION include/modules
-+)
-+
-+# install pcms if they are created
-+if (${ROOT_VERSION} GREATER 6)
-+ install(FILES
-+ ${PROJECT_BINARY_DIR}/modules/libModulesDict_rdict.pcm
-+ ${PROJECT_BINARY_DIR}/modules/libFastJetDict_rdict.pcm
-+ DESTINATION lib)
-+endif()
diff --git a/781e311.patch b/781e311.patch
deleted file mode 100644
index 0e5bb33c9231..000000000000
--- a/781e311.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 781e31188326232df2e0b57b10da09395d4301a1 Mon Sep 17 00:00:00 2001
-From: Michele Selvaggi <michele.selvaggi@uclouvain.be>
-Date: Thu, 24 Nov 2016 10:52:50 +0100
-Subject: [PATCH] fixed typo in display cmake list
-
----
- display/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
-index 43d208e..b3a9efd 100644
---- a/delphes-3.4.0/display/CMakeLists.txt
-+++ b/delphes-3.4.0/display/CMakeLists.txt
-@@ -15,6 +15,6 @@ add_library(display OBJECT ${sources} DisplayDict.cxx)
- # install pcms if they are created
- if (${ROOT_VERSION} GREATER 6)
- install(FILES
-- ${PROJECT_BINARY_DIR}/external/DisplayDict_rdict.pcm
-+ ${PROJECT_BINARY_DIR}/display/libDisplayDict_rdict.pcm
- DESTINATION lib)
- endif()
diff --git a/7d83636.patch b/7d83636.patch
deleted file mode 100644
index 2846ef245332..000000000000
--- a/7d83636.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 7d8363633177b762d8293d313bd4ce0cbbc397e8 Mon Sep 17 00:00:00 2001
-From: JP-Ellis <josh@jpellis.me>
-Date: Fri, 27 Jan 2017 20:04:35 +1100
-Subject: [PATCH] Include all ExRootAnalysis headers
-
-When the headers are installed by `make install`, they are all installed in:
-```
-$INSTALL_PREFIX/include/ExRootAnalysis
-```
-
-In addition, one include directive has been fixed as per instructions in the
-pull request.
-
-Signed-off-by: JP-Ellis <josh@jpellis.me>
----
- examples/CaloGrid.cpp | 2 +-
- external/ExRootAnalysis/CMakeLists.txt | 14 ++++++++++++--
- 2 files changed, 13 insertions(+), 3 deletions(-)
-
-diff --git a/delphes-3.4.0/examples/CaloGrid.cpp b/delphes-3.4.0/examples/CaloGrid.cpp
-index 5cc15b5..f466fa9 100644
---- a/delphes-3.4.0/examples/CaloGrid.cpp
-+++ b/delphes-3.4.0/examples/CaloGrid.cpp
-@@ -10,7 +10,7 @@
-
- #include "display/Delphes3DGeometry.h"
- #include "classes/DelphesClasses.h"
--#include "external/ExRootAnalysis/ExRootConfReader.h"
-+#include "ExRootAnalysis/ExRootConfReader.h"
-
- #include "TCanvas.h"
- #include "TStyle.h"
-diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-index 6cf2043..ca4bae3 100644
---- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-+++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-@@ -12,8 +12,18 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
- add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
-
- # install headers needed by public Delphes headers to include/
--install(FILES ExRootTask.h ExRootConfReader.h ExRootTreeWriter.h ExRootTreeBranch.h
-- DESTINATION include/ExRootAnalysis)
-+install(FILES
-+ ExRootClassifier.h
-+ ExRootConfReader.h
-+ ExRootFilter.h
-+ ExRootProgressBar.h
-+ ExRootResult.h
-+ ExRootTask.h
-+ ExRootTreeBranch.h
-+ ExRootTreeReader.h
-+ ExRootTreeWriter.h
-+ ExRootUtilities.h
-+ DESTINATION include/ExRootAnalysis)
-
- # install all LinkDef files into the same folder to ease user environment
- install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
diff --git a/PKGBUILD b/PKGBUILD
index 3de78b42ede7..84e6750e5bbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,18 +11,12 @@ depends=("cmake"
"root"
"exrootanalysis")
source=("https://github.com/delphes/delphes/archive/${pkgver}.tar.gz"
- "0f5bf9d.patch"
- "7d83636.patch"
- "781e311.patch")
+ "cmake.patch")
sha256sums=('35a11e7c027a4f0523827babce7b496ff660dfabb2e8b94fd8be1da7468ad197'
- '502ba71464610b4a76708941cb528bfb30829ebaff6a6b8509304086d13cefea'
- '550ed21c707ba71c8df702291b914b00835c44b56118cdc074c31d9a43e7ae6d'
- 'c48fab60b712d7ac3841ebeba4feb8201da3daf73ebcc7103790f088543d39ea')
+ 'bfed1d16f3ca1068f60dd38f9b21958331adb7a66af1f8e2bbafb0f842c9203d')
prepare() {
- patch -p 1 < 0f5bf9d.patch
- patch -p 1 < 781e311.patch
- patch -p 1 < 7d83636.patch
+ patch -p 1 < cmake.patch
}
build() {
@@ -37,9 +31,9 @@ package() {
rm -rf "${pkgdir}/usr/include/ExRootAnalysis"
rm "${pkgdir}/usr/lib/libExRootAnalysisDict_rdict.pcm"
- msg2 "Moving examples"
+ msg2 "Moving examples and cards"
mkdir -p "${pkgdir}/usr/share/Delphes"
- mv "${pkgdir}/usr/examples" "${pkgdir}/usr/share/Delphes/"
+ mv "${pkgdir}/usr/examples" "${pkgdir}/usr/cards" "${pkgdir}/usr/share/Delphes/"
}
# Local Variables:
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..9630f8c486a6
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,404 @@
+From 0f5bf9d9e29b38f680ebcaf979921989a54af915 Mon Sep 17 00:00:00 2001
+From: Joschka Lingemann <joschka.lingemann@cern.ch>
+Date: Wed, 23 Nov 2016 18:02:52 +0100
+Subject: [PATCH 03/31] Add missing install targets
+
+- header files for some ExRoot* classes
+- all pcm files generated when ROOT version > 6.x
+---
+ classes/CMakeLists.txt | 7 +++++++
+ display/CMakeLists.txt | 7 +++++++
+ external/ExRootAnalysis/CMakeLists.txt | 13 ++++++++++++-
+ modules/CMakeLists.txt | 12 +++++++++++-
+ 4 files changed, 37 insertions(+), 2 deletions(-)
+
+diff --git a/delphes-3.4.0/classes/CMakeLists.txt b/delphes-3.4.0/classes/CMakeLists.txt
+index fd7fb15..51b353c 100644
+--- a/delphes-3.4.0/classes/CMakeLists.txt
++++ b/delphes-3.4.0/classes/CMakeLists.txt
+@@ -20,3 +20,10 @@ add_library(classes OBJECT ${sources} ClassesDict.cxx)
+
+ # install public headers
+ install(FILES ${headers} DESTINATION include/classes)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/classes/libClassesDict_rdict.pcm
++ DESTINATION lib)
++endif()
+diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
+index d11b9c6..43d208e 100644
+--- a/delphes-3.4.0/display/CMakeLists.txt
++++ b/delphes-3.4.0/display/CMakeLists.txt
+@@ -11,3 +11,10 @@ list(REMOVE_ITEM headers ${CMAKE_CURRENT_SOURCE_DIR}/DisplayLinkDef.h)
+ DELPHES_GENERATE_DICTIONARY(DisplayDict ${headers} LINKDEF DisplayLinkDef.h)
+
+ add_library(display OBJECT ${sources} DisplayDict.cxx)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/external/DisplayDict_rdict.pcm
++ DESTINATION lib)
++endif()
+diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+index 6ac4873..6cf2043 100644
+--- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
++++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+@@ -12,4 +12,15 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
+ add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
+
+ # install headers needed by public Delphes headers to include/
+-install(FILES ExRootTask.h ExRootConfReader.h DESTINATION include/ExRootAnalysis)
++install(FILES ExRootTask.h ExRootConfReader.h ExRootTreeWriter.h ExRootTreeBranch.h
++ DESTINATION include/ExRootAnalysis)
++
++# install all LinkDef files into the same folder to ease user environment
++install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/external/ExRootAnalysis/libExRootAnalysisDict_rdict.pcm
++ DESTINATION lib)
++endif()
+diff --git a/delphes-3.4.0/modules/CMakeLists.txt b/delphes-3.4.0/modules/CMakeLists.txt
+index 0b0604f..c2d7394 100644
+--- a/delphes-3.4.0/modules/CMakeLists.txt
++++ b/delphes-3.4.0/modules/CMakeLists.txt
+@@ -19,4 +19,14 @@ list(REMOVE_ITEM sources ${CMAKE_CURRENT_SOURCE_DIR}/PileUpMergerPythia8.cc)
+ add_library(modules OBJECT ${sources} FastJetDict.cxx ModulesDict.cxx)
+
+ # install public headers
+-install(FILES Delphes.h DESTINATION include/modules)
++install(FILES Delphes.h
++ DESTINATION include/modules
++)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/modules/libModulesDict_rdict.pcm
++ ${PROJECT_BINARY_DIR}/modules/libFastJetDict_rdict.pcm
++ DESTINATION lib)
++endif()
+--
+2.11.1
+
+From 781e31188326232df2e0b57b10da09395d4301a1 Mon Sep 17 00:00:00 2001
+From: Michele Selvaggi <michele.selvaggi@uclouvain.be>
+Date: Thu, 24 Nov 2016 10:52:50 +0100
+Subject: [PATCH 04/31] fixed typo in display cmake list
+
+---
+ display/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
+index 43d208e..b3a9efd 100644
+--- a/delphes-3.4.0/display/CMakeLists.txt
++++ b/delphes-3.4.0/display/CMakeLists.txt
+@@ -15,6 +15,6 @@ add_library(display OBJECT ${sources} DisplayDict.cxx)
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+ install(FILES
+- ${PROJECT_BINARY_DIR}/external/DisplayDict_rdict.pcm
++ ${PROJECT_BINARY_DIR}/display/libDisplayDict_rdict.pcm
+ DESTINATION lib)
+ endif()
+--
+2.11.1
+
+From 764f536462b646fdd0f033cc71c2b1539df6296a Mon Sep 17 00:00:00 2001
+From: Michele Selvaggi <michele.selvaggi@uclouvain.be>
+Date: Thu, 24 Nov 2016 10:53:49 +0100
+Subject: [PATCH 05/31] added cards to installation with cmake
+
+---
+ CMakeLists.txt | 1 +
+ cards/CMakeLists.txt | 8 ++++++++
+ 2 files changed, 9 insertions(+)
+ create mode 100644 cards/CMakeLists.txt
+
+diff --git a/delphes-3.4.0/CMakeLists.txt b/delphes-3.4.0/CMakeLists.txt
+index 5429d0f..904f6c6 100644
+--- a/delphes-3.4.0/CMakeLists.txt
++++ b/delphes-3.4.0/CMakeLists.txt
+@@ -31,6 +31,7 @@ add_subdirectory(examples)
+ add_subdirectory(external)
+ add_subdirectory(modules)
+ add_subdirectory(readers)
++add_subdirectory(cards)
+
+ add_library(Delphes SHARED
+ $<TARGET_OBJECTS:classes>
+diff --git a/delphes-3.4.0/cards/CMakeLists.txt b/delphes-3.4.0/cards/CMakeLists.txt
+new file mode 100644
+index 0000000..0af8376
+--- /dev/null
++++ b/delphes-3.4.0/cards/CMakeLists.txt
+@@ -0,0 +1,8 @@
++file(GLOB confDir *.tcl)
++file(GLOB confFccDir FCC/*.tcl)
++file(GLOB confCmsPhase2Dir CMS_PhaseII/*.tcl)
++
++# copy *.tcl files into cards
++install(FILES ${confDir} DESTINATION cards)
++install(FILES ${confFccDir} DESTINATION cards/FCC)
++install(FILES ${confCmsPhase2Dir} DESTINATION cards/CMS_PhaseII)
+--
+2.11.1
+
+From 7d8363633177b762d8293d313bd4ce0cbbc397e8 Mon Sep 17 00:00:00 2001
+From: JP-Ellis <josh@jpellis.me>
+Date: Fri, 27 Jan 2017 20:04:35 +1100
+Subject: [PATCH 23/31] Include all ExRootAnalysis headers
+
+When the headers are installed by `make install`, they are all installed in:
+```
+$INSTALL_PREFIX/include/ExRootAnalysis
+```
+
+In addition, one include directive has been fixed as per instructions in the
+pull request.
+
+Signed-off-by: JP-Ellis <josh@jpellis.me>
+---
+ examples/CaloGrid.cpp | 2 +-
+ external/ExRootAnalysis/CMakeLists.txt | 14 ++++++++++++--
+ 2 files changed, 13 insertions(+), 3 deletions(-)
+
+diff --git a/delphes-3.4.0/examples/CaloGrid.cpp b/delphes-3.4.0/examples/CaloGrid.cpp
+index 5cc15b5..f466fa9 100644
+--- a/delphes-3.4.0/examples/CaloGrid.cpp
++++ b/delphes-3.4.0/examples/CaloGrid.cpp
+@@ -10,7 +10,7 @@
+
+ #include "display/Delphes3DGeometry.h"
+ #include "classes/DelphesClasses.h"
+-#include "external/ExRootAnalysis/ExRootConfReader.h"
++#include "ExRootAnalysis/ExRootConfReader.h"
+
+ #include "TCanvas.h"
+ #include "TStyle.h"
+diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+index 6cf2043..ca4bae3 100644
+--- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
++++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+@@ -12,8 +12,18 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
+ add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
+
+ # install headers needed by public Delphes headers to include/
+-install(FILES ExRootTask.h ExRootConfReader.h ExRootTreeWriter.h ExRootTreeBranch.h
+- DESTINATION include/ExRootAnalysis)
++install(FILES
++ ExRootClassifier.h
++ ExRootConfReader.h
++ ExRootFilter.h
++ ExRootProgressBar.h
++ ExRootResult.h
++ ExRootTask.h
++ ExRootTreeBranch.h
++ ExRootTreeReader.h
++ ExRootTreeWriter.h
++ ExRootUtilities.h
++ DESTINATION include/ExRootAnalysis)
+
+ # install all LinkDef files into the same folder to ease user environment
+ install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
+--
+2.11.1
+
+From 8c872c8c104faa08d68022943bee71eae2c18b74 Mon Sep 17 00:00:00 2001
+From: Pavel Demin <pavel-demin@outlook.com>
+Date: Mon, 13 Feb 2017 16:08:08 +0100
+Subject: [PATCH 28/31] remove ExRootAnalysisLinkDef.h from installation and
+ simplify install command
+
+---
+ external/ExRootAnalysis/CMakeLists.txt | 18 ++----------------
+ 1 file changed, 2 insertions(+), 16 deletions(-)
+
+diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+index ca4bae3..2658fe7 100644
+--- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
++++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+@@ -11,22 +11,8 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
+
+ add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
+
+-# install headers needed by public Delphes headers to include/
+-install(FILES
+- ExRootClassifier.h
+- ExRootConfReader.h
+- ExRootFilter.h
+- ExRootProgressBar.h
+- ExRootResult.h
+- ExRootTask.h
+- ExRootTreeBranch.h
+- ExRootTreeReader.h
+- ExRootTreeWriter.h
+- ExRootUtilities.h
+- DESTINATION include/ExRootAnalysis)
+-
+-# install all LinkDef files into the same folder to ease user environment
+-install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
++# install public headers
++install(FILES ${headers} DESTINATION include/ExRootAnalysis)
+
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+--
+2.11.1
+
+From 39e729dc24bbaede8e3f81f1dac65fa01a18a441 Mon Sep 17 00:00:00 2001
+From: Pavel Demin <pavel-demin@outlook.com>
+Date: Mon, 13 Feb 2017 16:10:52 +0100
+Subject: [PATCH 29/31] fix formatting in modules/CMakeLists.txt
+
+---
+ modules/CMakeLists.txt | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/delphes-3.4.0/modules/CMakeLists.txt b/delphes-3.4.0/modules/CMakeLists.txt
+index c2d7394..4ba0fe5 100644
+--- a/delphes-3.4.0/modules/CMakeLists.txt
++++ b/delphes-3.4.0/modules/CMakeLists.txt
+@@ -19,9 +19,7 @@ list(REMOVE_ITEM sources ${CMAKE_CURRENT_SOURCE_DIR}/PileUpMergerPythia8.cc)
+ add_library(modules OBJECT ${sources} FastJetDict.cxx ModulesDict.cxx)
+
+ # install public headers
+-install(FILES Delphes.h
+- DESTINATION include/modules
+-)
++install(FILES Delphes.h DESTINATION include/modules)
+
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+--
+2.11.1
+
+From 102596aa0a166e071b5697caa104a865d6818ec9 Mon Sep 17 00:00:00 2001
+From: Pavel Demin <pavel-demin@outlook.com>
+Date: Mon, 13 Feb 2017 16:11:04 +0100
+Subject: [PATCH 30/31] add DelphesDisplay target to CMakeLists.txt
+
+---
+ CMakeLists.txt | 15 +++++++++++++--
+ display/CMakeLists.txt | 6 ++++++
+ 2 files changed, 19 insertions(+), 2 deletions(-)
+
+diff --git a/delphes-3.4.0/CMakeLists.txt b/delphes-3.4.0/CMakeLists.txt
+index 904f6c6..d3e26ce 100644
+--- a/delphes-3.4.0/CMakeLists.txt
++++ b/delphes-3.4.0/CMakeLists.txt
+@@ -35,7 +35,6 @@ add_subdirectory(cards)
+
+ add_library(Delphes SHARED
+ $<TARGET_OBJECTS:classes>
+- $<TARGET_OBJECTS:display>
+ $<TARGET_OBJECTS:modules>
+ $<TARGET_OBJECTS:ExRootAnalysis>
+ $<TARGET_OBJECTS:fastjet>
+@@ -44,6 +43,18 @@ add_library(Delphes SHARED
+ $<TARGET_OBJECTS:PUPPI>
+ )
+
++add_library(DelphesDisplay SHARED
++ $<TARGET_OBJECTS:classes>
++ $<TARGET_OBJECTS:display>
++ $<TARGET_OBJECTS:modules>
++ $<TARGET_OBJECTS:ExRootAnalysis>
++ $<TARGET_OBJECTS:fastjet>
++ $<TARGET_OBJECTS:tcl>
++ $<TARGET_OBJECTS:Hector>
++ $<TARGET_OBJECTS:PUPPI>
++)
++
+ target_link_Libraries(Delphes ${ROOT_LIBRARIES} ${ROOT_COMPONENT_LIBRARIES})
++target_link_Libraries(DelphesDisplay ${ROOT_LIBRARIES} ${ROOT_COMPONENT_LIBRARIES})
+
+-install(TARGETS Delphes DESTINATION lib)
++install(TARGETS Delphes DelphesDisplay DESTINATION lib)
+diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
+index b3a9efd..4886a1c 100644
+--- a/delphes-3.4.0/display/CMakeLists.txt
++++ b/delphes-3.4.0/display/CMakeLists.txt
+@@ -12,6 +12,12 @@ DELPHES_GENERATE_DICTIONARY(DisplayDict ${headers} LINKDEF DisplayLinkDef.h)
+
+ add_library(display OBJECT ${sources} DisplayDict.cxx)
+
++# install public headers
++install(FILES
++ Delphes3DGeometry.h
++ DelphesEventDisplay.h
++DESTINATION include/display)
++
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+ install(FILES
+--
+2.11.1
+
+From 9259bfea9820e3d83c7984014f5dc652aa61b05f Mon Sep 17 00:00:00 2001
+From: Pavel Demin <pavel-demin@outlook.com>
+Date: Tue, 14 Feb 2017 09:13:54 +0100
+Subject: [PATCH 31/31] install headers required by libDelphes and
+ libDelphesDisplay
+
+---
+ display/CMakeLists.txt | 7 ++-----
+ external/ExRootAnalysis/CMakeLists.txt | 2 +-
+ modules/CMakeLists.txt | 4 ++--
+ 3 files changed, 5 insertions(+), 8 deletions(-)
+
+diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
+index 4886a1c..30fc7f9 100644
+--- a/delphes-3.4.0/display/CMakeLists.txt
++++ b/delphes-3.4.0/display/CMakeLists.txt
+@@ -12,11 +12,8 @@ DELPHES_GENERATE_DICTIONARY(DisplayDict ${headers} LINKDEF DisplayLinkDef.h)
+
+ add_library(display OBJECT ${sources} DisplayDict.cxx)
+
+-# install public headers
+-install(FILES
+- Delphes3DGeometry.h
+- DelphesEventDisplay.h
+-DESTINATION include/display)
++# install headers
++install(FILES ${headers} DESTINATION include/display)
+
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+index 2658fe7..cdd325a 100644
+--- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
++++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+@@ -11,7 +11,7 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
+
+ add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
+
+-# install public headers
++# install headers
+ install(FILES ${headers} DESTINATION include/ExRootAnalysis)
+
+ # install pcms if they are created
+diff --git a/delphes-3.4.0/modules/CMakeLists.txt b/delphes-3.4.0/modules/CMakeLists.txt
+index 4ba0fe5..9482b8a 100644
+--- a/delphes-3.4.0/modules/CMakeLists.txt
++++ b/delphes-3.4.0/modules/CMakeLists.txt
+@@ -18,8 +18,8 @@ list(REMOVE_ITEM sources ${CMAKE_CURRENT_SOURCE_DIR}/PileUpMergerPythia8.cc)
+
+ add_library(modules OBJECT ${sources} FastJetDict.cxx ModulesDict.cxx)
+
+-# install public headers
+-install(FILES Delphes.h DESTINATION include/modules)
++# install headers
++install(FILES ${headers} DESTINATION include/modules)
+
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+--
+2.11.1
+