aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2017-01-27 21:39:39 +1100
committerJP-Ellis2017-01-27 21:57:08 +1100
commitee2f94257d583a103366b992102fca7440126813 (patch)
tree8a60da2019cd8a353fd567e3f519a6df32814c8e
parent8343c2fd012fcad1043558baafd114a072c0a1fe (diff)
downloadaur-ee2f94257d583a103366b992102fca7440126813.tar.gz
Bring forward commits from next release to fix headers and pcm files
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO12
-rw-r--r--0f5bf9d.patch85
-rw-r--r--781e311.patch21
-rw-r--r--7d83636.patch57
-rw-r--r--ExRootAnalysis.patch20
-rw-r--r--PKGBUILD14
6 files changed, 181 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b58de076c05..cf2a4928e694 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 27 01:09:13 UTC 2017
+# Fri Jan 27 10:56:04 UTC 2017
pkgbase = delphes
pkgdesc = A framework for fast simulation of a generic collider experiment
pkgver = 3.4.0
- pkgrel = 2
+ pkgrel = 3
url = http://cp3.irmp.ucl.ac.be/projects/delphes
arch = i686
arch = x86_64
@@ -11,9 +11,13 @@ pkgbase = delphes
depends = cmake
depends = root
source = https://github.com/delphes/delphes/archive/3.4.0.tar.gz
- source = ExRootAnalysis.patch
+ source = 0f5bf9d.patch
+ source = 7d83636.patch
+ source = 781e311.patch
sha256sums = 35a11e7c027a4f0523827babce7b496ff660dfabb2e8b94fd8be1da7468ad197
- sha256sums = be6fc8df9c89d2b7a14ce8f01b9848ec13eec63aece31d51939baa90d89ba60f
+ sha256sums = 502ba71464610b4a76708941cb528bfb30829ebaff6a6b8509304086d13cefea
+ sha256sums = 550ed21c707ba71c8df702291b914b00835c44b56118cdc074c31d9a43e7ae6d
+ sha256sums = c48fab60b712d7ac3841ebeba4feb8201da3daf73ebcc7103790f088543d39ea
pkgname = delphes
diff --git a/0f5bf9d.patch b/0f5bf9d.patch
new file mode 100644
index 000000000000..68a1be73b1a3
--- /dev/null
+++ b/0f5bf9d.patch
@@ -0,0 +1,85 @@
+From 0f5bf9d9e29b38f680ebcaf979921989a54af915 Mon Sep 17 00:00:00 2001
+From: Joschka Lingemann <joschka.lingemann@cern.ch>
+Date: Wed, 23 Nov 2016 18:02:52 +0100
+Subject: [PATCH] Add missing install targets
+
+- header files for some ExRoot* classes
+- all pcm files generated when ROOT version > 6.x
+---
+ classes/CMakeLists.txt | 7 +++++++
+ display/CMakeLists.txt | 7 +++++++
+ external/ExRootAnalysis/CMakeLists.txt | 13 ++++++++++++-
+ modules/CMakeLists.txt | 12 +++++++++++-
+ 4 files changed, 37 insertions(+), 2 deletions(-)
+
+diff --git a/delphes-3.4.0/classes/CMakeLists.txt b/delphes-3.4.0/classes/CMakeLists.txt
+index fd7fb15..51b353c 100644
+--- a/delphes-3.4.0/classes/CMakeLists.txt
++++ b/delphes-3.4.0/classes/CMakeLists.txt
+@@ -20,3 +20,10 @@ add_library(classes OBJECT ${sources} ClassesDict.cxx)
+
+ # install public headers
+ install(FILES ${headers} DESTINATION include/classes)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/classes/libClassesDict_rdict.pcm
++ DESTINATION lib)
++endif()
+diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
+index d11b9c6..43d208e 100644
+--- a/delphes-3.4.0/display/CMakeLists.txt
++++ b/delphes-3.4.0/display/CMakeLists.txt
+@@ -11,3 +11,10 @@ list(REMOVE_ITEM headers ${CMAKE_CURRENT_SOURCE_DIR}/DisplayLinkDef.h)
+ DELPHES_GENERATE_DICTIONARY(DisplayDict ${headers} LINKDEF DisplayLinkDef.h)
+
+ add_library(display OBJECT ${sources} DisplayDict.cxx)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/external/DisplayDict_rdict.pcm
++ DESTINATION lib)
++endif()
+diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+index 6ac4873..6cf2043 100644
+--- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
++++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+@@ -12,4 +12,15 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
+ add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
+
+ # install headers needed by public Delphes headers to include/
+-install(FILES ExRootTask.h ExRootConfReader.h DESTINATION include/ExRootAnalysis)
++install(FILES ExRootTask.h ExRootConfReader.h ExRootTreeWriter.h ExRootTreeBranch.h
++ DESTINATION include/ExRootAnalysis)
++
++# install all LinkDef files into the same folder to ease user environment
++install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/external/ExRootAnalysis/libExRootAnalysisDict_rdict.pcm
++ DESTINATION lib)
++endif()
+diff --git a/delphes-3.4.0/modules/CMakeLists.txt b/delphes-3.4.0/modules/CMakeLists.txt
+index 0b0604f..c2d7394 100644
+--- a/delphes-3.4.0/modules/CMakeLists.txt
++++ b/delphes-3.4.0/modules/CMakeLists.txt
+@@ -19,4 +19,14 @@ list(REMOVE_ITEM sources ${CMAKE_CURRENT_SOURCE_DIR}/PileUpMergerPythia8.cc)
+ add_library(modules OBJECT ${sources} FastJetDict.cxx ModulesDict.cxx)
+
+ # install public headers
+-install(FILES Delphes.h DESTINATION include/modules)
++install(FILES Delphes.h
++ DESTINATION include/modules
++)
++
++# install pcms if they are created
++if (${ROOT_VERSION} GREATER 6)
++ install(FILES
++ ${PROJECT_BINARY_DIR}/modules/libModulesDict_rdict.pcm
++ ${PROJECT_BINARY_DIR}/modules/libFastJetDict_rdict.pcm
++ DESTINATION lib)
++endif()
diff --git a/781e311.patch b/781e311.patch
new file mode 100644
index 000000000000..0e5bb33c9231
--- /dev/null
+++ b/781e311.patch
@@ -0,0 +1,21 @@
+From 781e31188326232df2e0b57b10da09395d4301a1 Mon Sep 17 00:00:00 2001
+From: Michele Selvaggi <michele.selvaggi@uclouvain.be>
+Date: Thu, 24 Nov 2016 10:52:50 +0100
+Subject: [PATCH] fixed typo in display cmake list
+
+---
+ display/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/delphes-3.4.0/display/CMakeLists.txt b/delphes-3.4.0/display/CMakeLists.txt
+index 43d208e..b3a9efd 100644
+--- a/delphes-3.4.0/display/CMakeLists.txt
++++ b/delphes-3.4.0/display/CMakeLists.txt
+@@ -15,6 +15,6 @@ add_library(display OBJECT ${sources} DisplayDict.cxx)
+ # install pcms if they are created
+ if (${ROOT_VERSION} GREATER 6)
+ install(FILES
+- ${PROJECT_BINARY_DIR}/external/DisplayDict_rdict.pcm
++ ${PROJECT_BINARY_DIR}/display/libDisplayDict_rdict.pcm
+ DESTINATION lib)
+ endif()
diff --git a/7d83636.patch b/7d83636.patch
new file mode 100644
index 000000000000..2846ef245332
--- /dev/null
+++ b/7d83636.patch
@@ -0,0 +1,57 @@
+From 7d8363633177b762d8293d313bd4ce0cbbc397e8 Mon Sep 17 00:00:00 2001
+From: JP-Ellis <josh@jpellis.me>
+Date: Fri, 27 Jan 2017 20:04:35 +1100
+Subject: [PATCH] Include all ExRootAnalysis headers
+
+When the headers are installed by `make install`, they are all installed in:
+```
+$INSTALL_PREFIX/include/ExRootAnalysis
+```
+
+In addition, one include directive has been fixed as per instructions in the
+pull request.
+
+Signed-off-by: JP-Ellis <josh@jpellis.me>
+---
+ examples/CaloGrid.cpp | 2 +-
+ external/ExRootAnalysis/CMakeLists.txt | 14 ++++++++++++--
+ 2 files changed, 13 insertions(+), 3 deletions(-)
+
+diff --git a/delphes-3.4.0/examples/CaloGrid.cpp b/delphes-3.4.0/examples/CaloGrid.cpp
+index 5cc15b5..f466fa9 100644
+--- a/delphes-3.4.0/examples/CaloGrid.cpp
++++ b/delphes-3.4.0/examples/CaloGrid.cpp
+@@ -10,7 +10,7 @@
+
+ #include "display/Delphes3DGeometry.h"
+ #include "classes/DelphesClasses.h"
+-#include "external/ExRootAnalysis/ExRootConfReader.h"
++#include "ExRootAnalysis/ExRootConfReader.h"
+
+ #include "TCanvas.h"
+ #include "TStyle.h"
+diff --git a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+index 6cf2043..ca4bae3 100644
+--- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
++++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
+@@ -12,8 +12,18 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
+ add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
+
+ # install headers needed by public Delphes headers to include/
+-install(FILES ExRootTask.h ExRootConfReader.h ExRootTreeWriter.h ExRootTreeBranch.h
+- DESTINATION include/ExRootAnalysis)
++install(FILES
++ ExRootClassifier.h
++ ExRootConfReader.h
++ ExRootFilter.h
++ ExRootProgressBar.h
++ ExRootResult.h
++ ExRootTask.h
++ ExRootTreeBranch.h
++ ExRootTreeReader.h
++ ExRootTreeWriter.h
++ ExRootUtilities.h
++ DESTINATION include/ExRootAnalysis)
+
+ # install all LinkDef files into the same folder to ease user environment
+ install(FILES ExRootAnalysisLinkDef.h DESTINATION include)
diff --git a/ExRootAnalysis.patch b/ExRootAnalysis.patch
deleted file mode 100644
index 7ae6a7f1d804..000000000000
--- a/ExRootAnalysis.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-+++ b/delphes-3.4.0/external/ExRootAnalysis/CMakeLists.txt
-@@ -12,4 +12,16 @@ DELPHES_GENERATE_DICTIONARY(ExRootAnalysisDict ${headers} LINKDEF ExRootAnalysis
- add_library(ExRootAnalysis OBJECT ${sources} ExRootAnalysisDict.cxx)
-
- # install headers needed by public Delphes headers to include/
--install(FILES ExRootTask.h ExRootConfReader.h DESTINATION include/ExRootAnalysis)
-+install(FILES
-+ ExRootAnalysisLinkDef.h
-+ ExRootClassifier.h
-+ ExRootConfReader.h
-+ ExRootFilter.h
-+ ExRootProgressBar.h
-+ ExRootResult.h
-+ ExRootTask.h
-+ ExRootTreeBranch.h
-+ ExRootTreeReader.h
-+ ExRootTreeWriter.h
-+ ExRootUtilities.h
-+ DESTINATION include/ExRootAnalysis)
diff --git a/PKGBUILD b/PKGBUILD
index 28bba7269cd6..c8b2310d90ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=delphes
pkgver=3.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="A framework for fast simulation of a generic collider experiment"
url="http://cp3.irmp.ucl.ac.be/projects/delphes"
arch=('i686' 'x86_64')
@@ -10,12 +10,18 @@ license=('GPLv3')
depends=("cmake"
"root")
source=("https://github.com/delphes/delphes/archive/${pkgver}.tar.gz"
- "ExRootAnalysis.patch")
+ "0f5bf9d.patch"
+ "7d83636.patch"
+ "781e311.patch")
sha256sums=('35a11e7c027a4f0523827babce7b496ff660dfabb2e8b94fd8be1da7468ad197'
- 'be6fc8df9c89d2b7a14ce8f01b9848ec13eec63aece31d51939baa90d89ba60f')
+ '502ba71464610b4a76708941cb528bfb30829ebaff6a6b8509304086d13cefea'
+ '550ed21c707ba71c8df702291b914b00835c44b56118cdc074c31d9a43e7ae6d'
+ 'c48fab60b712d7ac3841ebeba4feb8201da3daf73ebcc7103790f088543d39ea')
prepare() {
- patch -p 1 < ExRootAnalysis.patch
+ patch -p 1 < 0f5bf9d.patch
+ patch -p 1 < 781e311.patch
+ patch -p 1 < 7d83636.patch
}
build() {